Outdoor Sirens for UK? (2018)

project_security

(Ahmed) #102

Thanks, I will try and exclude, reset and re-pair. Is there a easy way to tell if it is being included as a secure device or insecure? Because if I pair it, I have to then go through this process to see the log to see if it’s secure


(Robin) #103

I think if you have live logging running during inclusion you’ll see a log line telling you if it’s secure or not.

Your siren is obviously latching onto a repeater somewhere instead of a direct connection to the hub… that’s what prevents secure inclusion and is why you have to get very close to the hub.


(Ahmed) #104

I don’t know what I am doing wrong but I think maybe something seriously wrong in the way I am pairing it as I can never 100% always get it to work. I’ve removed it and now stuck again trying to add it. I reset as per the instructions. and the few times that I was able to successfully add it was when I just randomly pressed the small button in the small circle instead of the tamper switch. I could never get it to pair with the tamper switch.


(Robin) #105

The manual says either tamper button or circle button can be used to add, exclude or reset the siren.

If you’re having most luck with circle button, stick with that.

3 fast presses.


(Ahmed) #106

Struggling to get it to pair now. In live logging when I put it in Add A Thing and then press 3 times quickly on the siren I get this message:

10:40:08 PM: debug Parsed 'zw device: 21, command: 9881, payload: 00 20 03 00 ' to [['name':'switch', 'value':'off', 'displayed':false, 'isStateChange':true, 'linkText':'Dlink DCH-Z510', 'descriptionText':Dlink DCH-Z510 switch is off], ['name':'alarm', 'value':'off', 'isStateChange':true, 'displayed':true, 'linkText':'Dlink DCH-Z510', 'descriptionText':Dlink DCH-Z510 alarm is off]]
10:40:08 PM: debug Parse returned [['name':'switch', 'value':'off', 'displayed':false, 'isStateChange':true, 'linkText':'Dlink DCH-Z510', 'descriptionText':Dlink DCH-Z510 switch is off], ['name':'alarm', 'value':'off', 'isStateChange':true, 'displayed':true, 'linkText':'Dlink DCH-Z510', 'descriptionText':Dlink DCH-Z510 alarm is off]]
10:40:08 PM: debug rx BasicReport(value: 0)
10:40:08 PM: debug encapsulated: BasicReport(value: 0)
10:40:07 PM: debug No devices to add, verified devices: [:]
10:40:07 PM: debug detecting status for 80ee11c5-86cb-40ca-a409-ad2e2ddd29e0 : true

Any ideas what is going on?


(Ahmed) #107

Also noticed these errors in the Live Logging when I am trying to pair the siren:

debug Parsed 'zw device: 21, command: 5E02, payload: 01 05 00 0F 00 0F 00 ' to null
debug Couldn't zwave.parse 'zw device: 21, command: 5E02, payload: 01 05 00 0F 00 0F 00 '

(Robin) #108

Not sure, but the larger log looks like it’s working and parsing secure commands.

Guess just keep trying… some devices can be a pig to pair, sometimes takes a while to come up on the screen as well so give it a few minutes after each triple press.


(Ahmed) #109

Seems’s really strange, I got to the bottom of the pairing issue. It’s definitely this device handler that isn’t allowing it to pair. I came across a few other threads where people mentioned that they had to remove the device handler in order to repair it. All these errors in the Live Logging keeps referring to the custom device handler. I tried like for a good 30minutes with the same errors all the time. As soon as I remove the device handler and reset the siren and enter pairing mode it pairs instantly. So something not right with the handler. Maybe the newer models of the Siren’s are different perhaps?

Anyway, I found the following custom device handler on this forum by another member who had the exact same problem and he gave up with this device handler and modified the Aeon one to work with the DCH-Z510. I installed this handler and it seems to work great. Below is the link to this alternative handler:

https://pastebin.com/raw/MA0m1yGW


(Robin) #110

very odd but glad it worked out for you!

Maybe you could link to the other thread you found so others can find it in the future (and me if I ever buy another siren)


(Ahmed) #111

Here is the link to the thread:

It’s the post right at the bottom. Just wondering do the sounds sound the same as your device handler or can you make your own tone based on the data?


#112

You can’t “make” your own sounds as they are hardcoded into the Siren itself, however you can play sounds and cut them before they finish to create your own sounds (In a way). Thats what i’m doing with the “Beep Code”

Anyways, i’m glad my hacked-together handler is working for someone else :smiley: . Let me know if you find any bugs!


(Robin) #113

It has a beep command??? Might give it a try myself as the ding dong is a bit crappy!

Wonder why mine works on older handler? Should be an identical device?

Maybe release your handler in a new thread so others can find it easier?


(Ahmed) #114

Yeap I like the beep as I can use it for the disarming countdown rather than a chime.

@knackrack615 Is the handler set to 100% volume? I’m now running one siren for outdoor use on the Standard Aeon handler as I do not need anything other than a super loud siren. The other 2 I am running this custom modified Aeon handler. But for some reason it does seem like the loudness of the siren is lower on this custom handler.

What part of the handler code do you edit to play around with the tones like end it early to create that beep? I want to create different variations of that beep if possible.

@RobinWinbourne how did you get that custom icon to be the tile of the siren? Do you just change the icon with a custom picture?


(Robin) #115

#116

I don’t really see why it wouldn’t be at full volume, i just took the default aeon handler and added the extra sounds, haven’t really touched volume

If you look at line 218 is where i define the "Beep Code"
Basically what i do is play the sound i want then wait for a bit and then send the stop command


(Robin) #117

Hacky but if it works, all good. Guess the beep sounds different each time due to cloud lag variance?

Volume can’t be adjusted on these devices :frowning:


#118

For me the beep code sounds perfectly for like 90% of the time, the rest it just cuts off the last beep

Yeah it looks like the volume is fixed sadly :confused:


(Ahmed) #119

Awesome.

@RobinWinbourne I’ve followed your instructions to install webCoRE, got to the part where I now need to install the smart app on the ST app. I have a few questions, where you have to set a password, this isn’t linked to the webCoRE community account password right? it’s a different one for logging into the web UI? Secondly, when you get to the section where you have to select the Actuators, do you just select everything there? I have all my lights, outlets, sirens etc on there. I assume if adding them will make them available in the webCoRE UI so what happens if I later add more devices how do I add them to WebCoRE?

Also I added the WebCoRE mobile presence. How do I replace the current mobile presence I have to the webCoRE one?


(Robin) #120

No… it’s different, but can be the same if you wish… just needed for logging into the webCoRE dashboard.

I would select everything, anything you select will be made available to webCoRE, anything not selected will be invisible to webcore.

You have to go back into the webocre app and add them.

You have to download the webcore mobile app from the apple App Store or Google Play Store.


(Ahmed) #121

Awesome thanks, some of the devices show up in the actuators and also in sensors. For example all my fibaro dimmers show up in the actuators as well as sensors. Is it ok to just add everything from every category even though its already in the other category?