My ST is not responding to mode changes right now, though hello home says it’s working fine. How can I tell if the problem is local versus an ST outage?

Ugh. Disconnected power to hub, then reconnected. It works now. Annoying, since there’s no way to know in the app if things are okay (unless enabling extra events under Help Us Debug in the support menu would have helped–I’ve turned that on, now). No matter what, tho, if I was away I couldn’t fix it.

Mode changes happen independent of the hub. Modes are changes cloud-side, so if you are attempting to change a mode from the app and its not taking my guess would be an issue with the mobile phone connection. Not sure why rebooting the hub did it :o I wonder if the modes were changing, but nothing was launching because of a hub connectivity issue. You can always tell the hubs status by looking at the LED.

Blinking Blue = Acquiring DHCP Lease
Solid Blue = Opening Connection to cloud
Green = All good

We had a slight uptick in traffic around 5PM EST, but no show stoppers.

I am having issues as well. Even manual commands don’t seem to be working 100%.

Also been having issues as of 8pm - still having issues at 1am. Rebooted hub, no change. Some commands are being issued, but very intermittent - and quite laggy. It seems some devices are worse off than others. One of my kitchen lights turns on, but the other does not (they’re both used identically in every app, etc).

Since others are having the same issue, I’m sure it’s fruitless, but I’m trying a Z-Wave network repair:

  • Log into your hub page: https://graph.api.smartthings.com/hub/
  • Click on the hub you want to repair
  • Scroll down to “Utilities” and click “View Utilities”
  • One of the top options should be “Repair Z-Wave network”

I’m not 100% sure this is available on all accounts or all firmware versions, but now that I’m aware of it, I’m more diligent about running it.

Update: IP and zigbee devices appear to be functioning correctly. Z-Wave is pretty much useless right now.

I had about 10-12 seconds of latency much of yesterday evening as well.

@imbrian Unless I missed something, that Z-Wave Repair feature is still just a button that doesn’t actually do anything.

Same thing happened to me yesterday around 5PM PST. My aqurium lights were not on, did the manual on/off for my things with no response. The ST app shows the changes but not the physical device. A reboot of the hub fixed it for me also. This brings me back to a question I asked a while back, should we be rebooting the hub regularly?

If you have to reboot your HUB it is usually a local network issue. Maybe the DHCP address isn’t renewing properly, or it isn’t obtaining one in the event of a power outage because it came up before your router/switch (just a guess). I have given mine a reserved DHCP address. I don’t know if that is why I have never had those type sof issues, but regardless it is never a bad idea to give important devices a dedicated IP.

One of my apps which turns on some lights at dusk, only turned on 2 of the 4 lights. It’s simple things like this that get to me (and my family even more). I wish they’d get the basics rock solid before they add fun things like SONOS integration etc.

@tonyfalcone I had a lot of issues like that when I first started setting up my system and had few devices. I think SmartThings gets blamed a lot for glitches that are due to poor z-wave network coverage rather than the hub not sending out the command. I now have 15 or so switches through the house and can’t remember the last time I had a device flat out not respond to a command.

I still have times of extreme latency however, which is something they need to work on.

I kind of backed off on expanding my system because of the glitches, but maybe I need to do the opposite. Cory when you say you have latency problems, is it usually around 10-15 seconds, or can it be as long as 1/2 an hour?

@tonyfalcone I have had issues where commands seem to get queued up for a device, and then they randomly hit it over the course of half an hour. It’s very rare…but it has happened twice that I can recall for sure. One was for my door lock. It unlocked like it should when we pulled into the driveway, my wife went inside while I checked the mail…then it just locked on me before I got to the door. I thought she was screwing with me, but it looks like a previous lock command randomly hit it.

Then night before last My wife asked me to go into “Movie Mode” which just turns off the lights and apps that turn the lights on with motion (the dogs set them off) The app took almost 20 seconds to turn the lights off, and then one of them came back on about 5 minutes later. I turned it off, then it came on again another 5 minutes later. I turned it off once more and then it finally stuck.

What’s odd about those two occurrences is you’d thing if a queued command just hit it then that must be a command that didn’t make it to it when it was sent. As far as I can tell that’s not the case and these devices responded to all previous commands. It’s almost as if maybe the cloud thought they didn’t receive it and sent it out again, but that’s just speculation.

The times I have had latency longer 60 seconds is usually due to some serious system wide issue going on at ST, which thankfully seems to be a lot less common these days.

Same issue here. My “I’m Home” actions all failed (basically turning on 4 lights - 2 Z-wave and 2 WeMo. I tried resetting the hub, the z-wave repair, etc. Still totally unable to turn anything off or on reliably. Motion sensor seems to be working, tho.

Strange we all experienced similar behavior on the same day around the same time. I too had events not firing and leggy response.


Yes, there was something going on. Happened to me as well.

Is there a smartthings services status page?

I’m also getting double notifications every since the latest iOS update.

I have opened a support case so we will see what comes of it. This is still happening to me.

From Dan in the IRC:

I didn't see anything from our monitoring system - I'm on the list to get emails on things that would indicate an outage.

TechOps says that there’s nothing that shows up in our metrics other than a rather short queue spike at 5pm ET - and we’ve pretty well instrumented the whole pipeline.

For about a week now, I have been seeing all of the issues showing up here.

  • An app I have to turn on 3 lights will only turn on one or two
  • I manually press a switch in the iPhone app, and anywhere between immediately and 10 min, the light will come on or go off
  • “Home” and “Away” actions not occurring (or random subset of them occurring)
  • Missing Sunrise/Sunset actions.

Well said @tonyfalcone:

It’s simple things like this that get to me (and my family even more). I wish they’d get the basics rock solid before they add fun things like SONOS integration etc.

This seems to be a systemic problem for all cloud-based home automation systems, including Iris and NinjaBlocks. Makes you wonder if the cloud-based systems got a bit ahead of themselves.

I fixed my problems be removing and re-adding the device that stopped working. Now it is strange that multiple people had issues at the same time.