OSRAM retro fit downlights

lighting

(Michael) #1

OK, so I have yet to see anyone talk about the retro fit high hats that OSRAM makes. They are Smartthings compatible and hook up very easily, you can dim them, change the temperature, and change the color. I picked them up at Home Depot for $45 each to put in my living/dining room.

This is my problem, after connecting them to the hub I wanted to control all 4 of them with one control instead of picking each light on the list and adjusting them, so I downloaded the “Master” smart app… Then all hell broke loose. I picked one as a master so the other 3 would have to do the same… I made it blue, the others turned violet… I turned it bright white, the others did nothing… I turned it to soft white and the others went soft white. After time in the proper set color, it would rebel and change to some blue’ish hue…More often than not, it did the wrong thing.

Not the only issue, because I was watching TV I turned 2 of the 4 off to make the scene better, after some time all the lights decided to turn on and change color… As if someone is controlling these lights to mess with me. Does anyone know why these things are happening???


(Joshua Moore) #2

I had the same issue and two things:

  1. Update the firmware (needs the lightify gateway). Unless you do this, you will see differing behavior between the bulbs (my experience).

  2. I had to write a virtual master device and app to control them as a group. I can share the code with you if you want.

With the two above things completed I couldn’t be happier with them. They work great, good price, and easy to install.


(Michael) #3

That would be much appreciated… So with the gateway the problem will stop? Do you still use the ST app to control the light? I’m not fully understanding the point the needing the hub if the gateway can control the lights.


(Joshua Moore) #4

I don’t use the Lightify hub to control anything. All control is done with the ST hub. The Lightify hub allows you to update the firmware on the bulbs.

Updating the firmware solved quite a few issues (random turn/on off, incorrect color, etc).

Here is the device type I hacked together

And a simple app to use the master device to control the bulbs


(Michael) #5

Great I appreciate the help… Now I need help with the help lol.

So I tried to use the code however I’m probably doing it wrong. This is the first time I’m doing this, could I trouble you for a walkthrough?


(Michael) #6

I’m having problems with this. I can’t control my lights anymore


(Joshua Moore) #7

Sorry, about the delay in replying but I’ll do my best to walk you through it.

First, the overall concept. The idea is that you install the virtual control as a new device. This is the device you will use as the “Master” device to control your physical bulbs “slaves” using the application.

How to install the device

In the IDE go into the “My Device Handlers” and click on the “Create new Device Handler”. Then click on the “From Code” tab and paste the code for the device handler into there and click “Create” Once you have done that, click “Save” and then “Publish” and “For Me”. This will add this new virtual ZigBee RGBW Bulb to your available devices. Which we will use in a bit.

How to install the SmartApp

Click on “SmartApps” in the IDE. From there click on “New SmartApp” and then the “From Code” tab. Paste the code for the SmartApp into the form and click on “Create”. Finally click on “Save” then “Publish” and “For Me”. This will add the “ZigBee RGBW Bulb Grouper” SmartApp to your list of available apps on your mobile. We’ll set this up in just a few steps.

How to setup the virtual device

Now we need to setup the virtual device. From the IDE click on “Devices” and “New Device”. You can name this whatever you want and give it whatever label you want "I used “Living room lights (virtual)” for both. Just so I knew what it was. Leave “Zigbee Id” empty and put something unique into “Device Network Id” (I used living-room-lights-virtual). Pick the “ZigBee Virtual RGBW Bulb” in the “Type” list (should be towards the very bottom) and select the Location and Hub you want to install this device on.

Installing and configuring the SmartApp

Now that the hard part is done it’s time to set it all up. On your mobile device go to “Marketplace”. Go into SmartApps and select “My Apps” (at the very bottom). From there you can open up and configure the “ZigBee RGBW Bulb Grouper” application. Pick the virtual bulb device you created before as the “Master device” and the bulbs you want to control as the “Slave devices”. Give it a name (optional, but a good idea) and click “Done”.

Now that you’ve done all of that you should be able find the virtual device in your “Things” (I edited the device on my mobile and put it into a group/room) and use it to control your bulbs.

Hope this helps, and if not just let me know and I’ll do my best to help some more!


(Chick Webb) #8

Am interested in trying these out but haven’t pulled the trigger yet. I assume that you could also use the virtual device with Rule Machine and have the physical devices track that. Have you tried it?


(Joshua Moore) #9

Rule Machine works well enough, but I wanted something (e.g. the SmartApp) with more physical control of the devices as groups. Not just automated.

Apples and oranges really.


(Michael) #10

What’s rule machine?

So I did the code that you shared. Where I was going wrong was the “publish” part, didn’t know I had to do that. Thanks for all the help. It works great so far other than the temp portion, it’s not changing the color of the bulbs.


(Joshua Moore) #11

Did you update the bulbs to the latest firmware using the Lightify Gateway?


(Michael) #12

Will that fix it? No, I haven’t… I’m waiting for it to show up


(Joshua Moore) #13

It did for me. It might very well for you as well.

In my case 2 of the 4 bulbs were showing the correct color while the other two were showing completely random other colors. Once I updated the firmware they all behave exactly the same way to color settings, etc.


(Michael) #14

I never got the controller but it all works perfectly right now other than one light strobes at 100% brightness in white… That I just think it’s just a defective light, I just need to exchange it