OSRAM Lightify

Just checked again and there seem to be 3 three E27 light bulbs:

  • Lightify Classic A RGBW
  • Lightify Classic A TW (=Tuneable White)
    -Lightify Classic A60 White (This one is not recognised by Smartthings)

Hope someone can help me getting the A60 white running on Smartthings.


Go to IDE and change Thing device handler type to lightbulb type and try couple different handlers.

Hi Mike,

That is where I do not know any further. I am pretty new to all of this. What is the IDE, where can I find it, what should I change?

Many thanks

IDE is the developer area. Use the Sign Up link at the top right of the below link (Not sure if it’s the same for EU, so you might have to go to the main ST page, then at the very bottom click the Developers link). Once you create an account and login, go to the My Devices tab. Click on the bulbs that are Things and click Edit at the bottom. Use the Type dropdown to select new device handlers. Try Zigbee Dimmer, GE Link Bulb, Wemo Bulb in that order. Once of them should work. If not, pop back here and we can help.


Hi Guys,

I tried the Zigbee Dimmer, GE Link Bulb and Wemo Bulb and all did not work unfortunately. Hope you have other ideas…

Many thanks

You may have to install the device handler code in this link and apply it to the bulb. For some reason, ST isn’t pulling the correct endpoint for these bulbs, so it’s not addressing the commands correctly.

In my experience changing the device type in the IDE is a necessary but not sufficient condition. A “configure” command also needs to be sent to the bulb, I believe. Sometimes that seems to happen by itself, sometimes you can do it through the “tile” for the device (some have a “configure” button), and sometimes the only way to do it is to reset the bulb (w/o first deleting it from ST), and then re-discovering it.

Note in this case the “Identifying” part of the discovery never finishes. But the bulb will flash and then you should be able to use it with the new DH.

Guys you are awesome!!! All the light bulbs and even my powerplug is working. Now only my Netatmo Weatherstation and my Nest Smoke detectors and then all is included :slightly_smiling:

1 Like

That’s where the Community’s search function will be your friend!

Hi Ronald

I am facing the same problem, trying to add the Lightify plug and A60 bulb to Smartthings.
Can you share the modification done to the Lightify Surface for the Plug to work?

Thanks for the help!

Hi Mahodk,

for the A60 bulbs I am using “ZLL White Colour Temperature” driver which seems to be new but is working very nice. The Lightify plug I am using the “Lightify Surface”. Therefor I have created a new device handler.


Thanks Ronald

I tried to use the Lightify Surface Device Handler with different options, hence the delay. But I have not been able to get the plug to work. Can you post or describe what changes you did to the code?


I used ZLL Dimmer Bulb and it worked perfectly.

I had a LOT of trouble as well adding my Sylvania Osram Lightify (73741) RT5/RT6 to Smartthings.

Here’s what happened. I installed 6 of these lights inside my living room.

I booted up the Smartthings app, started looking for devices and THEN turned on my lights. Smartthings found the lights and I renamed them all. After it configured the lights I went back to my devices list and it said “Tiles Missing” and would not allow me to delete them.

I did a lot of research and went to Smartthings IDE on my personal computer (desktop). Make an account if you don’t already have one. Once you get logged in go to the “My Devices” tab at the top.

Find the lights labeled “Thing” and click on one of them. Go to Edit. From there change the "Type."
I changed mine to “ZLL RGBW Bulb” and they worked perfectly. I had to change all six bulbs individually to the “ZLL RGBW Bulb” and they were added correctly and worked correctly.

I went back and refreshed my Smartthings app and they showed up correctly there. I was then able to make adjustments such as scenes, brightness, color and it appeared correctly in my Amazon Alexa app.

Hope this helps someone. I did a lot of research and no one had it written out concisely on what needed to be done. Cheers.

you just forgot to click on “save” at this moment.
it difficult to see it because it’s on the top right corner.

IS it possible to connect the Osram bulbs to the latest version of the Phillips Hue Hub? Like all the IFTTT (ifttt dot com) works with Hue hub. A while back I thought I had come across a thread that Osram worked with there hub… just would be much nicer to be able to control Osram from the Hue integration rather than directly from Smartthings. Thanks

I just added an OSRAM Lightify, In the classic app, I can select the device and set the color temp, color and brightness successfully. Is there a way to create a Routine that sets a specific color and brightness when triggered? Thanks

The Smart Lighting App will do limited colors. Turn on and set color is the option.

webcore FTW

Thanks! Where can I learn about webcore?