Original Xiaomi Aqara Smart Wireless Switch (Aqara Button) [Beta]

Hi have 2 aqara button ,was repporting ok first but battery goes down to 3 % ,so i have checked the voltage of those 2 battery , there were at 3.09 volt (original battery). I have also checked voltage of a new battery and its about 3.3v .So i have replaced both,one button goes up to 98 % after 2 hours,the other one took about 2 days before went up to 97%.Now after 5 days its showing 91%(3,28v) and 89 %(3,27v).
I know that battery at 3 volt is starting to be low ,i work as a mecanic ,and when i checked car remote battery under 3 volt i just replace them cause signal is getting weak.
Will see if they still reporting ok vs battery voltage.

Will this DH work with this button?

I cannot get it to pair. I have added your DH, and tried to pair however nothing appears?

P.S this is my first time adding a DH, so hopefully i have done it correctly.

Many thanks,

David

I haven’t seen one of those before but I doubt the fingerprint will work so it wouldn’t get this DTH automatically like the button this DTH was designed for. Also I’m guessing that button would require a completely different DTH since it looks like there may be two buttons on there?

Hi,

No just one button (in my one). However you can get a free different ones.

Wireless one button - https://www.gearbest.com/access-control/pp_626696.html
Wireless two buttons - https://www.gearbest.com/access-control/pp_626698.html
Wired one button - https://www.gearbest.com/access-control/pp_626698.html
Wired two buttons - https://www.gearbest.com/access-control/pp_626698.html

They look really good, quick slick. However just cannot get it to work :frowning:

Would it work with this -

This one is $2 cheaper than aquara

@DjAnu The DTH for that is at

Thanks for your quick reply, i had already skimmed that thread but it looks like that one has DTH for cube button not this one ? Isnt it ?

BTW is there any functional difference in aquara and this one ?

As far as I know the Xiaomi Zigbee Button DTH there works for the button you asked about.

The only difference is the one you asked about sends both an on and an off response when the button is pressed so the "Xiaomi Zigbee Button” DTH is able to check how long the button was held and provide both a pushed and a held function.

Do we know if the button held feature will ever get back in for the Aqara?

No, sorry this button only sends an on command when pressed but does not send anything when released so there is no way I have been able to think of to determine if the button is held. The original round button I believe does send a command on both push and release so the DTH for that checks to see if there is more than a configurable amount of time between pushed and released to make the held feature available.

2 Likes

Does anyone know how to replace this thing’s battery? I cannot open it, the back of the button is being destroyed by my attempts to open it.

Use a quarter to turn the slot in the back an 1/8 inch counter clockwise, you should hear a click most likely. Then the back should drop off when you turn it right side up. When you go to put the back on again you need to match up the little tab on the back with the slot in the switch (the tab and slot are next to each other in this picture.

Thanks man, will do.

Could you code the DH for two presses with a second or two to be a held command? Bit hit and miss though…

I could but I’d have to wait for two seconds to process push requests as well then otherwise the first press would activate the push rule and the second in a second would activate the hold rule and it would alway depend on SmartThings getting the signals close enough together to be reliable.

1 Like

Hello,

I have the square button showed in this post. So I created a new device using the catchall method and your DH.

Now, both the Android app and the hub log when I press the button but neither Smart Lighting nor Notify Me When smartapps react on button presses. Am I missing something?

Oh, I searched the whole evening but that’s only after posting the question that I go it working!
The following DH worked directly: https://community.smartthings.com/t/xiaomi-aqara-zigbee-switch-dth-help-needed/82072/48

Hi Terk

I’ve added your DH v1.3, then tried pairing my Aqara button. It was paired correctly as the “Xiaomi Zigbee Aqara Button AQ”.

Noticed in the logs each time I press the button, I get Last Checking, but I do not get the “Button 1 was pushed” in conjunction with the Checkin.

Help? I’ve already deleted and re-paired to the same result.