Original & Aqara Xiaomi Zigbee Sensors (contact, temp, motion, button, outlet, leak, etc)

If this was mentioned before, I must have missed it somehow.

It’s possible that the temperature value used to create temperature events on the hub needs to be using a different data type. Right now, if the user hasn’t turned on the “Display temperature as integer” option in the preferences, then the temperature value is passed on a float number with 0.1 decimal precision. If the “Display temperature as integer” option has be turned on, then the value is passed on as an integer number.

The hub event handler in theory should be able to handle either of those data types for the temperature value, but if it can’t that would explain why the Humidity Alert! SmartApp isn’t being triggered.

When I have time, I will take a look at the latest temperature sensor device handlers on the SmartThings public repository, and also the Humidity Alert! code, if available to view, and publish an update to the Xiaomi / Aqara Temp-Humidity DTHs if needed.

Honestly I don’t know what is expected for the new SmartThings Samsung Connect mobile app, because the developer documentation isn’t completed. Also, the device handler preferences are completely unavailable in the new mobile app, making it far less useful than the old SmartThings “Classic” m mobile app at this time.

Hi @veeceeoh
Just to clarify: I’m trying to get the Humidity Alert! SmartApp working with humidity readings, not temperature… :slight_smile:
Didn’t think of setting the “Display temperature as integer” option - does it affect humidity readings as well…? I’ll test later today…

And a correction: i am using the classic app, not the new one… Sorry… :roll_eyes:

Oh, yes, silly me. Well the DTH’s function to generate humidity events uses SmartThing’s standard zigbee.getEvent() method, which returns the humidity value as an integer. The “Display temperature as integer” option does not affect the humidity value at all.

So perhaps the Humidity Alert! SmartApp doesn’t like working with integer values? I would find that very strange, though. I will have to do some testing… when I have time, of course. :wink:

1 Like

Guys can someone give us steps for pairing WXKG03LM CMIITID: 2016DP1334? I have tried almost everything.

It is pretty simple.

  1. In the My Home tab of the SmartThings “Classic” mobile app, press the + icon to “Add a Thing”, putting your hub into pairing mode.
  2. Put the WXKG03LM into pairing mode, by holding its button down until the LED at the bottom flashes. There are two revisions of the WXKG03LM, the 2016 revision and the 2018 revision. Depending on which revision you have, you will need to hold the button down for either around 5 seconds or around 15-18 seconds. Either way, it has gone into pairing mode and you can release the button when the LED flashes rapidly a few times.
  3. Wait for the LED to flash again. If you see one long flash, it is paired. If it blinks a few time, pairing was unsuccessful, and you need to put it into pairing mode again (go back to step 2).
  4. Wait for the device to appear in the SmartThings “Classic” mobile app, ready to be renamed and used.

If you cannot pair the button in 5-6 attempts, then please see this post for more information about why Xiaomi / Aqara devices can have pairing / connection issues:

1 Like

same problem here, i had to add my Xiaomi aqara motion sensor using the old school “catch all” method…

the device handler used to be able to catch it during “add a thing”, but nothing shows anymore, even after several attempts

Edit: nvm, it dropped off the network overnight… Think I’ll just buy some officially supported motion sensors and save the headache and troubleshooting

I’ve purchased a few Tradfri devices, as bulbs, sockets and repeaters. Pimped up a bit the network and now everything seems to be working fine.

Except I ran into a weird Aqara button, a WXKG11LM. It reports only battery level on any button press, but no press at all. The weird thing, it starts to flash the LED time to time, like it is during pairing, and stops only when the button pressed, but it changes nothing on it’s behavior. I’ve already changed batteries, twice. Any thoughts?

Sounds like that WXKG11LM is a faulty unit. The only time the LED should flash is when the reset / pairing button is pushed.

Suddenly this is what I thought too.

Have you ever tried to pop one of these open? What is the trick to not damage the plastic? :slight_smile:

Can someone confirm that Aqara Flood Sensors and Aqara motion Sensors should be working with new ST hub firmware 000.027.00009 (27.9) which is now rolled to users.
I lost connection to all my aqara sensors. I managed to get open/close sensors back but motion and flood sensors are not working anymore and they are not found when trying to “add a new thing”.

EDIT: one of my sensors just connected on its own:
Flood Sensor Dishwasher Description:catchall: 0104 0000 01 0…
Others are still out.

My hub is on firmware 000.027.00009 (27.9).
I have two Aqara motion sensors and 5 door/window sensors.
They have all been working fine (knock on wood).
I don’t know when my hub updated to 27.9.
I don’t have any flood sensors so I can’t comment on those.
I am using the latest bspranger device handlers.

1 Like

My problem is solved now and everything is working. I do not know what was the cause but I had to pair those sensors again by not removing them from thing list.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.