Original & Aqara Xiaomi Zigbee Sensors (contact, temp, motion, button, outlet, leak, etc)


(Mark C) #829

to get local processing have you tryed the stock/default zigbee button DH with any luck?


#830

I’ve not tried it but don’t I need to be on the latest beta of the hub firmware for that ? v22, I am still o n v21


(Mark C) #831

it was more to see if it worked pressing (not for local yet),
When i tryed the button, it just didnt respond till i swictch it back, but i never checked for catch all when paring.


(Keith G) #832

Both follow the “leftie loosie. righty tighty” convention.

“Original” (round) Xiaomi Button battery replacement video here. There is a tab, lift slightly to allow bottom plate to rotate counter-clockwise and release.

Xiaomi Aqara Button battery replacement video here. I use a nickel or quarter to turn cover counter-clockwise slightly and it is released, no issues whatsover.

There are some tips explained in the very first post of this thread. I’ve used a paperclip to press the reset button for my round Xiaomi buttons (and my other devices with a reset button hole.)

After pressing the + symbol to “Add a Thing” in the SmartThings Classic App, press and hold the reset button until the LED flashes, and then immediately release. Wait. If you see three rapid flashes, it’s paired. One long flash, it’s not paired yet. Either way, start repeatedly short-pressing the reset button, wait for the LED to flash, and press again, until the button appears as a device to add in the ST App. If it hasn’t shown up within a minute, start over with the press and hold of the reset button.

Sorry to hear that. I’ve had quite good luck with my 30+ Xiaomi devices, and have saved hundreds of dollars. With more expensive $30+ buttons I could say “You don’t get much for what you pay.”


(Ron) #833

Yes, funny part was I don’t know how I did it. I was holding the two buttons and when I started search (thing) got added right away. I didn’t press on the include buttons yet. So I didn’t even know which button it was until I tested.

OK, I’ll try again but was afraid to break it not knowing if it pops, twists clockwise, counterclockwise, etc

Thanks for the help.


(Max Tay) #834

Hi all.

Come across this handler for Aqara Dual Buttons Wireless Wall Switch which is written for another hub. Wonder it can be converted for the SamrtThings.
https://raw.githubusercontent.com/veeceeoh/xiaomi-hubitat/master/devicedrivers/xiaomi-aqara-dual-button-hubitat.src/xiaomi-aqara-dual-button-hubitat.groovy


(Keith G) #835

I made that device driver for the Hubitat Hub. And the answer is no, it can’t be converted to a SmartThings DTH to allow both buttons to work.

I know you really really want both buttons to work with the SmartThings hub. I wanted the same thing too. That’s one of a number of reasons I decided to move over to a Hubitat Hub. It just isn’t going to happen with the SmartThings hub. I am sorry.


#836

I too had issues getting battery out as plastic is so soft. In the end dug a screwdriver in the middle and got it to release. Messed it up a bit but only the back.


(Anuj79) #837

is there a way to refresh humidity sensor . i have the dehumidifier running but it doesnt show that the humidity has gone down.


(Keith G) #838

No, the Xiaomi Temp/Humidity sensors cannot be polled or refreshed to give an updated reading. It only sends reports according to the way the engineers designed it.

Are you still seeing battery reports every 50-60 minutes? If not, then the sensor may have dropped its connection to the hub.


(Anuj79) #839

i see check-ins every hour… but the humidity information isnt updated…
how have the engineers designed it… i would think when it checks in it should also report the current information.


(Keith G) #840

From what I have read, the sensor is programmed to report changes of +/- .5° C and +/- 5% humidity; however there are two models (the round one and the square Aqara model) and they the minimum change required for reporting may be different.

I have also read that sometimes the sensor may wait for the regular 50-60 minute check-in to report a change.

The best way to test if it’s working properly is to breath on the sensor, as the warmth and high humidity will result in a short burst of reports. This is what I’ve observed from my sensors (I use 4 of each model). If it’s not responding that way, it’s entirely possible you have received a faulty unit.


(Anuj79) #841

i have the round one and I tried the breath test and it seems to work… the temperature and humidity went up instantly … but it take some time for humidity to come down…
i have history from the device and as you would notice it was checking in every hour but there was no change recorded in temperature or humidity for 4 days. and my humidifier was running all the time because i have it to switch on when humidity is above 60

16 hours ago there was a temp change but no change in humidity for 4 days… which is very unlikely

temperature reading

checkin reading

humidity reading


(Mark C) #842

Does any one know if there is a DH for this cube


(Wout Funnekotter) #843

I understand it can’t be done at the moment because the SmartThings Hub is filtering out the neccessary information. It seems to be on their radar though, this is the answer I got when I DM’ed @jodyalbritton

Yes we have plans to accommodate devices that have multiple endpoints with the same capability. This is being introduced with our new capbilities model. I can add you to the beta list if you like


(Keith G) #844

Yeah, I’d have to agree. Still possible it’s just a faulty sensor.

Well, that would be some good news.


(Max Tay) #845

That’s fantastic, I have 5 of them and waiting to be commissioned.


(Ron) #846

So it does unscrew as the slot for the coin seems to indicate. That’s helpful, no to hack it as you did. The other one is still a mystery to me but it also refuses to pair so doesn’t really matter if the battery dies :slight_smile:


(Randy Thomas) #847

Uh, how do I use this device handler? I got my aqara temp/humid sensor to link but the tile is ugly and I need a way to enter an offset because the temp (and humidity) are way off.


(Keith G) #848

Not sure how to help here. Please explain “ugly”.

To access the settings for your sensor, click on the gear icon while viewing it in your SmartThings mobile app, here:

Settings%20Gear

Then you can change the offset for temperature and/or humidity for that device.