Original & Aqara Xiaomi Zigbee Sensors (contact, temp, motion, button, outlet, leak, etc)


(Alan Stuart) #809

And how did you do that?

If I didn’t set my ST Hub in the US, it wasn’t seen by the App/Software and couldnt be added

Then all the sensors have to be in the same are as the hub for it to see them.

And heard that if you dont set the app to same timezone as hub, wont see sensors.

If I can get it to wok with an Aus location, that woud be great.


(Paul) #810

I set mine up so long ago but I don’t remember being forced into picking the US for anything other than the very first choice, where you choose between US and UK (I think). I think I then set my actual home location to be here in Melbourne, and chose the Melbourne/Sydney timezone. It all works well. Having your home in the right place means you can use the presence feature in the app to automate things as you leave and come home. Sunset and sunrise times will also be correct if you want to use those in automations.

To change where your home is, in the app tap on the More tab at the bottom (with the three horizontal bars icon), then tap the cog icon in the top panel, next to where it says ‘Home’ or whatever you called your main hub location. Then tap on the map and locate your house. Click Save. That should also set your timezone correctly.


(Keith G) #811

Which version of the ST App - SmartThings Classic or the new SmartThings (Samsung Connect)?

I don’t use the SmartThings (Samsung Connect) app (yet), but it has been reported to not yet work correctly with all Zigbee/Z-Wave local devices.


(Alan Stuart) #812

OK, am happy to wipe and start again.

Hoxever, my hub is already registered with the supplied 6 or 8 character code.

Do I need to ‘deregister’ it before I can set it up again??


(Alan Stuart) #813

Dont worry,

I have reset it. Will find out in 10 minutes if successful LOL


(Paul) #814

I don’t think you need to wipe your hope. Just follow the instructions for changing your home location that I posted and that should be enough. For what it’s worth, I’m using the Xiaomi temperature & humidity sensors (the round ones) so there’s no reason they won’t work for you either.


(Alan Stuart) #815

I did anyway.
All setup and going in Oz. Happy about that.

Now, the buttons.

When connected thru the Xiaomi hub, i had single click, double click and click & hold.

I could also ‘toggle’ the light (using a Xiaomi wifi outlet) between off/on/off/on etc

Cant seem to do this when using the ST hub & apps.

Would like single click to toggle between on and off (using Xiaomi Zigbee outlet)

Any ideas


(MarkTr) #816

In Smart Lighting, you can configure a button to control a device. If you set it for “turn on” or “turn off” you should get a slider at the bottom for “toggle on & off”.


(Alan Stuart) #817

Thanks.
Had found BUTTON CONTROLLER under apps, but the smart lighting is much cleaner


(Alan Stuart) #818

Thanks. Was using the new app, but changed to classic and all added ok


(James Scholes) #819

Just chipping I with more adventures in Aqara land.
I have a handful of motion sensors, some pill-shaped window sensors and some more rectangular window sensors. I’ve been slowly trying to make my mesh more stable by repositioning the few plug-in Zigbee devices I have, and have rebuilt, and also re-added devices a few times now. I’ve come across something that I haven’t seen anyone else comment on.

The other day I set aside a couple of hours while the family was out, powered off all Zigbee devices, collected up several unavailable aqara sensors and set to work.

Some devices just needed a quick press, 2 then 3 flashes and they sprang back into life. Some needed a reset, then could be readded.

One motion sensor stubbornly refused to appear. I’ve reset it multiple times and afterwards I will very quickly get my 3 “connected” flashes, but nothing appears in Smartthings. After that I get the same 2 then 3 flashes which I understand to mean “all good”, but I can’t see it, there’s nothing in the logs.

Since then I’ve discovered an Aqara window sensor which behaves the same. Nothing I do seems to wake it up.

Any ideas?


(Graeme) #820

Have you exceeded the 32 ZigBee device limit in SmartThings? I had a similar problem also with an Aqara motion sensor. I ended up adding a xbee SC2 device to my network to act as a router and that has solved the problem for me. I now have 45 ZigBee devices, including 11 Aqara motion sensors all working on my network.

Refer to this thread for more information: Zigbee - from flakey to stable


(James Scholes) #821

I haven’t exceeded the limit. I do have an XBee waiting for the next spare window to be set up, but the issue is that the sensors think they’ve connected, but they’re not showing up in my devices


#822

I’m having some problems with the Xiaomi buttons and hopefully someone can help me out.

I’ve had two buttons die out on me - each time, I was able to pair and connect successfully, but each would drop off and fail to work again after a few months - they just spontaneously stop updating their status hourly. I don’t see them come up with the catchall method anymore, although I can pair them using the saved device ID, but the buttons still doesn’t work. The batteries are fine (measured with voltmeter) but I changed them anyways, without luck. I’ve updated to the latest DH just now, and no luck.

Any ideas? TIA.


(Ron) #823

I bought two of these buttons (one each of Xiaomi Button and the Xiaomi Aqara Button)

The Aqara, joined by accident. I didn’t even press it. I was holding the two buttons, started the discovery and “Thing” got added.

I switched between the two device handlers to figure out which one got added and ultimately it was the Aqara.

I have two issues now.

  1. I can’t figure out how to open either one to replace the battery. The Manual is not in english.
  2. The Xiaomi Button refuses to join. I have tried over and over but SmartThings just never sees it.

Not to impressed with these. You get what you pay for.


#824

That’s a shame you’re having problems, I have 30+ Xiaomi devices and I love them, they are no more problem than other brands for me except I went over the 32 device limit and had to set up routers, but that is resolved now (you can read about that elsewhere on the forums).

Changing batteries is generally straight forward, but you dont always have to do it they often report low battery but it’s not a problem. When I get home I will check the devices you have and send instructions. THe devices should join fine via catchall if you are patient - unless you are at device limit (32) for the hub.
How are you trying to join them ?


#825

How many zigbee devices do you have ? there is a limit at 32, I had similar experiences and I think it was due to family arriving with arrival sensors and that kicking off other devices when I was at the limit.

Else interference from wifi or other devices if they are in weak signal areas - could look at which channels etc you are using - there is a thread on that on the forums

Else could use routers (i am because of 32 device limit) but also helps for low signal areas, I have a v stable network now and 40+ zigbee devices.


(Ron) #826

I have 3 zigbee devices, a plug and two presence sensors. My mess is mostly zwave.

I select + in things, then I am pressing the button on the device inside the tiny pin-hole (using a simcard removal tool), I can’t press the button without the device button triggering also, because I have to press down, don’t know if that is a factor. The instructions say to press and hold till it flashes and then expect either a single flash (fail) or a triple flash meaning it is trying to pair. Mostly I get the single flash, occasionally I get a double, never a triple. Regardless, SmartThings never does anything.

About getting to the batteries. I can’t figure out how to open the round one at all to get to the battery. The square one seems to have a slot on the back to use a coin to open but it’s too wide for a coin really and when I try to exert a tiny bit of pressure the plastic starts to rip before the back turns so I backed off right away.


#827

for the pairing it sounds like you have the aqara sorted already - it recognised it as a “thing” you said , therefore just change the DH etc.

For the other one you have followed correctly how it ‘should’ work but I’ll explain how I do it, it’s crude but i’s relatively fast and takes just a few seconds.
Firstly to say this is my variant on ‘catchall’ method , which I won’t explain here as it is in these forums a 1000 times, but needless to say you need to be logged into IDE with the hub events showing on PC or tablet screen.
Press ‘+’ as you have, then using a pin press the button on the device as you have been, keep it pressed till you have 3 flashes then release, then press it on and off for about 20-30 times in a row, the light will flash several times during this. Then just go to the IDE screen and look for the ‘catchall’ entry which should have appeared (90% of the time it will have done), if not then repeat… ie press and hold for 3 flashes etc. NB after each ‘3 flash’ a new network ID is generated so make sure you have the latest ‘catchall’ event (refresh PC screen etc)
Then just change DH to appropriate one etc .
Sounds longwinded but really is less than a minute per device and works for me v well.

For the battery , I can’t find a square button switch but the round ones are easy - looking at the back there is a slight gap in the outside rim, and what looks like a little area you can press, (on left hand side as I look at it), just hook your thumb nail under this so that you can press towards the button and turn at the same time - pull to the right with your thumb - ie anti-clockwise motion - and the cover just pops off to expose the battery.

I have no direct experience of Samsung sensors, and I know this looks a bit longwinded for setup but reading lots of comments from others Samsung devices tend to lose their pairing far more often than Xiaomi ones, a and my personal experience once set mine are very reliable.


#828

Any ideas? Thabks.