Original & Aqara Xiaomi Zigbee Sensors (contact, temp, motion, button, outlet, leak, etc)


#668

delete the motion sensor from SmartThings and then remove power from any Zigbee router/repeaters
(non battery powered Zigbee devices such as Zigbee light bulbs, light switches, power plugs, outlets) on SmartThings and re-pair the motion sensor. Then restore power to the previous devices.


(Zen) #669

Can I ask if the aqara motion sensor’s lux sensor is working fine?


#670

Hi,

working fine for me.
Are you having a particular issue… not reporting values, values are outwith expected figures, you have 2 and they both report different values?


(Killian Gilmartin) #671

These are all the devices on my hub with ZigBee IDs. Only two of them are switches, the other four are battery powered door sensors or motion sensors

Do hue bulbs count as zigbee devices? I have about 10 of those


#672

curious what brand and model of switches
You could try disabling one and then re-pairing and then put the power back to the switch you disabled.
See if it does not fall off.
Try and figure out which one is causing it or maybe both of them are.
but when you re-pair it is hit and miss if the Xiaomi will route through the switch or go directly to your hub.
once paired you could just take the power off the remaining switch and see if the Xiaomi stops working if it doesn’t then it is connected directly to the hub.

I have another 11 zigbee switches/plugs that the Xiaomi could have been failing on and 2 are in my attic so to much of a pain to figure out which one is causing the failure.

I may have found a zigbee outlet that does allow Xiaomi sensors to router/repeat through it but want to test a few more things. Running it on a seperate hub.


(Killian Gilmartin) #673

These are the two switches I’m using:
Dimmer
On/Off Switch

I will try cutting the power to both of these when I get home from work and re-pairing the Xiaomi Motion Sensor and we’ll see how that goes. I guess the Xiaomi door sensor I’m using managed to connect directly to the hub, but these motion sensors are being stubborn.


(Keith G) #674

Hue bulbs are capable of repeating if they’re connected directly to your ST hub, but people have reported them as being unreliable:

You’re on the right track here. Only mains powered Zigbee devices can be capable of repeating, so there’s no need to worry about any other battery-powered devices.

Generally people have reported issues with Xiaomi devices that are initially through a repeater, but there’s a higher level of success in keeping Xiaomi devices connected if they are first paired to the ST hub, and then moved to their install location, where they may change their connection to a local repeater device.


(Jimmy) #675

SmartThings started adding an attribute called “offlinePingable” to the device health piece of device handlers. No clue what it does, but may be good to add to the Xiaomi handlers


#676

I have the same switches on my SmartThings hub
could you try leaving the switches powered and just unscrewing the hue bulbs and then try pairing. No guarantee that they would pair through the switches but if they did it would confirm that they work as Xiaomi repeaters.
It would cut my testing of repeater devices in half.
I suspect that the problem is the bulbs.


(Keith G) #677

Thanks for the heads up, but the “ping” feature is part of SmartThing’s DeviceHealth, which is only available for local-execution devices - a subset of SmartThings “officially” supported device list.

Xiaomi devices are not “official” supported, and the DTH’s are most definitely not being executed locally.


(Jimmy) #678

It works for cloud devices too. I’ve added it to several handlers.


(Killian Gilmartin) #679

Well I have yet to be able to test this since smartthings has been down all night but I’ll let you know once I do…


#680

thanks
In my testing with Orvibo ZigBee Smart Outlet the Xiaomi would always pair as “devices” and I would have to just change the DH in the ide after they were paired.
When they paired directly to the hub (not through the Orvibo ZigBee Smart Outlet) they would be recognized as Xiaomi immediately.
You have to have ArstenA & veeceeoh Xiaomi DH already loaded in ide DH


(Killian Gilmartin) #681

yes the motion sensors are both recognized as the Aqara Motion sensors, but still continue to disconnect. I really wish I could log into smartthings to test


#682

they may still be recognized as the Aqara Motion sensors going through repeaters depending on manufacturer I don’t think all repeater functions are coded the same thus some work better than others.
I was kind of surprised when with my Orvibo ZigBee Smart Outlet Xiaomi devices were not recognized but still worked fine.

I have the following repeaters on SmartThings hub and one or more of them caused my Xiaomi devices to fall off (if paired while they were powered on). First suspect is the bulbs the next would be the plugs
1 - Iris ZigBee Smart Plug
1 - Samsung SmartThings ZigBee Dimming Outlet plug
1 - Sylvania Smart+ Color and Tunable White A19
5 - OSRAM LIGHTIFY A19
3- GE ZigBee In-Wall Smart Switch 45856GE

but all my Xiaomi devices I have moved to my Hubitat hub to isolate and test them.
They did stay connected to my SmartThings hub (when I powered all the above repeaters off and paired them) but I should do some more testing to isolate which of the above repeaters work and which do not.

They can also fall off if just at the edge of the range from the hub thus my interest in repeaters to extend their range.


(Jimmy) #683

I would guess none of those repeaters will work.


#684

why would you guess that?

I do have Orvibo ZigBee Smart Outlet working as a router with Xiaomi devices (2 Aqara motion and 4 Aqara water sensors) I am sure there are other types/brands that will work unlikely Orvibo is the only one.
They worked for over 3 days no problems I killed the power to the Orvibo for 24 hours to see how the Xiaomi devices react. As expected the Xiaomi devices stopped reading immediately. So far they have not tried to bypass the Orvibo and connect to the hub. I will power the Orvibo outlet back up tomorrow and see how long it takes the Xiaomi devices to start reading.


(Jimmy) #685

There’s been multiple reports of Xiaomi devices not working through repeaters.


(Alec McLure) #686

@veeceoh FWIW I’ve never had success with a Xiaomi device if it switches over to a repeater - only stay on line for me while connected directly to a hub. Would love to hear otherwise from anyone! (Could be my old house).


(Mursalin Akon) #687

Hi: I got 2 original Xiaomi wireless switches (button ?). I added the button DH through IDE and tried to pair with ST. I see 3 LED flashes as mentioned after.

Catch all looks like as follows:
catchall: 0000 8038 00 00 0140 00 0000 00 00 0000 00 00 000000F8FF071800070010C2CEB0CEDEC6D1D6CAEAC1BDD2B6BAD8

And raw data follows:
raw:F4990000158D0001D62B77, dni:F499, errorCode:00, ieee:00158D0001D62B77

I don’t see any zbjoin in logs. And obviously, pairing never happens.

What am I doing wrong?

TIA