Original & Aqara Xiaomi Zigbee Sensors (contact, temp, motion, button, outlet, leak, etc)

I have 6 or so round and and 6 or so square temp sensors that I am willing to get rid of since I can’t keep them on the network. Yesterday I shut off my hub for a few hours in order to get them to latch on to my S2B repeaters and they did. But once I turned my hub back on now I can’t get them to stay on the network. Yes I did shut down ALL my ZigBee devices during the repairing. What was interesting is those square temp sensors, which stayed on for weeks and have never been able to keep the round ones on, now will not even stay on the hub. So I am looking for 6 Visonic Door/Window Sensor and willing to trade. Heck I will even throw in two wall switches that I think are still in the box.

Just make sure to also copy the Device Network ID from the catchall message as well and enter that in when creating the device. Without the network ID, it won’t work at all.

This doesn’t seem to be working for me on a few original Temperature/Humidity sensors that I’ve enabled it for. The min and max are nearly always the same as the current temperature.

Could it be reseting the values too often (like once an hour rather than once a day)? I’m using Celcius and my date format is DMY if that makes any difference.

Edit: one device has a state of “currentDay: 38”. If that’s day of year then that’s a week behind? Also, the code is using Date.format(‘mm’)… I’ve not used Java in years but ‘mm’ doesn’t seem valid - ‘D’ is what gives day of year - ‘mm’ would just give you the minute in the hour twice.


I have been facing difficulties staying connected Aqara DWS to a Samsung Connect Home (MIMO router & ST hub)… My setup has a Samsung Connect Home connected to a Verizon FiOS router with 2.4 GHz deactivated.

I am able to connect to the Hub with the right catchalls, open/close status (during the first few min), battery status, etc. That said, in about an hour’s time or so, I am losing the connection.

I went through the detailed instructions from bspranger (i.e., switching off 2.4 GHz, bluetooth, etc.) and I continue to drop the connection. I am not sure if a similar situation was encountered by anyone in the group but I wanted to check for insights from the rest of you.

These are probably elementary questions for some of the more experienced minds here but::

a) Are Zigbee routing devices simply ST hubs / Zigbee enabled routers? Could any of my neighbor’s hubs be causing issues?

b) I also read that we could move the wifi channels to not interfere with Zigbee… How do we know what channels does Zigbee operate in?

These might be very basic but I wanted to be less stupid by asking them than not asking at all… I have been trying different permutations over the last few weeks before this SOS call. Any answers / suggestions will be great!!



You are correct!!

When testing the min/max reset function, I used a reset of every minute!

This was supposed to be changed to every day before release, but apparently the “original” Temp/Humidity sensor device handler didn’t get updated somehow.

I have fixed this, and the updated “original” Temp/Humidity sensor device handler is now version 1.0.1 and can be grabbed from the bspranger/Xiaomi repository, here, immediately.

My apologies for missing that, and thank you for reporting it!!

1 Like

I’ve heard this story before…

Personally, I bought a SmartThings Link for NVIDIA Shield as my hub last November, and it never worked with any of my Xiaomi sensors. I decided to switch to a v2 hub in late December and they paired quite easily and have never dropped their connection.

Since Xiaomi sensors aren’t officially supported, SmartThings support won’t offer any help based on them not keeping a connection. I did find out that the SmartThings Link hub uses different firmware and very likely a different ZigBee radio, and support confirmed that the Link is on a different development schedule than the v2 hub. The Samsung Connect Home also runs on different firmware from what I understand. This is something to consider - it may just not work with Xiaomi devices at all. Maybe with a future firmware update? Who knows.

To answer your questions:

Yes on the first question of A). However, it’s better to refer to a ZigBee hub as a “coordinator”, because that’s what they’re called. A ZigBee router is actually what a lot of people refer to as a “repeater”. Each ZigBee network can only have one hub/coordinator, and multiple repeaters and end devices. But ZigBee coordinators use something called a PAN-ID, which makes each ZigBee network unique from others. Coordinators/hubs self-assign their PAN-ID, but will use a different PAN-ID if they find another local coordinator/hub using the ID that was chosen. So this means there can be more the one unique ZigBee network in the same location. In theory, you should not have problems if your neighbor(s) also have a hub with ZigBee.

1 Like

Thanks much!! I already see a difference with my setup that my Samsung Connect Home is not setup as a repeater but as a separate network…

I will go through the best practices for Wifi Channels as well and let the group know…

Thanks much for the brilliant response.


1 Like

Update: “Original” Xiaomi Temp/Humidity sensor DTH to v1.0.2
in the bspranger/Xiaomi GitHub repository, direct link here.

I have added a couple additional fingerprints (the data that SmartThings uses to match a device being paired with the appropriate DTH) because I see that many people have never had luck pairing the (round) “Original” Xiaomi T/H sensors.

I have based the fingerprints based on a few sources by people who’ve learned a lot of technical information on Xiaomi devices.

For anyone having trouble keeping their connection to their round T/H sensors, I encourage you to give this updated DTH a try. I can’t promise it will work, but it would be great if it does!

Tagging @AlecM & @thearchitectuk because you’ve both mentioned troubles pairing these using the “Add a Thing” method

When creating v1.0.2 I get this error - Original” Xiaomi T/H sensors
Smartthings V2 Hub

Org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed: script_dth_metadata_ed12b29b_ded4_477b_b340_f0ff1a02cc75: 45: Duplicate named parameter ‘outClusters’ found. at line: 45 column: 14. File: script_dth_metadata_ed12b29b_ded4_477b_b340_f0ff1a02cc75 @ line 45, column 14. fingerprint profileId: “0104”, deviceId: “5F01”, inClusters: “0000,0003,0019,FFFF”, outClusters: “0000,0003,0019, FFFF”, outClusters: “0000, 0004, FFFF”, manufacturer: “LUMI”, model: “lumi.sensor_ht”, deviceJoinName: “Xiaomi Temp Sensor” ^ 1 error

This looks great, thanks!! However, when I try and update the DH from REPO I get this:

Error 500: Internal Server Error
URI /ide/device/doRepoUpdates
Reference Id 247963a0-4801-4496-bc91-cdde6f84ad94
Date Fri Feb 16 10:33:28 UTC 2018

Any idea @veeceeoh

Same here.

Me too…

There was a typo! It’s fixed and definitely no errors (I tested in my own IDE). No change in version number this time. Available here.

Apologies, @bobbles, @joelw135, @thearchitectuk, @D_Lev

Just came across the DH for the Honeywell smoke alarm after looking at the other thread about this device. So far everything seems to work just fine (thanks guys!) although I’ll need to get a can of smoke to do a proper test (which I’ll also use to test my other proper ‘dumb’ smoke alarms in the house).

As we in Australia don’t have z wave functionality on our ST hubs, I’m wondering if the smoke alarm could be pressed into service as a cheapish battery siren (it is loud) for other alerts once remote test/triggering can be implemented in the DH. What do you guys think?

No luck yet. Connect home is possibly on a firmware that still doesn’t support xiaomi aqara devices. I’ll research more…

Thanks much for your answer.

I’m trying to get access to some of the other features the xiaomi smoke detector has, you can read a little more on the git if your interested. If I can get it to work then what you are suggesting should be possible… but still a work in progress. If you are using the DH from the bspranger git (the one at top of this thread) I’d be interested to have any feedback and test result for how this is working for you.

Yes read through the git issues thread and started looking into the structure of device handlers also and how to write them. I used the code from your fork. So far everything works great, paired easily. Otherwise I’ll test it with simulated smoke next week once I order a can of the stuff. Looking forward to further progress in due course!

I am looking forward to this one: "Xiaomi mijia Honeywell Gas Alarm "https://www.gearbest.com/alarm-systems/pp_615080.html

Does anyone know if it is possible to pair a button directly with a wall switch?


So I just tested this with my round Xiaomi temp humidity using your most recent version w/ test fingerprints. Unpaired it and repaired.


  • the fingerprints don’t do anything with mine - it still doesn’t even come up as a Thing so I have to do catchall
  • the Zigbee ID is not in the catchall (nor could I find it in hub events or live logging - at least at this pass) - nothing starting with 00158

I bought this back in April of last year - might be a really early version w/ little reported.

I have access to the Zigbee ID through my Xbee mapping of the system - it does indeed start with a 00158 as I’d expect - so I’ll plug it in from there.



PS - here’s the catchall just in case you’re curious and see a pattern I don’t

Actual zigbeeID as identified by my Xbee/XCTU 00158D0001564B48