Original & Aqara Xiaomi Zigbee Sensors (contact, temp, motion, button, outlet, leak, etc)

Old platform Dth = groovy

New platform Driver = lua

Driver just come out in August or something .

1 Like

Wait, what?

This might be an issue: "Unknown route"


Will have to investigate how to deal with that. Any ideas?

I’ve removed the button and re-paired it. Now everything is fine. For some reason there’s no Route entry at all, though the old button has it. Either way it works

1 Like


can anyone help me, this aqara door sensor model doesn’t seem to work in any way with this device handlers

Hi @domenico_antonio_puo
Would you like to try an edge driver?
Please be advised it was not tested with Aqara E1.

hi, thank you, or already tried but it doesn’t seem to work with my device, it detects it but it doesn’t seem to work.

[quote="[ST Edge/Beta] Xiaomi/Aqara zigbee door sensor driver, post:1, topic:234709"]
MCCGQ01LM
[/quote]

it seems the MCCGQ14LM is using IAS instead of OnOff cluster

@veonua , right, seems it is using IAS cluster for contact state and FF01 attribute under basic cluster for battery reporting

are there any chances that i can make it work at the moment?

I have a fronius inverter (no smart meter yet) but ow the hell do you get froniuis conncted to ST???

Can someone help me please, I’m trying to find the right device handler for a Mi Wireless Switch (WXKG01LM)

I managed to connect the wireless switch button to the hub.
I can also see the signals arriving in the hub under List Events when I press the button.
But there was no change in the SmarthingsApp when the button was pressed.

I’ve tried the versions of a4refillpad and bspranger.
Can it be that, in general, custom device handlers no longer work in smartthings?

They definitely still work, at least at this time.

Install the Edge driver by @veonua and keep pressing the reset button between double flashes until the app discovers it. It will take a minute or two.

1 Like

I added a Aqara switch button WXKG11LM * model: lumi.remote.b1acn01 button
using 1.4.3 DTH from [bspranger : Xiaomi Aqara Button] on a ST hub v3

but I can’t get the double click to trigger anything (scenes, lights, nothing). Although in the logs it appears to be working:

On 2x click: Aqara Button: Creating event [name:button, value:pushed, data:[buttonNumber:2], descriptionText:Aqara Button was double-clicked (Button 2 pushed), isStateChange:true] but doesn’t actually work.

Do I have the right driver?

LE: I tried the 1.3 version of the driver Xiaomi button and

  • 1x click works
  • the “Hold” button works (which in version 1.4.3 does not fully work).

In version 1.4.3 the HOLD button is followed by “PRESSED” and then standby which could trigger a single pressed action (standby - held - pressed - standby)

You are using an old style device handler.
This buttons work much better with Veon’s “Xiaomi/Aqara switch & button” Edge driver.

2 Likes

I have installed your driver on my MCCGQ11LM open and close works but not voltage and no battery status. Also it appears as cloud not local

please, read the forum before posting, every 5th message is about that.

in short, just wait, it will come in a day or two

I bought 5 of the Aqara temp/humidity sensors and was able to get 4 of them added without issue. The 5th one came in as Thing and when i went into the IDE it had the wrong device handler so i corrected it. The problem is, now its not pulling any data at all. Ive tried deleting and re-adding it multiple times, it always comes in as thing and when i correct the device handler it never pulls data. Do i have a bad sensor or am i missing something?

Here is what it looks like in my IDE

Hi to all,
I have to admit that I am a beginner Smarthing user and I cannot understand and comprehend everything, so I am asking you for help.
I have already tested several HUE, Osram, Xiaomi gate solutions, now the choice fell on the ST due to the openness of combining various solutions.
SmartThings. Add a little smartness to your things. at this address I added a repo from GitHub, I downloaded and published drivers for Aqara / Xiam, and I can see them, etc. but i couldn’t add any device via apps. unfortunately I do not see them at this address SmartThings. Add a little smartness to your things.
so I added them manually via “from code” now there are devices (flood sensors) connected but they are often offline or I check the distance from the hub is not large. I have a different flood sensor and it works fine. I do not fully understand if there are these two different addresses, why after adding the drivers, one was not on the other.
I am asking for help in understanding and guidance :blush: