SmartThings Community

Original & Aqara Xiaomi Zigbee Sensors (contact, temp, motion, button, outlet, leak, etc)

(Jimmy) #11

You may have hit the 32 device limit

1 Like

(Keith G) #12

I think it’s perfectly fair to start a new thread focused on discussion and support of any of the Xiaomi Device Handlers in Brian’s GitHub repository. There are quite a few people who’ve made modifications to the a4refillpad DHs, but they’re not being actively maintained and updated with improvements.

Yes, there’s a lot of misinformation and early guesswork in some of the various threads on all the different Xiaomi devices, but I think it’s not fair tell people to stop using the threads or close them. These DHs are ST community-created at their origins, and it’s every individual’s choice as to how they get non-official devices working with their hub setup.

Bottom line, if you’re using any of Brian’s updated Xiaomi Device Handlers, then I think it’s great having this thread to avoid confusion over which DH is being used when discussing issues or asking for help.

1 Like

(Alec McLure) #13

Thanks much @prjct92eh2!

I didn’t know about this. Bet that’s it - have 23 Trippers, which I think mostly connect directly, 15 Xiaomi devices, etc. etc. Bet that’s it. Thanks!!! (Annoying but I think I know things I can shift around).

1 Like

(Brian Spranger) #14

So the hub has a 32 device limit on the zigbee radio? If so, I am only 1 or 2 away…

0 Likes

(Jimmy) #15

32 device limit for direct connections to the hub. Devices routing through repeaters don’t count.

0 Likes

(Alec McLure) #16

And per this, found in another thread - if a device is itself a repeater it doesn’t count. (So my Smartplugs, which are repeaters, are connected directly but don’t count.)

Thanks again @prjct92eh2 - you’ve probably saved me hours of Xiaomi heartbreak! I can rearrange some things, I think. But it will put a limit on my buying many more of them. Pity!

1 Like

(Joel W) #17

@ArstenA OK installed an Original Temp Humidity sensor. I re-paired the device got the catchall and created the device. When I tried to pair using thing method and it came up after applying the DTH as unknown and blank. I then used catchall, but no luck with battery and it went off line once already. it checks in not often enough. I see no temp or humidity or battery. How long does it take to show? If it doesn’t what next?

Update: Temp Humidity now show. No battery.

0 Likes

(Joel W) #18

@ArstenA Still no battery, how long before it shows.? I also don’t see the cability in IDE for the DTH So as of now the Temp/Humidity and the button no battery. Also they both seem to be asleep, as the button doesn’t respond. How do I wake these up? Online for two hours exactly then goes offline and unavailable. What now?

0 Likes

(David McDougall) #19

I’ve been reading through the 10+ other threads for a few days now and have been adding devices using the catchall method. (And seeing them drop off after an hour or so). Could the original post be edited to specify the the recommended steps to take to add a device so that drop-offs do not occur? That way everyone can find the steps in a single spot without needing to continue hunting through a bunch of other threads.

0 Likes

(Pierre-Olivier Berthiaume) #20

Great job Brian on the device handlers.

Why is the motion sensor not registered with the “Illuminance Measurement” capability instead of just publishing the “light” variable in a tile.

Registering the sensor as an “Illuminance Measurement” device would enable sending the sensor data over MQTT Bridge written by @stjohn.

1 Like

(Brian Spranger) #21

Good question. :grinning:

I don’t actually own all of these sensors, and the Aqara motion sensor with illumination is one that I do not have.

I have only worked on the DH enough to get it functional based on debug data others have posted.

Your welcome to make the changes and make a pull request. Otherwise I will look into it when I get a chance.

0 Likes

(Joel W) #22

@ArstenA I paired my Temp/humidity sensor, it became unavailable after two hours. How do I get it back?

1 Like

(Brian Spranger) #23

Delete is and try again.

How are you adding it? Use the app, and add a thing.

Try this, near the hub:

  1. On the sensor, hold the button until it flashes, then release and wait until it flashes (takes 10 seconds?). This should reset the sensor.

  2. In the app click add a thing.

  3. Press and release the button on the sensor. Wait 10 seconds for the sensor to stop flashing.

  4. Continue step 3 until the sensor appears in the smart app. May take 5-10 presses.

  5. In the web interface look at the hub events, you should see th catchall from the sensor and also a zbjoin.

  6. Leave the sensor near the hub and hope it starts to report battery.

  7. If it fails, try, try again…

0 Likes

(Joel W) #24

Yes that is what I did, started showing battery. Only 51% battery. I hope I can open the door for the battery change, I tried with a coin. Not sure if it counter clockwise or what to open it. A nickle didn’t work. Has anyone got it to open?

0 Likes

#25

@ArstenA I believe the barometric pressure capability is not listed in the aquara temp sensor device handler. Can we add that? I’m not sure how to fix it myself. Also, someone on GitHub suggested a fix for the motion/lumen sensor to convert the light measurement to lux instead of percentage.

1 Like

#26

Tested with Aqara Motion Sensor and Aqara Contact Sensor, worked flawlessly! Great work!!

Reporting all the right measures as well, as my sensors are relatively close to the Hub no loss and response time is great.

0 Likes

(Alec McLure) #27

Is it the little round one? It’s crazy difficult to open. I ruined one once trying everything from a nickel to whatever. What has worked is to actually stick it on to something and then you can twist and open it. Maybe someone else has a better suggestion.

1 Like

(Joel W) #28

Is it just the center that opens or the whole white back? I tried opening just the little coin center and it tore the coin slot.

0 Likes

(Alec McLure) #29

Had to change mine today anyhow (easily 6 or 7 months) - hope this helps

Whole thing, mounted with a 3M strip,

The back after rotating the front off - it’s just a short twist counter-clockwise- but sticking it to something is all that worked for me - the slot on the back just got messed up

The front where battery is

Alec

1 Like

(Joel W) #30

Thanks for that. When you received yours what percentage was the battery?

0 Likes