SmartThings Community

Original & Aqara Xiaomi Zigbee Sensors (contact, temp, motion, button, outlet, leak, etc)

In the app all I get is Battery at 100%, rest of display blank. Odd.

Has anyone been able to have Xiaomi sensors work correctly (not drop out after a few hours) with the ADT Smartthings Hub. Using device managers for the sensors. They work fine with V2 hub, but am wanting to purchase a ADT Smartthings hub for security and would be nice to run everything though it.

Not sure I’m even going to try. But as it happens …

08:48:55: info Aqara Button WXKG11LM: Battery at 100% (5.032 Volts)
08:48:55: info Aqara Button WXKG11LM was quadruple-clicked (Button 4 pushed)
08:48:54: info Aqara Button WXKG11LM: Battery at 100% (5.032 Volts)
08:48:52: info Aqara Button WXKG11LM was triple-clicked (Button 3 pushed)
08:48:50: info Aqara Button WXKG11LM was double-clicked (Button 2 pushed)
08:48:47: info Aqara Button WXKG11LM was single-clicked (Button 1 pushed)

So it can work when it feels like it!

I have a full array of Aqara devices and have had great success with them. That being said, I had a long power outage after which two Aqara Door/Window sensors dropped off and I have not been able to get them or any other Aqara Door/Window sensor to rejoin. I have used the method as described by Veeceeoh (thanks Veeceeoh) for HOURS… no can do… I have tried two new devices right out of the box and even one that was operating on another hub.
Nothing will pair…
Any ideas?

I noticed that one of my motion sensors was reporting as unavailable today, but funny enough all motion is detected in ST and it seems to be working just fine…
Obviously i tried to re-pair it, but after numerous attempts i still can’t get it to pair, so i am having the same problem at the moment…
Maybe ST have some issues right now…?

I’m not 100% sure, but this sounds like a known issue with custom DTH’s going “stale” in SmartThing’s cache for a user’s hub, as explained in this thread:

The “stale” DTH issue has actually happened to me twice while pairing a device, and although it did not appear in the SmartThings mobile app when in “Add a Thing” mode, I could see Live Logging output showing that it had successfully paired. Oddly, the device was not in my hub’s Device List as viewed in the IDE.

In addition to re-saving and re-publishing my custom DTHs, I also had to look at the Hub Activity logs to figure out the Device Network ID so I could manually add the device to the Device List before I could delete it and try pairing it again normally. I call this phenomenon “ghost devices”, and it’s quite frustrating to deal with.

There are other possible reasons why Xiaomi / Aqara devices may have trouble pairing, so if the above suggestions don’t work, let me know.

1 Like

Thanks for that info. You hit the nail on the head… I did have a duplicate driver.

Now the question… As luck would have it , the driver I would like to delete is in use… What must I do to delete it?
Think it might be to c/p the desired driver into the driver that is running (the undesirable driver) and republish… what’cha think?

i Start using the new Xiaomi zigbee outlet that released before a month is much better that i have energy meter but before i have only tepreture we use Celcius here and was 17C before the new handler after the refresh with new handler become 160 i think you must check again your code about tempreture propably is *100

1 Like

WKG11LM with ST hub firmware 25.27, using Version 1.4.2b device handler. Button presses no longer trigger smartapp events.

I need more information to be able to help.

You say “no longer” which makes it sound like it was working before. Did something change? Were you using the v1.4.2b device handler successfully before?

Can you turn on debug & info message logging in the preference settings for the button and then copy the log output seen when pressing the button (single, double, triple, & quadruple)?

Do you see recent battery level events, or did they stop some time ago?

1 Like

Yes, worked fine before. Battery level seems to be reporting, but says 5.032 volts which seems improbable with a 3v battery.

Edit: forgive my stupidity, I had apps set to only activate in “home” mode. For some unknown reason the mode wasn’t in home.

This is a known issue:

I am finishing up an updated DTH that gets rid of the erroneous battery reports, but it is significantly different in both the button push / held / etc. events it generates as well as in the main UI tile display, so I need to do more testing and refinements before sharing the new beta version here.

No worries, I’m glad you figured out that issue!

[UPDATE] Aqara Button DTH v1.4.3

This update fixes an issue with erroneous battery level events from catchall: messages that don’t actually contain battery voltage data, especially during every triple- or quadruple-click of the original revision of model WXKG11LM Aqara Button.

Many thanks to @AnubizDK , @orangebucket, @an1uk, and all others who reported on this issue.

I will be releasing a new beta Aqara Button DTH with some significant changes soon, but wanted to squash this incorrect battery level bug in the meanwhile.

However, if you are still seeing incorrect battery level reports after this v1.4.3 update, please let me know!

Please see this post for full details about the Aqara Button DTH and link to the updated device handler code.

Im not sure if this has already been discussed but what to do if xiaomi sensor seems to be unavailable according ST but it works normally?
Even simple device viewer reports that it is available. Sensor reports battery, it senses motion normally etc.
Its just basically that st reports it wrong. Any tips what to do?

EDIT: hub reboot and that helped.

I recently started to use the new app’s Switch Power State so the button’s state is in sync with the actual light. However, I now cannot get the original Xiaomi button to work with the multiple presses. If I try to program a double press the the single press action from the new ST app still kicks in as well as the double press action. If I try programming a “Pressed 2 Times” in the new smart app it doesn’t work.

I have been using ABC Manager to program buttons 2-5, however I need to override the detected button amount. I imagine that if the number of buttons were hard coded into the device handler I might be able to use the new app to program a double click (though I’m not certain that would fix my problem). It would be awesome if it were possible to use the more straightforward Pressed 2 or 3 or 4 times that are found in the new smart app.

I am not a developer and surely miss something here.
Can someone tell me what to do with the src file I find for the sensor in question?

Thanks for your help.

Reiner

@Jani -

This sounds a lot like the “ghost device” issue that I’ve experienced twice now. Rebooting my hub did not help the paired & working device actually appear on my hub’s device list as it did for you, however.

What I had to do is figure out the Device Network ID (DNI) for the device and manually add a device in the IDE with that DNI and assign the correct device handler.

The possible reason for this issue, so-called “stale” device handlers (DTHs) is explained this post I made last week. The advice to avoid it is to view all of the custom device handlers installed on your hub, and re-save and republish them.



I don’t quite understand what you mean here, but I can say this:

Support for the new SmartThings Samsung Connect app in all of the Xiaomi / Aqara device handlers cannot be promised until Samsung officially begins support for devices with custom device handlers. As of today, here is what I see in terms of developer support and documentation on this SmartThings Developer’s page:

Hub-connected device

Currently you can connect ZigBee or Z-Wave devices with either a SmartThings hub or Samsung Connect Home hub. We will offer developer tools and guides for hub-connected devices soon.

Some users have reported some success using some Xiaomi / Aqara devices with the new app, but until full documentation is provided, there is no way to know how to code device handlers to work correctly and take full advantage of the new app.

Personally, I don’t use the new app (in fact, I use another type of hub, Hubitat, with nearly all of my home automation devices and have just continued making improvements and updates to the Xiaomi / Aqara device handlers out of kindness towards the SmartThings Community). But based on all the posts I’ve read about it, I would not at all be surprised that it can’t handle backwards compatibility like what you are describing.

I find it hilarious that this option even shows up when the device handler doesn’t include code to support it.

Although full developer documentation for integrating hub-connected devices to the new SmartThings platform isn’t available, there are some bits and pieces, including an updated Capabilities Reference. Capabilities are the core of SmartThings automation as they define the types of events the device can create for apps to use and/or commands that can be sent by apps to control or manipulate the device.

This updated list of Capabilities includes a new Button Capability definition, which is significantly different from the previous definition. However, both the old and new Button Capability definition support a number of buttons to be set for a device, so presumably the new Samsung Connect app should work with that.

The newest version of the Xiaomi Button DTH, v1.3, does in fact include code to set the number of buttons available to SmartApps, right on line 350. If you had updated from a previous version of the DTH, it’s really important that you followed the note I included in my post announcing the new Xiaomi / Aqara Button device handlers:

If you had updated to the new Xiaomi Button DTH from a previous version, did you follow these instructions? If not, then the correct number of buttons available to SmartApps will not be set.

Either way, I am not sure why the Pressed 2 Times option appears in the new Samsung Connect app, because the current version device handler does not include code shown in the new Capabilities Reference to set the supported button values.

Maybe without that code, the default supported list includes pushed, held, and pushed twice? If that’s true, then what you’re experiencing will happen to anyone using a button with a custom device handler, not just Xiaomi / Aqara ones.

I am testing a significantly reworked Aqara Button device handler which sets the supported button values based on the button model, but this will require users to change automations so the correct trigger is used (for example, change button two pushed for a double-click automation trigger to button pushed twice.) The button values set by the device handler appear as choices in the older SmartThings “classic” app, so hopefully they will work in the new app as well.

After finishing and releasing the next Aqara Button DTH update, I plan to re-work the Xiaomi Button DTH next. I can share an early beta with you if you like. Please just PM me.



You do not need to be a developer to install a custom Device Handler (also known as “DTH”). You will need to install the Device Handler code to your SmartThings Hub.

There’s a very thorough FAQ on installing custom Device Handler or Smart App code here:

1 Like

Thanks. I had not followed the steps to save the preferences so that the number of buttons gets saved. Unfortunately it didn’t help in the new app because it still did not recognize that there was more than 1 button. The new app lists these possible device statuses when programming.

Hello, can the Xiaomi aqara read the atmosphere progression?

Thanks

I finally installed the new SmartThings (Samsung Connect) mobile app, and my initial experience is that it is a total exercise in frustration. I can’t believe this is public release software, honestly.

Anyhow, I am going to have a really really hard time troubleshooting and supporting any Xiaomi / Aqara devices in the new app because for the majority of them, when I try to view them I get a blank screen and nothing ever happens. I have to force-quit the app to use it again. I am using the iOS version of the app, and I have no plans to spend money on an Android device just to get it working. Samsung needs to make sure their platform development teams are on the same page.

However, I think I might have found a workaround for you for the time being.

If you log into the IDE, then edit the Xiaomi Button to use SmartThings’s SmartSense Button device handler, save, and then change back to the Xiaomi Button device handler and save, it should limit the list of supported button values just to pushed, held, and pushed twice. More importantly, I was able to choose the button number, at least when setting up an automation in SmartThings’ Smart Lighting app:

However, I’m not at home to test whether a double-click results in both button two pushed and also button pushed twice events.

At this point, I should state that besides getting a blank screen when trying to view the devices, also seeing that the preference settings section of device handlers is missing, I am not sure how I would be able to properly support the use of Xiaomi / Aqara devices with the new SmartThings mobile app.



Yes, the device handler for the Aqara Temperature / Humidity Sensor supports reading and displaying atmospheric pressure. It does not display the current trend of atmospheric pressure, however (for example “pressure increasing” or pressure decreasing).