SmartThings Community

Ongoing Intermittent Delays


#1

I have been experiencing intermittent delays controlling my devices for several weeks now. I initially noticed this with my Smart Lighting automations not turning on lights when motion is detected. The first few times this happened, I power-cycled the hub. About two weeks ago, it finally became frequent enough for me to contact support. I was told about interference, adding more repeaters, etc. Since my initial contact with support, I have noticed that the entire system seems to become unresponsive during these periods of delay. I lose the ability to control any Zigbee and Z-Wave devices in my home for a couple of minutes or so. Once things start responding again, all of the delayed commands fire off in sequence as if they’ve been queued up somewhere.

Support continues to claim that everything is fine and that I need more Zigbee repeaters even though I have now experienced this with multiple Z-Wave devices and my Z-Wave network is extensive. I’ve been a SmartThings user since 2014, my house is not large, and my hub is centrally located in the hallway exactly where my V1 hub sat. (I upgraded to a V2 hub in February.) I did humor support and purchase a Zigbee outlet to add to my system. It’s presence thus far has had no effect.

Does anyone have any advice? At this point, I’m wondering if my hub has a hardware malfunction.


New 17.00012 firmware causing delays
Random zigbee slowness (and now z-wave)
(Bobby) #2

Keep nagging the support. They can run tests with their brand new diagnostic tools. It does sound like you either have a bad hub or a bad Zwave device. Alternatively, you can spend hours chasing zwave ghosts. I’ve had similar issues and after identifying a bad Zwave device everything went back to normal.


#3

I reached out to them via chat this time and feel much better. Going to try a couple of things to troubleshoot whether it is definitely interference or not.


(Bobby) #4

Keep us posted if you get to the bottom of it. Good luck!


(Jason "The Enabler" as deemed so by @Smart) #5

Allison, you are not alone. I’ve been the EXACT same thing. It affects both zigbee and Zealand and its system wide. I have not contacted support.

I also know that it’s absolutely NOT interference of any kind… RF is kind of my specialty.


#6

Anyone having this problem should definitely report it to support. They’ll need the data points to investigate.

https://support.smartthings.com/hc/en-us


(Dale C) #7

You are NOT alone. I have a similar setup with motion triggering lighting that is random.


(Joel) #8

i’m seeing weird stuff with my lights turning off then on when they’re activated with the normal smartlighting routines. not a one off occurrence either.


#9

the hub is running much slower than it use to with the new firmware update.
setting SHM to disarm which causes the worst delay.


(Aaron S) #10

It’s almost definitely not a hardware malfunction. Honestly, I do not think it’s directly related to the firmware update - it’s more likely that the Hub needed to re-map the mesh networks or something is gunking up (<-technical term) cloud side. I think I found your ticket and will keep an eye on it.


#11

I know it’s not related to the firmware update because it was happening long before that. This has been going on for weeks and my hub only received the latest update last Friday.


#12

For whatever reason, I haven’t had this problem all week. Hopefully, it stays gone. The only thing I have changed in my system is that I’ve been slowly changing my GE Link bulbs to Osrams because I’m tired of the GE bulbs dropping off the network. They’ve been dropping much more frequently since I upgraded to V2.


#13

I went almost a week without any delay issues and now I’ve experienced it twice today. The one this evening was about 5 minutes.


(Joel W) #14

Not only am I having long delays, parts of automations are not working when they were a week ago. My problem started after the IDE Commit command became messed up but during that time my IDE was really fast. They fixed that and everything else slowed up. Now as far as automations go I have similar automations set up in SmartRules, CoRE and Smart Lighting. The pistons were two part. Turn on a light under certain conditions then turn it off after other conditions were met. The turning on works but the turning off stopped. It didn’t work in CoRE either. But in the native App Smart Lighting both parts worked, but a slight delay on the On and off cycle. Now I know for sure the Pistons and Rules worked fine before, now don’t . Also BigTalker has a longer delay than before the IDE fix. It can’t be a coincidence.


(David) #15

Same issue here. Just started bringing things back on-line from a move. Worked great for a few days and now significant problems with all of my z-wave devices and Samsung TVs. I contacted support, they removed a couple of devices that weren’t deleted from a complete hub reset (odd), ran a z-wave repair and things worked… until I closed the chat window. In supports defense, ST support has always been great, I haven’t had time to start a new session due to travel.

Here is what I’ve noticed in the event it is helpful for anyone else:

  1. Running a z-wave repair from the application can take anywhere from 2 minutes to 40 minutes. During the extended time there is nothing in the log. The application simply spins until a ‘Z-wave network repair started’ shows up.

  2. After a z-wave repair I can sit in a room and using ST turn everything on and off a hundred times. Abuse it. Click, click faster, everything works great. Like a kid flipping the light switch over and over but on the app.

  3. Running any kind of CoRE piston works after a z-wave reset. One to four times. After that the z-wave devices (most, not all) stop working. This includes pausing all of my pistons and simply executing a simple ‘if x then fan off’ to eliminate an odd rule.

  4. When broken the log and the app GUI shows in most instances that the command has been executed. Off changes to off, on changes to on and the device under ‘My Devices’ shows the correct state. The physical device does not respond.

  5. Occassionally the devices seem to ‘come back’ but seem to execute all of the commands immediately that I’ve been trying to execute. This can happen after 2 minutes or 30 minutes. Ex: the ceiling fan will turn on and off 20 times quickly.


(David) #16

Ok, after typing the novel I tried something:

I have a CoRE piston that turns on / off a ceiling fan (only z-wave device in the piston), 2 WeMo devices and a Samsung TV. I felt like the ceiling fan device might be causing an issue so I, after a z-wave repair, removed the device (z-wave remove) and re-ran the piston. As before, despite not executing against a z-wave device, all of my z-wave devices went unresponsive but this time after about 2 minutes my hub is now off-line. Oddly enough the light is green and I can ping the hub. Doesn’t look like it’s going to come back until I power cycle it.

Also noticed that my hub up-time is 165 seconds. It’s been 165 seconds for the last several hours even when functional.

Possibly CoRE related?


(Jeffrey) #17

I may as well join the mix. I am unfortunately to scrap this all and move on as it’s just become unusable now no matter what I do. It’s been more or less great minus the last few weeks or so.

My issues are similar but only seems to be zigbee powereddevices. I only have one z-wave outlet and always seems fine - have another coming today.

I have 4 smart plugs that are a few different brands and zigbee. I can now basically barely control them if at all.

  1. If I reboot the hub they work perfectly for a few minutes but will start to slow down to many minutes or not at all within 30 minutes.
  2. Testing only local processing by using smart lighting and having one control the other seems to work fine and a few hours of testing. instant response. This was with network cable unplugged.
  3. It now takes between instant and 20+ minutes to get a response from a device or sometimes not at all.
  4. If while the “delay” is happening I press the button on the device the update is instant in the app.
  5. Support is just going in circles and it’s become pretty useless.

I have literally tried everything. unplugging devices, moving hub in the same room, disabling wifi.

Not sure what my next move is but I am out of ideas and this totally sucks! Got told my smarthouse wasn’t so smart today - that hurt lol.

@Aaron - I can ask for my ticket number if you can’t find it if you wouldn’t mind watching it. I am losing my mind on this one.

*EDIT

I now have delays on z-wave devices also. Before I only noticed it on zigbee as I have more of those and don’t control the z-wave often but today while having slowness I tried to turn on a z-wave outlet and nothing. It updates the app fine if I control the outlet manually but I can’t control from the ios app.

It’s now a full on mutiny with both sides against me


#18

You are not alone, I have opened a ticket for similar issues. I have a “goog night” routine that executes several commands, most worked but my zigbee and zwave devices did not turn off until I started to unscrew one of my zigbee bulbs… strange :confused:


(Aaron S) #19

Sure - feel free to DM me the ticket and I’ll see if we can poke at it a bit.


(Jeffrey) #20

Thanks Aaron - as soon as I figure out what the ticket is I will send along.