One of two nests crashing ios app

I have two nests in my home and am using https://github.com/smartthings-users/device-type.nest
to integrate with them. this has worked fine for a long time but recently one of my two nests has started causing the ios app to crash every time I open that device in things. the other one works fine… I have tried deleting the offending nest and recreating it, sadly same issue…

any ideas???

Read this.

1 Like

Thanks a ton!
20 cha…

Sorry to ask, but could you expand a little on what you did to change the name of presence to nestPresence please? Thanks in advance.

In the code I changed “presence” to nestPresence. I am guessing presence is a special keyword, and has different behaviour.

Ah gotcha - thanks very much!
I’ve managed to get it going now - thanks again.

“presence” seems to be all over the place in the code. Change all of them or some specific set of them?

Thanks!

Got it, I think:
I replaced ‘presence’ with ‘nestPresence’ - note the single quotes were typed.
and presence" with nestPresence" - note the double quote was typed.

I have a strange character in the temp number display “”. Right before the degree symbol. What is that supposed to be? I must have the wrong font or something…

Thanks!

1 Like

Brilliant! This worked for me! Hurrah!