One of my Smart Lighting Rules stopped working


(Michael A Biglin) #1

I have a IRIS plug adapter that has a lamp plugged into it. I have “Smart Lighting” set up to turn this light on when the presence sensor shows my phone has arrived, but only between certain times. It worked up until about 10 days ago. Now it won’t turn the light on at all. I removed the “smart lighting” app and re-created it several times, but it didn’t work. I have also rebooted the hub.
I can turn it on manually within the app, but that kinda defeats the purpose. If I add it to the “I’m Back” routine, it turns on, but I can’t restrict the time of day that way.

Other smart lighting things work, such as my “dusk to dawn” light.

I’m still on the classic app. Haven’t gotten notified to merge apps yet. I already have it because of other samsung products, but I’ve had it for quite a while so I doubt if that is the issue.

Any Ideas?
Thanks


#2

Did you change anything 10 days ago? Did you update the DTH for the smartplug? You say you have tried recreating the program…have you tried with a different device? When you go into smartlighting, Have you made sure that your presence sensor shows the correct status (Present vs Away) and that this location updates when you arrive/leave? What are you using for your presence? If a phone, iOs or Android?

If you could run down those answers that would be a starting place to debug it.


(Michael A Biglin) #3

Didn’t change anything.
Did not update DTH.
Presence & Location are correct and updates correctly.
It turns off when I leave when “Goodbye” runs.
Time on phone is correct
Android Pixel 2

I did not try a different device. I have just set up a different device. Will see what that does next time I leave.
Thanks


#4

Wait…when you say “I have just set up a different device” do you mean another android phone logged in with the same SmartThings account? If so, then that is your problem. I did the same things and all of my presence automations broke. If you want to be logged in on 2 devices, I would create another email address and authorize that on your hub and sign into the ST app with that email address.

To fix your presence, delete your presence device and make sure you are only signed into 1 device. Now re-add the presence device from the Classic app on your phone. You’ll then have to re-add presence to your automations but they should work then.


(Michael A Biglin) #5

Sorry, I set up another plug adapter.

Now, I have been logged into both my phone and a wall mounted tablet with the same email for about a year now, without any problems.

I will try what you said and see if it works.


#6

It all depends on the order you do things. I’m just sharing the experience I had. I logged in and then out of an iOS device when my presence sensor was on my android phone and my presence routines would not work again until I deleted and re-added my presence sensor. Was there another cause for it…possibly. But if nothing changed, it would still be working, right? And you said that you just finished setting up another device. So, MAYBE the thing you did affected it. But hey, it was probably Gremlins.


(Armando Zarco) #7

I am having the same issue here, all of a sudden all of my smart lighting automations are not functioning.


(Joseph Fattizzi) #8

Go to the IDE and logon. Go to your locations and click on the location you want.
Then click on Installed SmartApps and go down to Smart Lighting.

Click on update next to the one that is not behaving nicely.


(Michael A Biglin) #9

Well !@#$.
Presence sensor was the first thing I checked when the problem started, WAS working fine. Double checked while I was at work today and now it isn’t working. I logged out of my tablet, then removed and re-added my phone, then redid my routines. Have to see if it works tomorrow.


#10

Any update just to close the loop?


(Michael A Biglin) #11

Sorry, forgot to update. It’s working fine now…
Thanks a lot.