Oh GOD, a newbee question! (Iris Smart Fob)

OK, I’m a complete newbee. A refugee from Iris. I have a ST hub installed and I installed one GE light. Works OK!

Now I want to install the Iris Smart Fob. So, I studied this forum (so much great information) and found that a generous user had written an app for that device. I followed the directions and added the code to the developer page “From Code” When I hit the “Create” button I get an error message that means nothing to me. I tried a different app just to make sure, and I get the same type of error message. I have to assume the app is correct, so I can’t figure out what’s happening. Can’t get past that screen. I.m sure I’m doing something wrong, but I cant figure out what. Any help will be gratefully appreciated.

Here is the error message text:

No signature of method: script14723192597681316881706.metadata() is
applicable for argument types:
(script14723192597681316881706$_run_closure1) values:
Possible solutions: getMetadata(), getState(),
setState(java.lang.Object), metaClass(groovy.lang.Closure)

Again, thanks for your patience and help!


Are you sure it was a smart app and not a device type handler? They get installed into different places in your account library.

See the following custom code FAQ and check the steps to make sure that you were doing the one that matches the code that you are trying to use.

( and don’t worry if you weren’t, we’ve all made that mistake at some point. :sunglasses:)

If you do have the right process, then ask your question in the thread where you found the code, since that will be the fastest way to get an answer.

I knew I was doing something really BASICALLY wrong, but I just couldn’t see it. Thank you so much. I added the code to the DTH page and everything worked fine. I attached the device to the handler and now it turns on and off that GE light switch. Now I have the confidence to port the many other Iris and other devices to ST.

Thanks again.


1 Like