[OBSOLETE] Xioami Zigbee Door/Window Sensor, Motion Sensor, & Smart Button Device Type

I’m not having much luck either. Was able to get it paired one time, but it’s hit or miss.

Thats correct… the initial pair takes sometime… i was sitting there resetting the sensors multiple times, until the “Thing discovered” comes up on the App Screen.
My Sensors are still working so far.

Let’s see if they will have the same fate as the HUE Dimmers and will disconnect after some weeks. FYI im also on Hub V2

I just received delivery of my first Mi button. It carries the markings WXKG01LM, 2015DP0290 mentioned elsewhere in this thread.

I nearly gave up on the pairing, but persevered with and eventually it found it.

Some observations / steps I took:

  1. Copied the device handler from Github, added and published it in the Smartthings web IDE/API.
  2. On my phone, I select ‘Add a Thing’, ‘Start looking for Things’ and then the search appears to begin.
  3. While the search is running, I used a pin to press the button through the hole in the bottom of the switch. A short push gives 2 short flashes of the blue LED. I tried this around 10 times, with 10-15 seconds in between each push. The phone didn’t acknowledge any thing as being found.
  4. I tried a long push. The LED responds with 3 flashes, a pause, 1 flash, a pause, then 1 long flash. Still no device detected.
  5. More short pushes, perhaps another 10 or so, and eventually a thing was found. I had nearly given up!
  6. In the IDE, I edited the Thing and assigned the correct device type. I’ve only had it working for an hour or so, but seems great so far.

I have it set to turn a light on and off that the kids have been playing with non-stop - it should get well tested. Any problems - I’ll report back.



Well, I checked it 2 hours later, and it wasn’t working.
I deleted the device, and have been trying for 15 minutes to reconnect it - no joy.
For me - things don’t look good :frowning:

1 Like

This is so weird. This is exactly the behaviour i had before.
Now both my devices are still working perfectly fine.

Can you post a screenshot of your device? Mine currently looks like this:
I believe it previously never showed an “Endpoint ID”.

This is the info from my account when the sensor was added several months ago. It does not have the “Data” section filled in or anything for “Raw Description”:

Your device definitely looks like the inclusion process was more complete. I wonder what the difference was.

Hm, i have the “unsecure rejoin” in my Zigbee utilities activated. Maybe thats it?

Here is mine (captured several days after install, following it stopping working after 1 hour)
Another potential difference - I am based in the UK so have a UK hub, and use the graph-eu01-euwest1.api.smartthings.com web interface.

I’m also on the UK Hub with EU01-EUWEST.

Do you have unsecure rejoin activated in your Zigbee Utilities?

UK User here with unsecure rejoin activated.

I added a motion sensor that lasted a couple of hours before dropping off.

Very weird behaviour… wonder if this can be debugged somehow… maybe somebody from Smartthings team can give some pointers where to look? How to make this visible to them?

I have unsecure rejoin activated also. Here is the full ‘data’ field from my hub in case you can see a difference with one of your settings:

appengineConnected: true
appengineEnabled: true
appengineVersion: 1.4.1
backupVersion: 0.0.0
batteryInUse: false
bluetoothRadioDetected: false
bluetoothRadioEnabled: false
bluetoothRadioFunctional: false
bootloaderVersion: 0
hardwareID: 000E
hubcoreVersion: 000.015.00008
localSrvPortTCP: 39500
localSrvPortUDP: 0
macAddress: D0:52:A8:53:EC:A8
originalZigbeeEui: D052A853ECD00001
presenceTimeout: 2
updaterVersion: 80
uptime: 838673
videocoreVersion: 0.8.16
zigbeeChannel: 14
zigbeeEui: D052A853ECD00001
zigbeeFirmware: 2.1.10
zigbeeNodeID: 0000
zigbeePanID: 1A11
zigbeePowerLevel: -14
zigbeeRadioDetected: true
zigbeeRadioEnabled: true
zigbeeRadioFunctional: true
zigbeeUnsecureRejoin: true
zwaveControllerStatus: 09
zwaveHomeID: D65AFBF2
zwaveNodeID: 01
zwavePowerLevel: full
zwaveRadioDetected: true
zwaveRadioEnabled: true
zwaveRadioFunctional: true
zwaveRegion: EU
zwaveSerialVersion: 4
zwaveSucID: 01
zwaveVersion: 4.05

Other than having other Network Address the only difference is my Zigbee Channel being 15.

I can confirm I had same drop off the network after 2 hours with Xiaomi motion and door sensors. It’s a smartthings zigbee issue I think. Possibly interference with WiFi from what I read in other threads in the forum. I have the exact same issue (drops an hour or two after joining) with Iris (Lowes) smart button.

One more update… Button and Window Sensor still working.
However, i bought a Motion detector now and tried pairing it with smartthings. Same weird problem i had early happens. My HUE Smartapp (this time im using reconnect, not ohmyhue) keeps catching the Zigbee fingerprint and not my smartthings it self. So i cannot add the device.

To the people trying to pair the device and having no luck. Check you live log if one of your smartapps actually catches the fingerprint… I really do not understand that behaviour at all…

And another update…

After removing the Hue Smartapp, i was able to pair the Motion Sensor as well. It took quite a while as I had to reset it several times. I still do not know why it only works sometimes. Maybe it has to do with the amount of time you hold the reset button?

Maybe after 20-30times resetting it finally connected. The first time tough it showed a Zigbee and Network ID of 0000. And it didn’t work. Next try, and several resets later, i seem to have a fully connected Motion Sensor.

Hoping it will stay active with Smartthings same as my other 2 sensors from Xiaomi.

Below an image from the motion sensor:

And another update… as they say… never change a running system…

I deinstalled my Hue (RE)Connect Smartapp to be able to add the Motion sensor as i described a post earlier. And since then, all the Xiaomi Sensors drop.

I even reinstalled ReConnect and tried to do everything as i had it before… no chance. 1h and all the devices are gone. This is especially annoying as i KNOW that it can work. It did for more than a month…
NOTE: Once i deinstalled the Smartapp, i actually had a drop of ALL of my Zigbee devices. So my Smartthings multisensor, my Zigbee Plugs & all of the Xiaomis.
Somebody from Smartthings team really should investigate whats happening.

Sorry to hear that :frowning:
Did anyone raise a support ticket @ Smartthings? Might be the next idea. Or are there any staff that use the community we can bring into the discussion?

What about Xiaomi Cube? http://xiaomi-mi.com/mi-smart-home/xiaomi-mi-smart-home-cube-white/ I guess it is a good replacement for ST in Mood Cube app.

ST will say they won’t support becoz it’s not a supported device?