[OBSOLETE] Xiaomi Sensors and Button (beta)

Anyone tried to pair this xiaomi/phillips light controller with temperature e and humidity sensor?

wow, this is a long thread.

I have been reading through trying to find someone with the same issue as I have, but so far haven’t found it.

Unlike most of the posts, I am not having any issues pairing the Xiaomi Buttons or Door/Windows Sensors.
They come up as “Thing” when trying to pair and then pair successfully.

My problem is, the button or sensors do not show anything in the app.
Pressing the buttons doesn’t change the status on the app at call.

I have tried both a4refillpad and bspranger device handlers with no affect.

Has anyone had this issue? How did you resolve it?

I have tried re-pairing the buttons several times, each time resetting them, same issue.

I bought a number of these buttons and sensors based on the positvie feedback from these forums, only to find that I haven’t been able to get them to work :frowning:

Any help would be appreciated.

What is it that you are expecting to see happen? The button is a momentary action. You press the button and it immediately returns to its original state, so you won’t see anything in the app really happen. It’ll flash blue briefly, then go back to gray, the status never changes. In the “Recently” tab for that device, you should see “button 1 is pushed” “momentary is pushed” every time the button is pressed.

I’ve had my Xiaomi sensors working well for a while now. Question: has anybody got them integrated with Google Home via Smarthtings hub, using these DH.

I want to ask Google Home, what is the temperature in Cramer’s house? (and the like).

Thanks, George.

Look into Ask Alexa or Echosistant

I’ve been using your DH’s on my Aqara door sensors for a few weeks and the battery only reports 100%. I looked into the smartthings logs and noticed that whenever I tried to do a refresh it kicked the error “java.lang.IllegalArgumentException: Needs to be string or int, received null value”

Further investigation led me to this thread where it mentions the issue may be because I added it via the catchall method. Adding that line (device.endpointId = 1) does solve the error in my logs but my battery percentages still stay at 100%.

Is there something else I can check? or a log I can look at?

Are your buttons the square based aquara ones? If yes then it’s a little bit tricky. You need a different device handler, the one made by Terk (you cand find it easily if you search the community). After you install terk’s handler it should work fine, even if the app doesn’t show the button as pushed.

I stumbled into a bit of a problem. I have 5 aquara temperature/humidity sensors. All of them work fine, except for the occasional battery value fluctuation. Yesterday I tried sticking one of them to the outside of my window to get the outside temperature. The temperature outside is about 7-8 degrees C. The window has double glass, but even so, the smartthings hub is about 80cm from the window, theoretically it should work, but the sensor froze. I couldn’t get a reading for hours, then it went inactive. The moment i took the sensor off and brought it inside it came back to life, started registering the inside temperature normally. Even stranger, I looked in the events section and it showed multiple temperature readings, as the temperature was dropping, all at the same time, the exact moment it froze. What do you think? Is the window blocking the signal or is the sudden temperature difference blocking the sensor? Any ideas?

Did you unplug the hub for 15 minutes so it can rebuild the Zigbee network after you moved it outside? If not it may have been paired to another Zigbee repeater and moving it caused it to drop the connection.

thanks for the replies guys.

the exact model number is the following:

I am aware they are only momentary, however, I don’t even see it flicker blue and nothing is shown in the recent events:

Doesn’t look fully paired, This is a V2 hub right, V1 they don’t stay paired to? It should be showing a checking in and pushes. Mine checks in every hour.

No, I didn’t reset the hub. But will try. So far I deleted the sensor, turned off all of the other power connected zigbee bulbs in the area and then paired the sensor again, but that didn’t work, but i didn’t turn off all the bulbs in the house, so maybe you’re right.

L.E.: reseted the whole thing, it now works like a charm

1 Like

The temperature sensor doesn´t report correctly when the temperature drops below zero (celsius).


Mine is ok ,its the aqara one,and in celcius too

Hmm. Wierd. Mine is Xiaomi (not the Aqara). Did drop from 0.2 ´C to 100.6 ´C.

I think there may have been a fix to the DTH to handle negative temperatures fairly recently. Does that sound familiar to anyone?

Yes, my DH has the fix

Anybody from UK having pairing issues with xiaomi sensors after last firmware update 16.11.2017 ? firmware: 000.019.00017.

Saw your post and took a brand new Aqara Door/Window and Motion Sensor out the box and they both paired after about 6 or so button presses so no issues here. What are you experiencing?

I have 3 Xiaomi Aqara water sensors, one xiaomi door window sensor, two Xiaomi Honeywell fire alarms that I need to pair, but no chance to pair, not via app/button presses and not via catchall.

I have a lot of xiaomi sensors that is functioning perfect, 8 xiaomi temp/humidity sensors (catchall connected), 15-20 xiaomi door window sensors (connected via app/button presses), one xiaomi button (connected via app/button presses), one xiaomi cube (connected via catchall), one Xiaomi Aqara water sensor (I believe I connected that catchall)
My last successful pairing was Wednesday 15.11, then I catchall paired 4 xiaomi temp/humidity sensors.
Only thing I can se is different is that there was a firmware update Thursday 16.11.