[OBSOLETE] Xiaomi Sensors and Button (beta)

So I Did the paring magic dance, not sure how or when but it works!

So I have the button on the SmartThings app, it can trigger routines. progress!

But this is what I am trying to do, please advise:

1/ Click button -> change my Arlo Q cam to disarm
2/ Same click button-> change my home monitor (ST) state to disarm (home)

now I know I can do the ST state part using a routine, (it always felt strange that a simple routine can disable a security system but ok)
What I don’t get: how to I trigger changing the Arlo camera state? and very important to note here: while discovered, I am not letting ST control the camera. that just made it all work strange, making it disabled when I wanted to access it, sending notifications when I don’t want to… the Arlo app is much better. so I use it.

So the question is, can the button trigger via IFTTT, stringy or anything else the arlo cam state? any ideas?

Great idea Thank you but I’m not looking to pay for own information on a free project LOL
Action Tiles charges users…

If you feel like seeing up your own website host, you can use House Panel. No cost, and the developers are very active and helpful. Search for it here on Smartthings forum.


Hi I’m new to ST and the community. I’ve been successful in setting up my Hub on my Nvidia Shield, and I’ve been able to add some TPLink Smart Bulbs and my Garadget Garage Door Opener.

I tried taking another step and got a couple of the Xiaomi Smart buttons to use to turn off and on a couple lamps that are on TPLink Smart Plugs, but I’m not able to pair the smart button to the Hub.

I’m able to copy and publish the device handler for the Smart button and that seems straightforward (and I’ve double-checked I’m adding the device handler to the location/hub correctly).

When I try to pair them using the steps outlined in this link my Hub never finds them.

So I tried using this alternate method provided in this article, and I’m able to create the device manually, but the device never seems to register a click with the hub.

I’m computer and gadget literate but I really don’t know where to go from here to troubleshoot, would anyone have any suggestions?



I used to run my SmartThings hub using the SmartThings Link for NVIDIA Shield. After hours and hours of trying to get Xiaomi devices to stay connected, I gave up. ST Support made it clear that the ST Link uses different hardware than the standalone v2 hub, and the firmware for the ST Link is on a completely different development schedule. So I got a v2 hub, and… ta da! Everything works great.

I have shared my experience here on the forums, and have seen at least 3 other ST Link users report no luck in getting Xiaomi devices to work for them. I don’t think any of them were trying to use the smart button though, so I can’t say for 100% sure. Just be aware that ST Link users seem to have nothing but trouble with Xiaomi devices. I wish I could be more helpful…

Thank you I’ll look into that… I understand the need for security but had I known Samsung was going to make it this difficult I would have gone in a different direction.

Actually, that’s hugely helpful, saved me lots more headaches to hear it’s not just me… Maybe I’ll buy another hub.

Honestly, you’re going to find a downside with every hub. I have Insteon, Wink, SmartThings, Hue, Lutron, and Harmony. Together they provide a lot of options, but each alone has strengths and drawbacks. Consider instead buying better sensors. There are a lot of great options available. SmartThings is unique in being a commercially available hub that can control just about anything thanks to the dedication of the community members.

Samsung is putting a lot of money into the platform and there are bigger plans coming together this year. If you’re looking for a plug and play hub, I think you will like Wink, but I wouldn’t give up on SmartThings. As you get more into smart home gear, you’ll find there are some pretty interesting things you can do with it.

Well the sensors aren’t the problem getting to your own information is. Like I said I understand the need for security but honestly there is not one reason I can come up with that shouldn’t allow a user to get their to own data without jumping through so many hoops… :slight_smile:

Same boat here, getting a v2 hub to replace my Samsung connect :frowning:

1 Like

Well for anyone asking my temp/humid sensors have been connected and working great for a couple weeks now! :slight_smile: Thank you all for your help!

1 Like

Depending on which button you have, you might need a different device handler. If like me you have the square shaped button, then the device handler on this page won’t work (well it didn’t for me). I was getting “check-in” responses but the actual button push didn’t register. The device handler from this page worked for me:


No support for the “hold” function but at least you can use the button!

I have purchased a couple of the Aqara Motion Sensors.
I’m using the DH from bspranger : Xiaomi Aqara Motion Sensor.
I notice that the motion active time can be set in the settings for the device.
No matter what I set it to, motion stays active for 2 minutes before it goes inactive. Is anyone else getting this?
Is this correct or is there a bug.

Bob, you should probably run over to this thread and read through it. It’s a mixture of information on the Xiaomi Sensors, but when you read through, I believe there is some fairly recent information about these Motion Sensors.

As a note - this is a bug -update should be released in next day or two

@RBoy, any chance you can look into this as your next DH project?

Please send in a request to our support team, if enough folks want it we’ll be happy to do it.

Thanks, I will send an email to make the request.

For anyone else wanting to request integration of the Original Xiaomi Universal IR Remote Controller, you can email RBoy support at;

support @ rboyapps.com

If this IR controller was through Zigbee then there would have been a possibility. Xiaomi infrad red controller is based on Mi cloud and it communicated over Wifi. So the authentication has to be done at Xiaomi clod level. Which Xiaomi has to agree and sign contracts with smartthings which is unlikely to happen any time sooner, because xiaomi smart home target market is just china

So I installed this DH yesterday after I got a Xiaomi Aqara from ebay. Everything works great. Then I decided to try it in the fridge, no problem at all. Then today I tried putting it in the freezer and now I got some really interesting values. It reports back temperature at 120 degrees celsius which is “somewhat” high. :slight_smile:
(freezer is set to -18 degrees)

So, do I have a faulty sensor or is it a bug in the DH?
Using a v2 hub.