[OBSOLETE] Xiaomi Sensors and Button (beta)

Please try my DH and let me know if it works.

Hi, I’m already using your DH
I already tried removing and adding the motion sensor again but still no getting any battery status or lux

Please send me some logs via private message.

I do not have one of these sensors to test.

Can anyone advise as to what the Smart Button can be used with in terms of smart app?

I have tried with Smart Lighting smart app but when I press the button nothing happens. Ive set the app to turn off the light on click. Maybe there is a better app to use or maybe i have missed something?

Its online…

2018-01-08 5:17 PM GMT - moments ago button released
2018-01-08 5:17 PM GMT - moments ago button pushed
2018-01-08 5:17 PM GMT - moments ago button released
2018-01-08 5:17 PM GMT - moments ago button pushed
2018-01-08 5:17 PM GMT - moments ago button released
2018-01-08 5:17 PM GMT - moments ago button pushed
2018-01-08 5:07 PM GMT - 10 minutes ago button released
2018-01-08 5:07 PM GMT - 10 minutes ago button pushed
2018-01-08 5:06 PM GMT - 11 minutes ago button released
2018-01-08 5:06 PM GMT - 11 minutes ago button pushed

Use Button Controller in the Marketplace under Smartapps “MORE”.

That doesnt seem to work either. Why do you get 4 buttons to configure? I only have one…

Also I dont see the option to turn on/ off

Simple, just set up one button. Make sure you name it. Then set the first button to pushed and the device you want to control. Then click next until you get passed the other three buttons. Then save it. Now to work it you usually have to push it and hold 1 second for it to work. This is a simple app no need for it to show a menu for on / Off it does it. Make sure you pick your button controller that you installed and originally named.

I dont get the option to change the name. And this still didnt work. Is the default action to turn on or off?

You aren’t changing the name. Here are three screenshots.

The last is just the Save in top right.

Just tried this. It doesnt seem to work. Maybe something up with my button?

!. Does it show in the SmartThings App?
2. Go to Live Logging in the IDE and press the button.
Post what you see under the name of the button.
3. After you set up the button Controller app got to the device in the SmartThing app and press the button and see if the lights work.

Also post what you see in logging for the button controller.

35ad0b7c-d217-48c1-9178-031e1c0a835a 18:12:10: debug Found 1 events in past 3 seconds
35ad0b7c-d217-48c1-9178-031e1c0a835a 18:12:10: debug button: {“microDeviceTile”:{“type”:“standard”,“backgroundColor”:"#ffffff"}}, value: released
35ad0b7c-d217-48c1-9178-031e1c0a835a 18:12:10: debug buttonEvent: button = released ({“microDeviceTile”:{“type”:“standard”,“backgroundColor”:"#ffffff"}})
35ad0b7c-d217-48c1-9178-031e1c0a835a 18:12:10: trace timeOk = true
35ad0b7c-d217-48c1-9178-031e1c0a835a 18:12:10: trace daysOk = true
35ad0b7c-d217-48c1-9178-031e1c0a835a 18:12:10: trace modeOk = true
35ad0b7c-d217-48c1-9178-031e1c0a835a 18:12:09: debug Found: false for notifications_3_pushed
35ad0b7c-d217-48c1-9178-031e1c0a835a 18:12:09: debug executeHandlers: 3 - pushed
35ad0b7c-d217-48c1-9178-031e1c0a835a 18:12:09: debug Found 1 events in past 3 seconds
35ad0b7c-d217-48c1-9178-031e1c0a835a 18:12:09: debug button: {“microDeviceTile”:{“type”:“standard”,“backgroundColor”:"#53a7c0"}}, value: pushed
35ad0b7c-d217-48c1-9178-031e1c0a835a 18:12:09: debug buttonEvent: button = pushed ({“microDeviceTile”:{“type”:“standard”,“backgroundColor”:"#53a7c0"}})
35ad0b7c-d217-48c1-9178-031e1c0a835a 18:12:09: trace timeOk = true
35ad0b7c-d217-48c1-9178-031e1c0a835a 18:12:09: trace daysOk = true
35ad0b7c-d217-48c1-9178-031e1c0a835a 18:12:09: trace modeOk = true

f127b717-b601-4e35-887e-6f2273bba36e 18:12:10: debug FB53: Parse returned [name:button, value:released, descriptionText:FB53 was released]
f127b717-b601-4e35-887e-6f2273bba36e 18:12:10: debug FB53: Parsing ‘on/off: 1’

I am not sure your button is set up correct in the devices. Here is mine for the device. As you can see it is just the on and off.

Are you in Live Logging in the IDE?

1 Like

Yes in live logging.

OK, I am not an expert. But I think your button is not paired properly. I would remove it and follow these directions.
Try this, near the hub:

On the sensor, hold the button until it flashes, then release and wait until it flashes (takes 10 seconds?). This should reset the sensor.

In the app click add a thing.

Press and release the button on the sensor. Wait 10 seconds for the sensor to stop flashing.

Continue step 3 until the sensor appears in the smart app. May take 5-10 presses.

In the web interface look at the hub events, you should see th catchall from the sensor and also a zbjoin.

Leave the sensor near the hub and hope it starts to report battery.

If it fails, try, try again…

You can forget about the battery reference. But copy the catchall 4 letter number code, incase you need to install it with the catchall it is the numbers and letters following the 00000000000 zeros. in the IDE Hub events list.

I did this originally. Maybe im using the wrong DH?

I have done again, see below:

OK Looks good. Set up button controller with the lights you need to control. Then press the button first in the app. Not the actual button. The light should come on. But hold the button for about a second if that works and you are trying the actual button. Are you using the round button? This is the correct DTH. https://github.com/a4refillpad/Xiaomi/tree/master/devicetypes/a4refillpad/xiaomi-zigbee-button.src

Are you using the button daily? I’ve been able to successfully pair/operate, but I’m having to double press the button whenever I want it to activate.

I thought mine was not paired properly, but I found if you push the button and hold 1 sec. It works. If not after the second press once more. Some people have that double push problem. But wait a second as it might be delayed.
Iam using this DTH.

Hi can I ask how you paired your button ? I’m having zero luck