[OBSOLETE] Wink Relay - Custom SmartThings Integration

Okay, that’s weird. And no Play Services either then I take it?

I was able to disable the OEM app and it calmed down.

1 Like

Hello, I am trying to connect the relay to ST and my ST app can’t find it. So on the relay, I followed those steps to obtain root and king root says it is good, the STwink app is installed and working, factory wink stuff is gone. The IDE account has the smart app code and the device handlers. What can I do to troubleshoot this? ST app says it’s searching and never finds it, the relay is connected Ted to WiFi, I tried the manual connection with winks IP address but that can’t connect either. Any help would be greatly appreciated, I would really like to connect the relay.

Is the Wink Relay on the same network as the SmartThings hub? And is there anything on the router/network gear which could be blocking the SSDP discovery?

Also, can you access the STWinkRelay built-in webserver directly:

Thank you so much, I must have connected the relay to the guest network while setting it up, it didn’t even cross my mind to double check that. It is working as it should.

1 Like

is there a way to completely revert back to complete stock for the wink relay? i’ve been having some issues with it restarting and wanted to see if it behaves this way in stock too.


Hard reset of a relay

  1. While holding top right switch (physical button) on Relay, press soft reset button underneath faceplate
  2. Continue holding top right button until “System recovery” screen appears
  3. Press bottom switch twice, or until “wipe data/factory reset…” is highlighted
  4. Press top switch once to select “wipe data/factory reset…” option
  5. Screen will display message - “Confirm wipe of all user data? THIS CAN NOT BE UNDONE”
  6. Using bottom switch, navigate down until “Yes - - delete all user data” is selected
  7. “Wiping data… Formatting /data…” screen will appear, followed by original “System recovery” screen
  8. Press top switch to select “Reboot system now” option. “ERROR” may appear on screen, this is normal.
  9. Relay will reboot, and should eventually load main Relay home screen. If home screen does not load, Relay may require one more soft-reset (press button under faceplate).

it’s weird, I did that and it still has all of the modded stuff on the device. it’s as if factory reset didn’t take

1 Like

I had that happen on one of my Wink Relays. I call it the “Groundhog Day” relay… it’s like it is stuck at a very specific point in time. Everytime I would reboot it, it would go exactly back to all the files and configuration that I had at that specific day. I could then make updates to the device, load new apps, etc. and it would run fine until it rebooted. At which point it would revert to the state from that one specific day.

Edit: No wonder Wink used to be owned by ‘Quirky’ :stuck_out_tongue:

1 Like

:joy::joy: i have been having the same issue on one of my Wink Relays. I can’t seem to get it to reset

1 Like

I’m in this same spot. I didn’t have this issue before I installed this though. Could it be something with this app triggering the file system contents to be restored?

Joshua - you are a hero.

I had always looked from afar at the relay as I liked the form factor, but was put off by the Winkness. Having been burned by Insteon devices dying too many times, I was looking for an alternative. Smartthings is good, but is lacking in remotes and control panels. This fits the bill really well.

I have two feature requests, both related to the proximity sensor:
a) Can we have an option to wake up the screen based on proximity? This was a nice feature of the built-in software. I’d recommend a slider to set the threshold, then it can be tweaked for everyone’s preferences
b) The device is really lacking a home button. Could the proximity sensor be used for that? When it gets over a threshold (~40k) for mine, could the app fire a home action?

Is the source for the client APK available?

1 Like

As far as waking up the screen based on proximity, I think you can do that using WebCORE and a IF commande

I have noticed that my two relay gets freezed every 3 or 4 days. No buttons are responsive nor ST app control.
After a soft reset (Under button push) everything gets back to normal.
It may seems that reseting them every 3 days is not to much, but its kind of anoying… and routing do not work when freezed.
Any thoughts on this?

I’ve also noticed the same issues on all 3 of my Relay’s. I also noticed that the wallpaper is changed back to the default once I power cycle it. I have the OEM app disabled too.

I’m having the same issue as ered15. I’ve got the Relay rooted, got the app version 0.4.0a installed and have published the SmartApp, DTH, and child DTH. When I run discovery, it does not find the Relay, nor does adding it by IP address work. I have confirmed that I can browse the Relay from my PC and see the device.xml file there. Can you please offer some pointers on where and how I would go about adding logging statements to the SmartApp as you recommeded? Thanks.

@joshua_lyon Thanks for creating this and Sharptools.

I am up and running and able to control the Wink Relay fine via the device handlers. I’m not having much luck going the other way in using WebCore to execute actions based the proximity sensor. It seems Webcore gets no events from the Wink Relay when I enable full logging.

This is what I am trying to do in WebCore

Anyone else seeing this?

Try using the proximity attribute which is a numeric proximity value.

That did the trick. Thanks for the help!

1 Like

The problem was my router for some reason eas blocking the discover of device… what i did was hook smarthings and wink relay to an old router and discovered the device than went back and manually changed the IP from the wink apk. Hope thks helps.

1 Like

Just wanted to ask if at this point the only way to map the physical buttons on the relay to run ST routines or things is to setup webCoRe?