[OBSOLETE] Visonic Powermax Alarm

Same experience here with Powermax +

I can perform the arm function but cannot see status or zones

I bought my system about 6 years ago

Ross

Hi all,

Just to keep a running log, I have just updated the instructions a bit since I have changed from having a ‘multi zone’ device handler, to having one for contact sensor and one for motion sensor, this is so that it works better with CoRE. It now works perfectly on both contact and motion sensors (having a multi sensor doesnt work 100% with CoRE).

Next step is Powermax+/Pro. It looks like I can get a device off Passy for me to test with and hopefully this will allow me to fix things!

2 Likes

Well done cjcharles, thanks for the update. I’ll try the new device handler and CoRE functionality later.

Top Man !

Sorted - nice one…! thanks again.

I had a little issue rolling back for your info, obviously I had already got this working. so removed and added device handlers and new app. however the remove zones at the bottom of the app did not work so had to manually remove the devices. no biggie, but thought you may want to know.

For info sometimes the state of the devices in the app list don’t appear to update however if you go into the device itself it normally updates and also if you check the device activity its clearly working properly. I do however think this is a function of the Smartthings app itself as its not the first time i’ve seen this.

Well done cjcharles home you wasn’t up too late.

Nice one again.

1 Like

Yup, I think ST is being a bit laggy at the moment. Ive noticed it on other device handlers recently. I think this will be a temporary thing and it shouldnt stop any CoRE routines working, its just in the display side.

And Ive also just added SSDP to the firmware, so the device should now appear inside Windows and your router table more reliably, without needing to use an IP scanner.

If you want to update the firmware then just go to your device IPADDRESS/update and upload the new firmware. Though other than SSDP there are no changes.

Hello everyone.

I have all the bits that I need to attempt connecting up my PowerMax Pro and before doing so to try and save any errors, could I ask which port is preferred/works with the Wemos ? I have checked the link for the Complete here. I have an existing Powerlink + and that is cabled into the dual RS232 module. There is also a PC/IP 10 way connector on the alarm main board which has now left me confused. I’ll get going on this asap and report back here. @cjcharles if you wish for me to packet capture the comms between the PL and the alarm, I’m happy to do so.

Thanks everyone, in advance.

1 Like

Install it as though it was the powerlink, that will give the best chance of success. No need to sniff the protocol unless it doesn’t work… If that happens then it might be useful to see how that compares with the powermax+ that I’ve now got and will hopefully find some time to test this weekend.

So for people struggling to get this to work, so far @smoov , @Rossyb , @passy , I have managed to get the Powermax + working well now. It needs a couple of small tweaks in the timing, but the most important thing I have found is that the ESP8266 UART pins are not very fault tolerant (compared with FTDI/Arduino/Atmel pins). I have a few alternative parts, that will make the integration easier, arriving on Wednesday and can hopefully test them before I travel for work (on Friday). Though my working solution so far is to add a programmed Arduino Nano in between the Powermax and the Wemos.

@Rossyb if you have an Arduino (Nano ideally) at home and can quickly test a firmware for me, it would be good to know that my fixes should apply to other people!! If you dont have one, then no worries I will test with the extra hardware asap and send out some extra instructions.
@Gavin_Smith Sadly Im not particularly confident that these fixes will sort out the Powermaster since it is quite a different system, though I guess it is possible. After sorting the Powermax+ (and Pro from the US) I can try and get a test Powermaster and see how it differs.

@cjcharles Really wish I could help but sorry I do not have Arduino kit of any kind. Thanks for the effort in getting this working.

Hi all,

My extra parts arrived today and Ive just tried to enroll the Wemos into the Powermax with these parts but sadly it doesnt work. Im surprised the only way I could make this work was using some strange Arduino functions to sit in between the Powermax and the Wemos! Frustratingly unless you have an official Arduino Nano (with the Atmel 328) and not one of the many clones it can sometimes be hard to flash them without an FTDI aswell, but lets go with it for now.

I might keep trying to get it working with just the Wemos, but Im not optimistic as Ive tried a lot of things already (including using spare pins of the Wemos with Software Serial) and I find that most of the functions I need use very specific timing, which is incompatible with a chip using WiFi, since the WiFi interface timing is also super important to avoid dropouts. So, that’s where I’ve got to, and I’ve now spent enough money on troubleshooting this with easier-to-use components, only to discover they don’t work.

If you want an Arduino programmed I will post one to you for £8 plus postage as that will slowly claw back some of the component purchases Ive made trying to get this working. PM me if you want to do this, otherwise feel free to give it a go and let me know how you get on! (Ideally one person would buy one first and then at least I can be more confident that it should work for others, but Im 99% sure it should work!).

The extra instructions are in the ArduinoFiles folder of my Github.
(NOTE FOR OTHER PEOPLE: The Arduino is only needed for certain old Powermax boards such as the Powermax+ and American style Powermax Pro)

FYI @smoov , @Rossyb , @passy

Chris

Can any1 post a checklist (or where to start) how to connect the power Max to ST?

Have a look on my Github account link in the first post. It has everything you might want!

Thanks allot.
I’ll try to follow those steps, will keep you guys updated.

@Gil_Hoffman Any luck? Hope it is all going smoothly! :slight_smile:

:grin:

Just wanted to say Massive Kudos to CJCharles!!!

Whilst some Powermax’s seem to behave a little differently (uk/us) he has spent a lot of time and effort testing and helping followers to get this to work.

I had previously tried to integrate my powermax with an RPI but kept having issues. This was the simplest process to follow, with the write up at the top and he has spent many hours tweaking things for more simplicity and robustness.

Thanks for all your time and effort.

Huge respect!

1 Like

My Powermax+ is all sorted thanks to cjcharles’ dedication.

Thank you very much cjcharles for all your hard work!

1 Like

Happy days my Powermax + is now up and running in ST.

@cjcharles Thanks for all your help in getting this going

Cheers Ross

1 Like

Hi, is it possible to “arm away” or “arm home” in instant mode with this app?
I use it with “arm home” at night, to make perimeter sensors around house work without “entry delay”.

According this, PowerMax plugin for Vera can do it and use same interface, http://code.mios.com/trac/mios_visonic-powermax

thanks.

I can easily add it to the wemos firmware, though I’m not sure if both are possible, definitely looks ok for instant arm home but not sure about away. Why would anybody use instant arm away?

Once I’ve done that you can then tweak the device handler so it can do the instant arm options too. (You’ll just need to think about layout for the extra button or two!)

2 Likes