[OBSOLETE] Visonic Powermax Alarm

@smoov, if it doesnt fix it perhaps we can do a remote trouble shooting session? I would ask to see your computer screen through Team Viewer, and we can run a remote telnet debug which will list every command that is sent/received, so that we can work out what command is messing it up. You will obviously keep control, I would just need to see the commands.

I think we might find that the library I use gets confused by a Powermax Pro from some countries. Having a search online shows that there are some Powermax Pro’s which pad all of the serial communications with ‘0x00 0x00 0x00 0x00 0x58’ and the Wemos might be getting confused if trying to process this.

Sounds like a plan. I’ll let you know as soon as I get the panel back. So far I haven’t heard anything, but I’m going to ping my contact to see if he has heard anything.

I got my panel about 6 years. Let see if you fix your problem after firmware upgrade.

FWIW, I have made some huge improvements to the functionality of the Device and updated Github with the changes. As a summary they are:

  1. Firmware can now be flashed with ESP tool (much easier than faffing with libraries), and when the Wemos boots up it will create an Access Point for you to connect to and configure it
  2. It is now possible to update the firmware through a web dashboard by visiting IPADDRESS/update
  3. I have now linked the alarm status with the Alarm capability as ST sees it, this allows you to set the alarm through CoRE and also to get the alarm status through CoRE. In order for this to work you will need to lookup the states based on this list: Off=Disarm, Siren=ArmAway, Strobe=ArmHome, Both=Alarm . I.e. if Alarm status changes to Strobe then your alarm has been armed in home mode.
  4. I have made the Alarm Device handler smarter, so you no longer need a Smart App
  5. I have made the Alarm Device handler automatically create child devices when you press ‘Create Devices’, this means that you can press a single button and it will automatically create a device for each sensor that you have on your alarm.
  6. I have made some small changes such as speeding up some of the responses from the Wemos and making sure that the Multi-Zone device can be used by any other non-Powermax device if needed.

However, I still have one task on my to-do list, that is to get it all working with Powermax Pro, hoping to get that sorted in the next week or so (after some troubleshooting time with smoov).

@cjcharles This is great news! I finally received my wemos board, but have not had time to set it up yet.

Great job. I was going to use a pi integration but spotted this thread. I’ve installed it and it worked first time…the only problem I had was that when I closed up the alarm panel it pushed the reset button on the board.

1 Like

Great news, I’m working through a few issues on powermax pro but it’s motivating to read this!

That must have been quite confusing when closing it up! If you have any other feedback if love to hear it

Brilliant work cjcharles. Im trying to get a Powermaster 30 working with this with no success at the moment, I had it working through a Vera Edge with the PowerMax integration app. I do prefer the smartthings app ect. Unfortunatly i have no knowedge on programming ect, im just an alarm engineer so dont think i can help in any way. If i can however please let me know. Im hoping that your work on the powermax pro will hopefully work for PowerMaster.

Keep up the good work!

Interesting, the library I have been using doesnt have full Powermaster support, though it claims it should work in quite a lot of situations… Ive got a couple of other projects ongoing at the moment, but I will definitely come back to this and look at the Pro and Powermaster again, its just very difficult doing any testing and that is the biggest blocker.
Thanks for the good word though! :slight_smile:

EDIT: If you were based in London I might have asked to borrow a device so I can get it setup and working, but sadly I think you are based in Manchester. I aim to have another look at the end of the month, though as I said it might be limited by test devices at the moment.

I’m back…Sorry…I’ve been quite busy lately.

So i tried and tried to get RPI version to work and it just got very messy, needed help from a very kind person but never really got it finished, (couldn’t arm/disarm and had to kick off manually, then i think i broke it by installing something on my RPI)

Anyway enough of that…seeing as I had to work from home today and had a spare 60 mins so i thought, lets give this a go.

So i followed the instructions as set out, wow so easy to follow with one minor, I got a little confused with line 13 & 14 as you refer on line 14 to going to the smartthings app on your phone but we were already on it in line 13. sorry you did ask for feedback. apart from that minor thing the zone names did not populate in the app until i hit create zones then all the names came up and it created separate zones.

Boom job done in under an hour. the only thing i need to figure out is how i get the board to fit inside the panel as the pins make it sit a little proud and I cannot close the panel lid.

What an excellent write up and very easy process to follow, you have done a sound job.

There was a moment when i thought it wasn’t working, but read again and it said, wait 5 mins. I waited, it worked!

Thank you so much.

Powermax PRO working like a dream, wish I’d done this sooner.

THANKS :slight_smile:


1 Like

Great to hear, thank you! Instructions clarified! I have actually left the board outside the panel as I have been playing with some firmware changes, but I hope you did manage to get it inside the case eventually, it should fit at a push!

I would love to know why your Powermax Pro is working fine, and yet there are several Powermax Pro models which dont work. So far it seems the US version doesnt work but the UK version does… Will use that as extra guidance for my improvements!

Happy to help anyway I can.

I’m not sure what firmware it has but if you can tell me where to find it I will check. I purchased it about 1 year ago as my previous box went very crazy.

I did notice my Wemo board was listed as esp_881f20.home on my wifi and thought I had the wrong board but obviously not.

Yes, Wemos just uses a standard ESP8266 chip, but then packages some useful chips around the edge such as 6-18V power regulation chips, Serial-USB conversion and some buttons. When it joins your WiFi it will join as though it is an ESP since that is the underlying technology.

Knowing the firmware version would definitely be useful. Also if you can send me a PM paste of the status page that would be great (feel free to remove PIN codes and zone names as you wish) (IPADDRESSOFWEMOS/status). Im mainly after this section:

“stat_str”:“Armed Away”,
“panelTypeStr”:“PowerMax Complete Part”,
“eprom”:“J-701798 B17.113”,
“software”:“JS702159 B17.107”,

Hi, dont know if you can help but thought I would ask

I am having trouble with the Wemos. Everything seemed to go fine at first, I flashed it fine and got to the wifi config page.

I think at this point I may have incorrectly put in my wifi password so it never appeared on my home network.

Now I cannot figure out how to get back to the config page to put in the correct wifi password. I have reflashed the Wemos a few time now but it never appears as an AP

I am all a bit new to this and have not used this hardware before but your instructions are fantastic and I am really happy there is a way to get my Powermax onto ST

Many Thanks


The device is set to broadcast its own AP whenever it cannot connect, hence if you put in the details wrong it should start re-broadcasting. I would try checking in your router to see if you can see any new devices, alternatively I would suggest downloading Angry IP Scanner since that will be able to search your network for the device.

Anyone has success with the Powermax+?
For me only Arm away/home works when disconnecting the Wemos RX wire. I am unable to get any status/zones (with rx and tx wires connected).

Interesting, where are you based and how old is the Powermax+? It should follow the same principles as Powermax Pro, since the library supports it, however there are perhaps some differences between regions since even after a firmware update we are still struggling to get @smoov working…

Getting arm (away/home) is easy since that can be done without any security, however pulling the zone names and disarming requires that the WeMos successfully completes the enrol process with the Powermax - this is what seems to be failing on some devices.

Thanks cjcharles, I am based in UK, my Powermax+ is about 9 years old. I also think it is an enrolling issue. With rx/tx wires, I am getting a long beep when performing the Powerlink enrollment. Strangely if I connect only the tx wire, I managed several time to get a short beep but I am not convinced the enrollment was successful (it does not fix the problem after reconnecting the tx restarting Wemos…).
Note that I recently bought a second hand Powermax+ (probably similar age) in order to replace mine as I had tamper issues and I have exactly the same problem with both Powermax+.

1 Like

Ooh, thats exciting, where abouts in the UK? Feel free to PM. I wonder if I could borrow the Powermax+ which is misbehaving and see if I can troubleshoot with it? Im in North London…

Thanks found it with the scanner

Now moving onto connecting this up to the Powermax

Cheers Ross