[OBSOLETE] Virtual Device Manager


(and I’m saving this to prove to my wife that I do, in fact, have a great mind!)

1 Like

@btk - I shall also use this coincidence as conclusive, demonstrative proof of my brilliance. :sunglasses:


Will either of these apps also remove the virtual switches if you decide you no longer need them?

Yep. It’s just like uninstalling a child rule in Smart Lighting. You just want to make sure you go into the child device before hitting “uninstall”. Doing so on the list of child devices will uninstall the entire app.

1 Like

Yup at least this version of i you can. 1st thing I tested. :smile:

Yes. SwitchMania will remove the virtual switches (and / or the links to Routines) if you decide you no longer need them.


Just to pass this on… On Android App. When I access the parent app then click the plus… It just crashes the app and cycles it back up again… Any ideas?

Nope, I’m an iOS user. There have been a lot of reports of odd behavior with the Android app lately, though. I don’t think I’m doing anything non-standard. Try the SwitchMania app and report back if it works. If it does, I can compare code to see what’s going on.

Ok it looks like this one actually works for the switch creation - However I’m having trouble installing the 3rd (2nd child app). about to report the error on that thread.

I can confirm that I can’t install child apps on android, just crashes. But I can via iOS, no crashing.

I have no problems on Android 2.0.7 creating SmartTiles Child SmartApps (from SmartTiles (Connect) parent).

I don’t have a problem on android in Smart Tiles either. I just meant on the VDM Manager.

1 Like

Sorry. I don’t have any android devices to test with. It’s a shame that supposedly valid code works on one platform but not another. I’d be happy to accept a PR if anyone knows the secret handshake for Android, though.

1 Like

Getting error =Java.lang.IllegalArgumentException: Metadata definition not found
when trying to install the Momentary Switch Template.

Thoughts on how to fix this?

thanks in advance


Sounds like you’re trying to install it as a SmartApp. It is a device type.

1 Like

I’m getting the same error when I attemp to create either one. I’m thinking I may be in the wrong place because I can’t find the tab names you describe. I am trying to use “My Device Handlers” rather than “My Device Types”. I running “graph.api.smartthings.com”.

@smashim, @Sorapp: Well, I’ll be.

Looks like the code for that device in the IDE was changed to something that doesn’t work. I’ve asked the powers that be what’s up and will let you know as soon as I hear back.

@smashim, @Sorapp

The templates in the IDE for those two device types have been corrupted. Below are links to the correct versions of the files in the SmartThings GitHub repository. You can follow the same instructions but instead of “From Template”, you’ll pick “From Code” and then copy/paste the code into the IDE.


OK - I will give these a try tonight and see what happens.


That worked so thanks. Now on to test the rest!