[OBSOLETE] .. Updated Open Source Ecobee Device Type and SmartApps

It’s on the to do list to investigate. I’ve been on the road for
Work so haven’t been able
To investigate. And since I don’t have a Lite thermostat to test with I have to rely on data dumps from others. I have data sitting in my Inbox that hopefully will lead to an answer


Same for me.

Please Ignore.

I am new to ST so I may just be missing a setting here. I have noticed in Home IQ that when my ST sets my 2 ecobees to “Away” via geofence trigger, HomeIQ shows the mode still as ecobee’s home mode with a hold status but the setpoints change as directed for the away mode.

Is anyone else seeing this?


I posted the same basic issue on the github issues page. I searched around and found this one as well, so I’m following both.

I’ll do as you say and continue to keep trying to add the thermostats until it works.

I have just posted a significantly updated and enhanced version of the Open Source ecobee device created by @StrykerSKS . You can find the discussion for it here

Just saw that. Guess I should have gone through all my alerts before responding :slight_smile:

Hi thank you for your smart app! I was wondering if there is a proper way to cancel smart away? I’m trying to use resumeProgram with no parameters but it doesn’t seem to cancel it. Some other ideas are to just set a specific temperature and/or program I’m assuming a pass a string of the mode name from the Ecobee site.

Hey @StrykerSKS,

Just installed your ecobee SA/DTH and I am struggling with how to set as follows
I would like ecobee to go into sleep mode when ST goes into sleep and Home mode when ST goes into Home mode

Currently I have Sleep and Home as comfort settings with their respective temps

I am also trying to setup a CoRE Piston to do this, think I have the sleep figured out but not the home

What am I missing?


@StrykerSKS a couple questions on the Smartapp and I’ll preface them by saying that I’m fairly new to the SmartThings ecosystem and this is my first attempt at using a smartapp, so bear with me.

I have my families two phones setup as presence devices that change the mode to away by using a routine when they both are out of my geofence. When this happens, I have an Ecobee Connect routine handler run which will set my ecobee to Away.

When a single phone arrives, the Home routine runs and I then have the Ecobee connect routine handler run to Resume the ecobee.

Last night when we left my ecobee went to away, but when we arrived it was still set on Away and holding. Not sure if I have something setup wrong, as this is the first time it’s happened. I verified through the smartthings notifications that the mode was set to home when we arrived, so I’m not sure what happened.

One last question, is it possible to get all the LastPoll and humidity notifications removed from the notifications page, it spams it up quite a bit and makes for a lot of scrolling if you are trying to find something in the past. I set the debug level to 0, but that didn’t seem to help.

@Toy4Rick, start your Ecobee (Connect) app, click on Helper SmartApps, Create new Routines Handler. You can use Mode change or Routine execution as triggers. You don’t need CoRe for that.

Thank you, that is what I was missing

Safe to assume the “When Hello Modes(s) changes to” is the ST Location Mode? Seems like it, just wanted to confirm.

I created to 2 new routines, one for Night Time and One for Home and since I use ST Location Mode as Nite and Home, thought this would work out quite well.

I do have schedules setup in the ecobee app to trigger Home, Night and sleep in case we don’t leave meaning the ST Location mode only goes between home and nite

Am I thinking through this correctly?


I guess you are. I’m not sure I understand what is your question. I think of it like this: Ecobee’s schedule is primary, because it is more reliable. I use SmartThings to intervene only when there is an exception. I use the routine execution as a trigger, not the mode change because I have more than one routine that change the mode to the same value.

I’m getting this error:

“Error Saving Page”

Also here’s the log:

java.lang.NullPointerException: Cannot get property ‘c714d052-4e8f-445d-abd3-a1761613d763.411992023159’ on null object @ line 1155

This shows up when I;m trying to add the devices after doing the SmartApp authorization.

Any ideas what could be wrong?

Is it possible to switch on the ‘smartaway’ mode at all? When i leave the home i wanted to trigger the smartaway instead of away (not sure why yet but it seems to make sense).

There is no API available from Ecobee that allows an outside app to set to
the “smart” settings (away or home), unfortunately.

Understood. Great work on the devices and smartapps BTW. All i really wanted was to be able to change ecobee modes away and home. Very strange the ‘official’ does not allow this.

I do have a further question, the modes, when the ecobee changes a mode itself it is different to when the smart app does. The smart app will make the ecobee ‘hold until 11:30pm’ where as the ecobee itself will not ‘hold’

Is that right or am I doing something wrong?

You can select whether you want to change the mode “until next program” or “until I change”. When you do it “until next program” then it will show this “hold until 11:30pm”.

ah i didn’t realise that. If it is on ‘until I change’ I assume the next ecobee program will not be able to change it though? Just interested in how it is working