[OBSOLETE] Universal Ecobee Suite, Version 1.8.01

Hello! I recently swapped over to the new SmartThings app and notice on the Sensors it shows “Motion Detected” or “No Motion Detected” instead of just showing the temperature default. Is there a way to change the sensors to show temperature on the main SmartThings dashboard?

Thank you!

SmartThings has not made that possible, sorry.

I don’t know. Maybe another user can chime in, but I haven’t heard anything, good or bad.

Do you have the helper set to only adjust during the Sleep program?

I don’t believe so. In the help app, for the “Conditions: Perform Actions only when the Location Mode is” field, I left that blank since I didn’t want to limit the helper app from running at any time.

Ecobee Suite Manager Updated 24 April 2020 at 2:45pm EDT

This update is primarily cosmetic, and all of the SmartApps and Helpers have been updated (the Sensor and Thermostat drivers have not been changed).

I’m not going to list all of the version numbers anymore, but here are the primary non- cosmetic changes:

  • All Helpers that support Notifications
    • Updated to support the latest Echo Speaks Device release
  • All Helpers that change the thermostat’s program
    • Fixed type conversion issues for hourly holds
  • Ecobee Suite Manager, version 1.8.38
    • Cleaned up connection lost notification text
    • Started support for new “climates” enabled by the new Eco+ features (incomplete)
  • Ecobee Suite Smart Room, version 1.8.15
    • Doesn’t use Ecobee Sensor as a motion sensor, unless no other motion sensors are configured. This because of the inherent delay in active/inactive changes, which will cause a room to be prematurely activated.
  • Ecobee Suite Smart Switches, version 1.8.08
    • Fixes the logic to save and restore states (reverseActions())

Using Package Managers

I highly recommend that Ecobee Suite users make the small investment in time to setup one of the available automated package managers. This will significantly reduce the manual overhead of upgrading to new releases. Available options include:

  • SmartThings
    • SmartThings GitHub Integration is fully supported by the Ecobee Suite GitHub repository
    • SmartThings Community Installer - although this hasn’t changed in 2+ years, it remains a powerful tool for automating upgrades for a broad variety of applications and drivers.
  • Hubitat
    • The native “Import” capability should allow you to simply run through all of Ecobee Suite Apps & Drivers doing Import/Confirm/Save.
    • The recently released Hubitat Package Manager is really awesome, and I highly recommend it for everyone. It really will make managing your Ecobee Suite environment (and others) MUCH simpler!

These updates are recommended for all Ecobee Suite users

I have installed the app and the Ecobee site is asking for a 4 digit validation code. It appears to be operational. Did I miss a step during install that required a 4 digit validation code?
Great work with the app!

It sounds like you turned on Ecobee’s two-factor authentication…

It’s not set. When I log into the ecobee web portal and I click on my apps, the first screenshot comes up, I click add application and then it asks to validate your app.

The first screen confirms that you have authorized Ecobee Suite for SmartThings on this account.

The second screen is how you would add an app that uses PIN authentication, instead of the native authentication I used in the Ecobee Suite. You can ignore this…

Thanks, I figured something like that and it seemed to work ok but better to ask and confirm. Great work again!

Hi I am fairly new to Smartthings and am in the process of adding new SmartApp as I learn more.

I’ve recently tried to install the Ecobee Suite Manager and used the community installer but ran into a few problems. I followed the steps outlined on the GitHub doc and got it all installed, except when I got to the SmartApp part (using ST Classic App), after authenticating with my Ecobee credentials and trying to save them, I get message it is successfully installed followed by a second error message indicting “Device is still in use” “Remvoe from any SMartapps or Dashboards, then try again”, which is preventing me from proceeding.

BTW … I had to turn off 2-factor authentication on my Ecobee account to allow this to work. Can I turn it back on once the OAth credentials are saved?

I previously had Ecobee Connect SmartApp and have already removed it. I did remove my 3 Ecobee thermostats and 3 sensors from the app, before removing it.

Any ideas what I may be doing wrong? Can anyone help or point me to where I can get some support?

FAQ question #1: the test devices didn’t get removed before SmartThings health check linked them in. You need to manually delete the two test devices it created - one test Thermostat and one test Sensor. Look in the “Devices” page in the IDE to find them and delete them. Then you should be able to proceed…

Not to worry, happens about 1/2 the time…

Also - you may have gotten caught in this error situation on SmartThings this morning.:


Issues with Automation Execution

Incident resolved

The issues with failed automation execution and device history in the mobile apps have been resolved. Users should also no longer see any issues on boarding SmartThings Hubs or other devices in the mobile apps. Please contact us via support.smartthings.com if you have any questions.

Time posted

Apr 26, 15:42 EDT

Components affected

Operational\ 15x15 Americas - Hubs, Devices, and Automat…

Operational\ 15x15 Americas - Mobile App
View 1 previous incident update

You received this email because you are subscribed to SmartThings service status notifications.

Manage your subscription

Powered by Statuspage

Thanks for your quick response on this!

I had actually seen both the test thermostat and sensor but didn’t want to delete them in case they were required as part of the install. I have now removed them both and was able to complete the install.

An additional question. Per my earlier comment, I had to turn off 2 factor authentication on my Ecobee account to install this, so would it break things if I turn it back on now?

I don’t know about the 2FA, except that everything works fine if you don’t turn it on…

So I’ve gone through the steps in the github guide but I can’t seem to authenticate. I have no problem authenticating using the smartthings ecobee connect app, but I can’t authenticate through Ecobee Suite. I should add I’d been using StrykerSKS for quite a while and just stopped being able to login with it. I’m not sure if it’s connected but it looks like ecobee changed something with their login page. Here’s a screenshot of what the new login page looks like in the built-in ecobee connect app. Ecobee Suite appears to still have the old one, and from what I can tell it no longer works. I’d really appreciate any help.

A few things to try:

  1. if you enabled two-factor ecobee authentication, disable it And try again

  2. be sure to log out of ecobee from every other browser window/tab on your device

  3. if it fails, exit all the way out of ES Manager before trying again

  4. SmartThings has been having issues today. Try logging out of SmartThings entirely before trying again.

If all this fails, capture Live Logging while you try again, then send me the live logs for ES Manager while you try to authenticate.


I had originally thought it might be 2FA so I’d already disabled that. I logged out of every browser and even the ecobee app and tried again. I also logged out of smartthings and then back in. No luck. I captured the live log, but I’m not sure how helpful it will be. Nothing appears to happen in the live log when the authentication fails. It tells me I have a wrong username and password, but it’s the same username and password I just used to login to the ecobee app. I’m copy pasting it too to make sure I’m not screwing it up.