[OBSOLETE] SwannOne Key Fob Support (updated 2019 DTH in post #51)

Continuing the discussion from New Zigbee Device (Securifi Key Fob):

@NHENRY and @RudiP I am creating a separate thread for the SwannOne Fob discussion so we don’t continue to hijack the Securifi Key Fob discussion.

I learned about the SwannOne from your posts and also decided to purchase one for my wife. I too am having the same “disconnect” issue which is quite frustrating since my wife likes this design a lot better.

Thanks ritchierich, I am sorry that you purchased this keyFob on my recommendation stating that it works!

The first time I tried the Swannone keyFob , it worked well for the whole evening, then the next morning it worked for a couple of key presses, then it unpaired.

I tested it for two days trying to get it to stay paired! I really thought that it was something that I was doing wrong! Well there is now three of us, so that has isolated any local interference or cur corrupt setting on my hub!

I am not a dev coder, so I can only assist in testing. I have 3 fobs, therefore if anyone does manage to get the keyFob working. I can test how well three keyFobs play together. I am only holding on to this keyFob due to its shear beauty and well refined design!

I was wondering if all of this has got to do with rolling codes. Maybe this Swann one keyFob and the Swannone hub communicate with a dynamically changing rolling code!

Honestly I don’t know enough about zigbee to know. Maybe @JDRoberts knows. I doubt it though since the key fob joins back as the same device and not a new one after pushing the internal button. This is very odd indeed.

They pair back as the original device because they have a unique identifier that gets stored in ST. So when the device is paired again it links back up to the existing device record present in ST.

As for why they keep un-pairing, I don’t have any ideas :frowning:

Thanks for your input kriskit! It is very strange indeed!

The last couple of days I was reading a lot about Devices and ZigBee and had some ideas for testing, but when I got home last night ready to test I could not get my Key Fob to rejoin the Hub. After a while I’ve found out that I was having issues with all my ZigBee devices again (WiFi interference) but by the time I got everything back and running it was late and the wife was already mad, so I could not run any test.
I’ll try again tonight and will let you guys know by tomorrow if I had any success.

Once you’ve got the device stable, if anybody has any recommended changes for the “Arm my System Key Fob” app to support this device, please send a pull request.

Thanks chipr! Good luck with the testing Rudip!

Yesterday night I was finally able to run some testes but unfortunately the issue is NOT fixed yet.

I’ve started from scratch and was able to get and verify the “device fingerprint” (minor updates here) and it’s basically the same as the Securifi Key Fob. I’ve also managed to create a Refresh function and add buttons to manually call the Refresh and the Configura functions. Everything worked fine but after a couple of hours the device lost connectivity with the ST Hub again.

It would be nice to have the device “Technical Manual” (I’ve tried but could not find it) to see what the device is expecting from the inicial configuration (enrollment) and make sure we are sending the correct information.

Well, I’ll have to go back to the “books” and also try to validate other ZigBee devices to see if I can come up with some new ideas to test :frowning:

Wow! Rudip. You’re getting some good testing in! Good work! I also looked for some technical manuals, and could not find anything!
I will keep researching over the weekend.

The same issue/behavior is being reported for another ZigBee device that is also a remote (buttons) controller, the Philips Hue Dimmer, and there is no solution reported so far.
Just FYI: I could not do much testing this weekend and I’m still reading about ZigBee devices and related issues like the above.

Thats a great find RudiP! I read through the whole thread about the Phillips Hue Dimmer.

It does appear to be suffering from the same problems that we are experiencing with our keyfobs.

There is a wider audience on that thread also, which hopefully will produce many ideas about the issues that we are facing and hopefully a workaround fix!

@Sticks18 or @JohnR, you were both very helpful and knowledgeable about zibgee device handlers while helping with the Securifi keyfob. Would you happen to have any ideas why the SwannOne zigbee device loses connection with the SmartThings hub after several hours/day?

Here is the device code many of us are using:

I am curious if we need to tell the fob to check in every so often with the hub.

The device type looks pretty clean and straight forward nothing jumps out at me.

When you say looses connection what does that mean exactly? How do you get the connection back? Do you have to reset the FOB back to factory and rejoin SmartThings to get it back? Or do you just have to move it closer to the hub? Will it stay connected if it stays close to the hub? Wonder if it is a range problem? Did it work okay for awhile and just now start to have problems?

You may want to click on the logging tab in your IDE and let it run in background to see if you can get any messages.

I agree with @JohnR that the code looks fine. I’m surprised it’s having trouble maintaining the connection considering the hub enrolls the device as an IAS zone device. It might be interesting to see the logs to confirm it is enrolling properly and see if they give any clue as what’s happening. I’d recommend adding a log statement at the very beginning of parse() so we see all the messages coming through to help.

We’re having a similar issue with the Hue Dimmer Switch. After some amount of time the remote stops communicating with the hub. I thought about trying to send periodic messages, but I was worried about battery life. I suspect the issue lies deeper in the zigbee firmware/implementation than we can affect with device code.

1 Like

Thank you for taking the time to look at it. I have compared this device to others on the community and GitHub as well and nothing jumps out at me either. I am just wondering if we have to configure it to check in with the hub at a certain internal or something - pardon my ignorance of zigbee devices. I know with my ThingShield zigbee device as an example I get pings on a given interval.

Regarding losing connection, several of us on this thread are experiencing the same issue. We pair the device and all is good but then after X hours, it no longer works and the unpairing light on the fob blinks meanwhile on the SmartThings side the device is still setup, etc. We then have to reset the device and pair it again and then eventually the same situation will happen.

My fob was sitting very near my hub when I paired it and I left it there and came back and it was unpaired. So I don’t believe it is a range issue. These fobs are meant for the SwannOne home automation system so who knows maybe they are setup to NOT work with other systems.

I was just curious if there are any other configurations we can set on the fob itself during config to maybe make it work. There isn’t a whole lot of documentation on those commands so I have been struggling to troubleshoot this. Thanks again for your help!

@tpmanley mentioned this regarding the securifi fob. Wonder if it’s somehow related to this

When I tested your device handler I noticed the sensor rejoins the network on basically every button press. I wanted to hold off on further testing until some lower level changes I’m making to the ZigBee join support is released to make sure it would still work correctly.

1 Like

Thanks I believe it is definitely related because I see the rejoin as well. This is strange to me because the Iris Key Fob doesn’t behave this way but I am no expert on these devices either.

In my case the device works fine and if I leave it sitting for X hours it just stops sending commands to the ST Hub, the pairing light starts blinking on the device every minute or so.
I left the device close to the Hub for testing and makes no difference. On the ST Hub side I can manually send a Refresh or Configure to the device, the Hub logs the COMMANDS but I can’t see any response from the device.
To rejoin I just start the search on the ST Hub (“Connect new device…”) and hit the back button to wake up the device (no need to reset to Factory) and it will rejoin as the same device.

I’ll try to add the Debug Logs to the parse() command as recommended by @Sticks18, but this issue looks very similar to the issue with the Hue Dimmer Switch.

Thanks @kevintierney. The code that we are using is based on your device type code but the Securifi fob is not presenting this issue and id does not look like you had to implement anything to resolve/fix the behavior reported by @tpmanley, am I correct?