[OBSOLETE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

I searched this tread but I wasn’t able to find the answer. I flashed a Sonoff TH16. I used the Sonoff Connect app to add it to Smartthings. From Smartthings, I can turn it on/off, reboot. Everything seems to be working properly except the temperature. The temperature shows -196.6 °F. I am using the DS18B20 temperature sensor. Does anyone one know what might be the issue?

I am still having this issue. I had this working previously on a Sonoff TH16 for about 1 year. Then a chip on the back of the Sonoff TH16 died. I then purchased a new Sonoff TH16 a couple of days ago. I flash the firmware in the OP for the Sonoff TH using the nodemcu flasher method. I had no problem adding the Sonoff TH to my wifi and having the Sonoff (Connect) find it. From the Smartthings old app I can turn the Sonoff TH on/off, reboot, and refresh. The uptime updates and it shows the proper ip. When I select the DS18B20 temperature sensor, the temperature reading goes from 0° to -196.6° F. I thought maybe the sensor went bad at the same time so I just bought another one but I get the same result. Does anyone or @erocm1231 know what might be the issue? Did something change with the Sonoff TH16 in the last year that makes the DS18B20 temperature sensor not work? Is there something I need to change in the firmware or device handler to make it work?

Thank you so much for the great firm (I’m using it on 10 devices already).
Will one of those firms work with my Sonoff T4EUC1 (Single Wire switch).
Best, Sergei

Hello.
I have two S26 sonoff plugs and I have connected them to ST via IFTTT.
Now, I’m for a solution to continue using these plugs via ST hub, when the IFTTT will be available only with paid subscription
Is the S26 plugs supported by this SmartApp/DHs?

Thanks

I too am looking for your solution is there a DH now that LAN facility is unlocked by Sonoff. No need for IFTTT now, or flashing.

@Panos - Ive achieved this by using the workaround FAQ: Can I trigger an Echo Action without Speaking to It?

I dont have alexa speakers but utilised the Alexa app - plugs working again! Hope this helps.

TB

I am based in the UK and all my sonoff classic devices stopped responding on Tuesday.
I have 6 or 7 devices and none of them are now responding.
Everything else is fine,

I am not sure if there was an update or even where to troubleshoot this.

Any ideas?

Hi @erocm1231 - I love using your Sonoff firmware and smartapp, thanks. Reliability was never an issue but I switched to the new ST app a few weeks ago and since then I’m struggling with "Device Offline’ quite regularly. Also, each time my home router (where my DHCP pool sits) reboots, I have to restart all the sonoff switches, which isn’t so easy to do with some of them. Is it possible samsung has introduced issues with the new app?

Some of my Sonoff switches show the wrong IP in Smartthings (and thus don’t work) vs my router but I can’t get them to update.

1 Like

Not sure what is going on but when your router reboots they should reconnect. At least mine have for years without issue. Also, the SmartApp is supposed to handle ip address changes which seems like what may be causing the problem with offline devices. Anything different going on with your router?

Check the logs for the Sonoff Connect app and see if SSDP reports are coming in that would update the IP address. If they aren’t there might be something going on with your network and SSDP.

Does this DH work for the Sonoff Basic R3?

I’ve been using the 4Ch DH controlling a T1 2 gang switch and it was working fine until I had to migrate to the new ST app… now the switches have disappeared from my devices in the app and in webcore. My simple Sonoff switches seem to be fine. Any ideas?

Me too, Same for the 4ch wifi switch. Now only sees parent device and google home has also lost visibility through bridge, New app is becoming a pain.

Does device discovery really take more than 5 min? I don’t ever remember it taking this long! Got a new mesh router and had everything working. Rebooted, then couldn’t get the sonoff to respond. Deleted it by mistake and now I’m unable to add it again!

Gonna reply to myself so I remember how to fix this next time. Once its connected to network, reboot/unplug, then try doing device discovery in the app. Once its discovered and set up, you need to hit the refresh button in the CLASSIC APP! Then temperature will start displaying again. I guess someday this will eventually be totally broken when the classic app is completely gone? I only use this for the temp probe, so probably only my specific use.

Another issue with the terrible new app. Old one is soon I am afraid. I am looking into home assistant. Thinking of chopping smartthings for good. Anyone think HA any good? I loved smartthings but seems Samsung are done with it as they really dont care about the user.

Same brother, I have been looking into this but they require us to purchase their MCs -

If you find something else, do let me know!

Hi @erocm1231 - a v. quick question - I’m (painfully) going through my forced migration to the new app. I have six Sonoff 4Ch devices.
I’ve update the device handler, and deleted the children, but I couldn’t get the children to re-create.
If I completely deleted the master device and then re-added it, then it worked - do I really have to do this for all of them?

Also, my sonoff TH doesn’t even show in the new app - do I need to remove and re-add that?

(I realise this is totally out of your control, but some guidance would be great!)
The new app might be good if I can make everything work, but it’s annoying that they didn’t keep backward compatibility, and that they’ve forced me to use the new app, even though the old app still works for my needs.

Thanks for all your work creating these and continuing to support them!

Best,

James

You have to update the device handler, delete all the child devices, and then have them recreated with the new device handler installed. You can do this by changing a preference in the device settings and then changing it back.

@jamesxheath Maybe you are missing that last step of changing a preference in the device settings and then changing it back.

1 Like

Yep. I’m an idiot - I did that as directed for the Fibaro, but didn’t for this - have just tried it & it worked. - Thanks once again!

1 Like

Thanks a millions Eric, I will give that a shot. Appreciate all you work on these. Using your info for years :slight_smile: