[OBSOLETE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

It’s the only way to connect to ST, Install the smart app and it will find your device.

This is the whole topic of this post. I guess you have not read post 1?

i just re-read my response. This is not meant to sound like i’m being a jerk about it! Just a genuine question.

It could very easily by my lack of understanding how this is supposed to work but I cannot get the flashed TH16 to work with this app. I can web connect with the TH16 and I was able to manually add it using the app but could not get it working. The TH16 started showing unavailable shortly thereafter.

when you look at the device in the ST app, do you see the IP address or just zero’s?

If you just have zeros then make sure you have the latest version of the SmartApp. Or try what I said in october:

I guess I’m further behind than I thought. I never got an IP address displayed. Will try to flash again and see what happens. I may have bricked it already :frowning:

Just flashed again and it wasn’t bricked. Found the WiFi SonoffTH.xxxxxxxxxxxxx but don’t have password

Found the password of configme :slight_smile:

It works :grin:

OK I think things may have gotten a bit muddled. So here’s a recap:

I am trying to use the latest Sonoff devices that use the 8285 chip and not the older 8266 ones. I have loads of the older 8266 ones and they work really well with the erocm firmware and device handler.

I tried flashing with the standard(8266) firmware. They flashed OK, but failed to boot a network session. I guessed the 8266 firmware is incompatible with the new Sonoffs.

I did find 8285 firmware as detailed in an earlier post on the ESP Easy (details here:

The ESP Easy firmware for 8285 worked with the Sonoff and I have been able to turn the relay on and off by posting the relevant commands.

So the only question remaining is how to control it using Smartthings. I tried the erocm driver and was not surprised that it did not work (not erocm firmware).

I do have it working using a virtual switch and WebCore. Which I can detail if anyone is interested.

I am now trying to get it to work using URI Switch ( [BETA RELEASE] URI Switch -- Device Handler for controlling items via HTTP calls) which would be neat as it would be a local network solution and not relying on WebCore cloud.

I hope that makes sense…

I got it working by a simple modification to the URI Switch device handler (replacing GET with PUT. I am considering doing full documentation on how to use ESP Easy firmware with Smartthings.
Because the ESP Easy firmware is so flexible, it should work with any 8266 or 8285 based device. I am planning to try it out on a cheap RGBW led controller like these:
I may fork the URI Switch device driver, but that may take a while as I’d like to be able to return data as well eg temperature from Sonoff TH 10/16.

1 Like

I can potentially get a few of these devices cheap…

What are my chances of getting Tasmota firmware on there?

I have been unable to get the firmware to work with a Dual R2 (Think it is because the chip is the 8285 rather than the 8266). I successfully flash other firmwares which then work.

Has anyone made this work?

I’m going to have a go using the ESP Easy firmware that worked on my 8285 Sonoff.

The 8285 is a slightly cheaper chip, so I guess they are all going to be 8285s from now on.

I’ll let you know how I get on…

Well it’s an 8266 chip, so it should work. Only problem would be that you might have to work out what the GPIO pins map to. The sonoffs are so cheap, why would you bother?

Because my employer just got 200 of these in to stock, and at staff pricing they’re looking quite good…

David, did you follow the instructions here:

It’s for the 8285 version.

Yes thank you. Using Tasmota works with the Tasmota device handlers. I was trying to confirm that erocm1231’s firmware and device handlers do not support it

The only thing wrong (for me) with Tasmota is the lack of proper syncing (ie if you use the device button or a non-smartthing way to turn on/off)

What smartthings smartapp and device handler would you use with esp Easy firmware?

@erocm1231 Hi Eric. Thanks for posting this.

I have a Sonoff-TH16 with a Si7021 sensor that I bought directly from ITEAD:

I loaded the firmware SonoffTH.ino.generic.bin from your link but I can’t get the temperature/humidity sensor to work.

When I try to select the sensor under Advanced Configuration as DS18B20, and reboot, I get this as status:

{"power":"off", "uptime":"0:0:29", "temperature":"-196.60", "scale":"F", "humidity":"0.00"}

When I set it as AM2301 and reboot, I get this as status:

{"power":"off", "uptime":"0:0:15", "temperature":"nan", "scale":"F", "humidity":"nan"}


Can you please add support for this sensor? I really don’t want to have to order a new set of sensors.

Thank you.

Thank you very much ERIC M.
Also, thanks to Drew’s TaylorTech youtube video where I first discovered this was possible. https://youtu.be/FxV_zWvxbSE

I just got this working on my first SONOFF BASIC (with 8285 chip) using the newer Nodemcu flash method. (Removing RX TX after flashing and holding the button down for 10 seconds are not necessary steps).
I added it to my Wifi, then SmartThings and it shows up in Google Home (already connected to ST). Now I can order a bunch of these and control everything!

Next, I will try to figure out how to connect these to Google Home without SmartThings (for others who don’t have ST).

1 Like

I don’t think he’s working on these anymore.
I’ve been wanting these added for over a year now but there’s been no updates in aware of.

Are you using the Sonoff DS18B20? Mine works with that but when I tried one that I had wired up I got the same temp reading.

I am using the Sonoff Si7021 sensor. It doesn’t work with either of the selected modes. It’s good to know that the DS18B20 doesn’t work either. I guess the only other option is to wait until the AM2301 to become available again and try it.