[OBSOLETE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

I’ll have a reflash using first post as I don’t know if they are getting connected to my wifi or not.

Sounds right…go into the IDE and Live Logging, see what it shows for the H801 itself, and the virtual device. Maybe removing the virtual switches from the app and recreating would help?

So when I turn the “normal” device on, I see this line in live logging:
{“rgb”:“000018”, “r”:“00”, “g”:“00”, “b”:“18”, “w1”:“00”, “w2”:“00”, “power”:“on”, “running”:“false”, “program”:“1”, “uptime”:“1 days and 1:15:15”}

(This is defaulted to 10%, blue.)

But when I click the virtual device, I see this:
{“rgb”:“000000”, “r”:“00”, “g”:“00”, “b”:“00”, “w1”:“00”, “w2”:“00”, “power”:“off”, “running”:“false”, “program”:“1”, “uptime”:“1 days and 1:13:1”}

I think I see two things wrong there - 1) It should be 10% red and there are no levels being set at all and 2) “power”:“off” should be “on”, shouldn’t it?

I’ve already tried deleting the virtual switches from within the SmartApp and then re-creating them but it didn’t have any affect.


Figured it out! You have to put a duration in. I plugged in 1000ms and it’s working perfectly.

These things are great. I have 3 more now that understand how they work. I’m waiting for some more wiring supplies to come in so I can do the next ones as clean as possible, but they’re going to average less than $20 per 3m strip. Can’t beat that!


These switches are amazing! Big thanks to everyone here for the super helpful guides and posts!

One thing I might be missing is how to use the overall dimmer. I just have a white led (red: VCC on the left, black: W1 on the right), but I can’t use the main dimmer in the SmartThings app to control it (just the white slider in the app). This is too bad, since I can’t use Google Home to set the brightness to 50% or whatever.

Is there a setting I’m missing somewhere? I can probably go in and butcher the device handler but I’d rather not if I don’t have to.

EDIT: Well, I can just connect my strip to the R port and almost everything works. What I can’t do, apparently, is say, “Set the lights to 10%”. I can do that if they’re already on and it adjusts everything just fine, but it seems unable to turn them on to a given percentage. I can do this with my Cree bulb. That seems like an easy device handler change; I’d be happy to make a PR if I figure it out, unless this behavior is intended?

It should actually turn the lights on when you set a level. If you make the change, I will be happy to commit it.

As for the initial level issue, it was intended to control just the RGB colors with the main level. It might need to be changed so I will take a look there.


SmartApp Update: Inspired by @dalec with his idea to share programs, I have added the ability to “export” and “import” program strings. This also makes it a lot easier when moving your programs to multiple devices. Here is a video of it in action.


That’s wicked! Now the creative people need to start posting their programs!


Seriously! I’ve posted a couple of mine in the top post, but I would love for others to create some and share them. I will add them to mine as they come in.


That was a good way to do it aswell! Didnt think about just using a clear text string, way easier than a file!

Has anybody managed to get it working with <100ms? I find thats about as fast as these things can react (so police looks a bit fake…).

1 Like

Changing duration to less than 100ms causes some wonkiness. I haven’t had any luck.

If you’re not using all the virtual devices, you can just make a virtual switch for each dimness level and GH should be able to turn each of those on/off. (Actually, only need on, you can turn off with the main device.)

I found a cool one last night. You can program a virtual to cycle through all of the colors at a ~3500ms interval. When you tap the virtual switch again to shut it “off”, it actually pauses it on the current color. I was able to do it with Echo/Alexa too. Makes it so you don’t have to dedicated a switch to every color.

Also - make a program that cycles between red and blue at ~250ms and tie it to be triggered by a Smart Home Monitor alarm - instant police lights all over your house!

Just a quick ? with the import/export. Is there a place where we are sharing them or we just posting on here. Think it would be cool to have a place just for them.

In case it is easier, I have put the import/export profiles in a public Google Document that anybody can add to:


So when I import one of these, I get the first action (Fireplace) but the 2-6th aren’t completed. Anyone else seeing this?

Try hitting done and then going back into it. SmartThings isn’t always refreshing the actions right away.

Edit: Actually, there may be a bug. Let me take a look.

@Nightfire I was just going to place them at the top post. If you want to post them here I will copy them above. Or you can PM them to me.

Ok, there was a bug for import / export on programs with a Random duration. The fix should be in github. I have corrected the programs in the top post too.


OK what is going on here? I have a flashing H801 W1, W2 channels after a power outage.

I have an installation where I have about 15 ft of RGB wired up to the H801 R,G,B channels. then about 30 ft of Dual Row White LED on H801 W1 channel and finally about 15 ft of matching Dual White LED on H801 Channel W2.

The long 30 ft LED run on W1 was showing a noticeable dimming of the lights at the end of run compared to the beginning.

Everything was fine and working well except for the slight dimming of W2 due to length of run and resulting voltage drop.

So I went to get the end of run light drop off fixed. I thought all I had to do was cut the run in about half way junction which was at about 16 ft and then run a parallel pair of wires from this new cut section and back to the W1 terminal and VCC (+) terminal of the H801. Well this works for a short period of time until I switch off power going to the H801. It seems that when power is reapplied to the H801 the W1, W2 LED strips start an intermittent flashing about once a second and the H801 never is able to finish rebooting… It is like the H801 never finishes rebooting until I literally disconnect the wires from the extra long length of the W1 run? What is going on here?

UPDATE: It was all apparently due to overloading the H801 with too much load? After spitting off the long run it has been running perfect. I am getting another H801 to control the other half. edit: the h801 got hot enough to melt the outer case slightly!

Hi. First thank you for doing this. Great project!

I’ve flashed the h801. I’ve installed the 2 device handlers and installed the smartapp

Running the smart app it discovers my h801. But after I hit the next button it just sits at a white screen with a next button. Nothing happens.

Did I need to create my own virtual switch? Or am I missing something?

You seem to be doing everything right? Did you get all three (Service Manager, Smartapp, Virtual Switch ) loaded without errors? You might just reboot?

Also what OS are you using? I do know that I am having a heck of a time using Android right now with these apps for some reason but as soon as I go to iOS they work great and everytime.

Every once and awhile I have had that happen. I just hit back and next again and it usually works the next try. SmartThings did push out an Android update within the last couple of days though so hopefully that didn’t break anything.

Well I tried again today. And still no go. Yes Android and I have enabled Oauth in IDE just in case

Do I need to create a virtual switch first ??