[OBSOLETE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

When I made my list of things to purchase for this project I did not notice that the “Armorview PL2303HX USB To TTL To UART RS232 COM Cable Module Converter” was a ‘simplier’ version of the “Qunqi 3.3V 5.5V FT232RL FTDI Usb to TTL Serial Adapter Module for Arduino Mini Port.” I thought that the armorview PL2303HX was the USB cable to connect the Qunqi FT232RL to the computer. LOL!

So when I receivied the Qunqi FT232RL the first thing I noticed was it did not have a full sized USB and thats when I started digging deeper. I did have a regular USB to micro USB cable to test and get its driver installed.

Then I decided to test the Armorview PL2303HX and thats when I discovered the code 10 for a fake chip. Google to the rescue. How to fix PL2303 error code 10, Windows 8, Windows 10 So in the link details (click on show more) and download the file. Run the file. Then from the device driver update from the file location on the computer and pick “Prolific USB-to-Serial Comm Port Version: 3.32.105”

updated - thanks @delac

1 Like

I’m having trouble getting the LED’s to turn on by routine. It will turn off by tile but not on.

For instance, in the “Goodbye” routine, I have it turning off all lights in the house. That works fine. However, in the “I’m Back” routine, the LED’s flash for a second then turn back off. If I go to the “Things” page and turn it on, it turns on fine. Any ideas?

1 Like

Are there any other controllers that anyone’s found that use the esp8266 that work with this firmware? I see tons of various wifi controllers on Amazon and Ebay, but it’d be a crapshoot blindly ordering them hoping they have the right hardware.

These H801s seem to only be available from China and I’m way too impatient! (Although I just ordered 5 from Ali, it’s going to take 3-5 weeks for them to get here!)

FYI - Easylife 365 has them on sale for $8.30, but there’s a limit of 1.

Next cheapest is $9.05

Amazon has them. Took me less than a week and this was during holiday hours.
I’m just having trouble with the computer end. I run command and it says it can’t find the internal external prompt. I googled and get about 50 different answers. I bring it to work to try and of course my internet is down.
Seems I can’t win at this right now…

Only ones I’m seeing on Amazon are coming from China and showing 3-4 weeks delivery. I suppose they may get here faster, but not with my luck!

I ordered a couple more from Ali and paid a couple bucks extra for e-packet deliver, which seems to take less than 2 weeks normally. I guess I’ll just wait it out!

I’ve gotten all of mine within 2 weeks with normal shipping.

1 Like

Just curious what kind of power draw anyone is seeing on the LED strip lights. I picked up the Ledenet RGBW strip that Michael linked above. The full 5 meters running running through a H801, full power RGB, I am showing right at 200 watts. Showing about 120 watts with just one color at max. Unless my watt meter is giving me bad readings. I know the amazon specs on it show 60w per strip.

I’m getting about 24 watts from rbgw 4.5m approximately with all 4 at 100%. That’s the longest single strip I have. Only .32amps AC.

@erocm1231 can you share your config for your ‘candy cane’ and ‘rainbow fade’ programs?

Just received mine and flashed all ok, excellent work on this.

@erocm1231 @michaelahess

Guys I have a crazy idea, not sure if this will work or not.
Since H801 Controller can work with 5 to 24 V Input and i know we can use each 4 channel as individual key/switch. Can we use this controller as Garage door controller.

Just read me out, I know it’s crazy.
I’m using Liftmaster and those push buttons measures 16v in my garage.
Can we connect two say w1,w2 lines along with VCC to those garage door and change the H801 code so that this works as momentary switch? If so can it be used to open/close garage door? I know we will have to use tilt sensor to check whether door is close or open, but is it possible?

I was under impression that those push button in garage just finishes/closes a circuit and they don’t use any power/current, but when I checked using multi-meter, it showed 16V DC. finding/creating 16V DC power source should not be issue, but what do you say? can this be used to open/close Garage doors?

Assuming the opener is getting a simple voltage change to trigger it, I don’t see why not. Some actually encode a signal on that wire to authenticate that the actual door button is being pushed. I had to wire my opener to the actual switch on the wall vs the opener itself since mine is like this.

A relay would probably be a safer way, but you could use the H801 channels to do this. Seems overly complicated though. What would you use the remaining channels for? There are 5 actually.

You’d probably need a pot adjustable psu so you hit the 16v, just throwing a 12 or 24v power supply on the H801, would pass that through, unless you set level to a specific level on the channel I guess…

[quote=“Awestun, post:383, topic:51182”]
Then from the device driver update from the file location on the computer and pick the top of the 2 files which is older.
[/quote] I got this from Armorview Armorview PL2303HX as well but couldn’t make it work so I ordered the more “clutzy” but more reliable Qunqi which did work. Thanks for posting. I just got some of the Sonoff switches and needed to flash them so I tried your solution and bingo! This worked on my Windows 10 machine.

If I could suggest an edit to your post for clarity though for future readers and describe the updated driver file to pick as “Prolific USB-to-Serial Comm Port Version: 3.32.105” instead of “the top 2 files which is older” because in my case I had more than two drivers showing up due to other fixes I had tried so having the exact name is helpful.

updated: I don’t recommend that solution however. The FTDI using a genuine FTDI chip. See my tutorial for more info.

I removed the Armorview device from my post as well. That thing is just too buggy to recommend. Thanks to @awestun for that driver update as well!

1 Like

updated my post to pick “Prolific USB-to-Serial Comm Port Version: 3.32.105” driver - tanks @dalec

So, due to it being a fake chip and windows blocking it, I was thinking about contacting the seller thru @mazon and either asking for a refund or partial refund as it has to be ‘hacked’ to get it to work.

I think I actually did that and did get a refund…

[quote=“Awestun, post:396, topic:51182”]
I was thinking about contacting the seller thru @mazon and either asking for a refund or partial refund as it has to be ‘hacked’ to get it to work.
[/quote] I ended up sending mine back as well. It is fixed at 5v for the VCC which may be fine for Sonoff devices but not the H801 which wants 3.3v for the supply voltage.

I just got two more of the H801 in today from AliExpress. For some reason I am unable to flash them successfully like I did with my other three. I am wondering if the problem is with the Qunqi FTDI. I don’t recall seeing two red LED’s illuminate when I plugged in the USB the last time I used it? (UPDATE: the two red LED’s is normal) Can someone verify if that is normal? This is the flash screen I am getting:

UPDATE: Good grief, I got it to flash. I had to reverse the Tx, Rx connections :grimacing: This connection keeps tricking me. I need to glue my connection jumpers together in the right order for future H801 flashing.

@erocm1231 I just have to say another big THANKS for all the great work you did on this. I now have five of these up and running. Now I am working on your other similar project with the SONOFF switches. I am loving these low cost solutions and the excellent implementation you have done with the device handlers and smartapps.

1 Like

My switches activity is constantly saying off/on even though this isn’t happening and the LED strip works as it should on a colour rotation, anyone else getting similar?

I was in the same boat. I ended up making a quick video to help out those like us wanting to make the mod to Decora style.


Ive had a few of these rather useless with the stock software load controllers sitting around the place, so finding this thread was great.

Anyway, got them flashed up and configured easy enough, but I have not really done much with the smartthings hub since I got it other than move all my wemo lamps over to it from the belkin wemo link since the belkin one doesnt work with alexa.

I got thru the adding the smart app ok with those 3 lots of code to paste for device handlers etc.

Whats the next step in getting it so I can say “alexa, set the LED strip to red” and have it comply?

For those of you doing kitchen cabinet lights with led light strips, have you come up with any creative ways to cross open areas of cabinets? For example I have three groups of upper cabinets in my kitchen (one cabinet unit, opening for window, group of cabinets around a corner, opening for a walkway, group of cabinets along desk&refrigerator).

A few years ago I bought led strips and a couple IR remote switches. I put them on 2 of the 3 sections. Getting the two IR switches to turn off with one remote takes skill, if you aim it wrong they toggle out of phase until you get it just right. More recently I stopped using the IR remotes and put an extra zwave switch on the main section, it’s all I have running currently.

I’d like the whole kitchen to be controlled by one device but don’t want to go through the drywall horizontally. I thought of going down through the wall and running wire in the lower cabinets and/or into basement to bridge the gap, but I have run into problems trying to do that before due to the fire blocks between studs and it is mostly insulated walls.

I have one of these H801’s on order :slight_smile: