[OBSOLETE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

But did you already have the smartlife firmware on there ,because there is a FW update option that lets you upload a new FW bin file but I am not sure if it will work to flash a totally different FW like Tasmota since it is the ST smartlife FW
also I already am familiar with how to flash an ESP device I am just not sure if I left header pins soldered on to my H801’s , the flash would not take with out soldering for me ,I would need 5 hands to hold everything , the part I am not sure about is how to configure it before uploading it , how did you configure yours for the H801?
I have no clue on how o do it, and how to tell it what pins are being used for which channels, if you could upload your bin I could try and flash it from the current FW dashboard

You can’t flash from smarttlife web accès .
Need ftdi , already try.

I was successful in using the smartlife web firmware upgrade to a tasmota-lite.bin V8.5.1. Then upgrade tasmota with latest tasmota.bin.gz. The file size matters and the lite version is 474kb. There was no indication that the flash was over but after a while I saw the tasmota hotspot. You can configure module as H801, I used Arilux LC01 for rgb light strip. Works fine but I miss the cool animations.

Note the file extentions on the firmware file. Tasmota 8.5.1 gave tasmota the capability to used gzipped bin files hence the .bin.gz filename for final upgrade. The smartlife web interface does not support the smaller gzipped files so must use a small tasmota bin file.

Edit: It might have been the latest v12.1.1 tasmota-lite.bin it’s file is 513kb That I installed directly from the web interface.

4 Likes

What if someone in the community eventually does make an edge driver
would it involve reflashing the controller or would it just involve something on the server/ hub side.
I am not exactly even sure what edge is, will there be a replacement for the IDE or do you just upload drivers directly to the hub or something? or is it just a device FW that doesn’t need anything server side or on the hub, I have no clue how it even works or what is going on post groovy .
Can anyone make edge drivers or do you need some special access and do they need to be submitted and approved by ST to get hosted or is it just some code that you can upload to and run on the hub locally?

Yeah I will miss the animation programs too
I know nothing about Tasmota and not much about WLED either
but WLED has animations , but I am not sure if it can only be configured for addressable strips or if it can be configured for RGB/RGBW/RGBWW strips
might WLED be the better option here if does indeed support configuration for regular
RGB common
anode or common cathode strips?

Look here

1 Like

I was able to flash by inserting the pin end of the jumper cables into the header holes (no soldering needed for me). I used the web flash website in my previous post and clicked the option to erase first. After I got the board on wifi, I went into the web interface (IP address) and changed device configuration to H801 from the drop-down list.

1 Like

I can confirm that the same OTA flashing worked for me. Thanks for your guidance.

2 Likes

If anyone has successfully gotten their H801 into SmartThings app using Tasmota I’d appreciate any guidance on how you got everything set up and connected. I was on some old let firmware from @erocm1231 that wasn’t really working anymore after the transition to Edge. I successfully logged in through the existing IP address on my browser and upgraded the firmware to Tasmota. I can control the lights manually on the “control” page but I can’t seem to get them to speak to each other after adjusting the settings with the Light RGBW device that was created by the Tasmota Edge app/device in SmartThings. I’ve included some photos for context. Thanks for any help!







I’ve got two H801 controllers working with the Tasmota Edge driver.

I see in the screenshot of your old firmware that you had an admin password assigned. Do you have one assigned in the Tasmota firmware? If you do, I see you don’t have a password set for the device in the driver and that would hamper connection.

Thanks @BartschLabs. I have two devices as well and have just started with the first one. I did set an admin password and just erased it from the ST device and hid it for the controller settings for the screenshots, along with the IP addresses I had entered. I’ve tried with and without password. I’m guessing it has more to do with the IP address settings than anything else but I just haven’t been able to find documentation to help know where to direct everything.

Are the gateway IP address and port settings from ST Tasmota device/app supposed to go in the Gateway field or HA controller IP and port fields or possibly the “forward commands to IP Address” field?

Would you mind snapping a few screenshots of your setup?

You mentioned my old firmware but what I shared is what it looks like after I uploaded the most recent Tasmota bin file (aside from the fact one of the photos got uploaded out of order), so perhaps I didn’t do the process correctly or completely? My device that hasn’t been updated shows the same Smartlife menu when I log into its IP address through a web browser but it has slightly different fields and options, so I assumed this was the new one. It is still showing the old Smartlife RGBW controller settings title at the top, so perhaps I didn’t do all the required steps. I honestly just uploaded the bin and thought I was good and didn’t have to physically do anything to the device but I might be off on that assumption.

Thanks again for the ideas.

That seems to be the case. This is what it should look like after Tasmota has been successfully installed and configured.

Perhaps you tried uploading the latest version of Tasmota instead of a previous version 8.5.1 (and lite version at that) as @Hawks_nest and I found we had to do to be successful.

Here’s the URL for that older lite version:

http://ota.tasmota.com/tasmota/release-8.5.1/tasmota-lite.bin

Very helpful. I’ll try that. Thanks!

Also remember that once you’re successful running the lite version, you must upgrade to the full version for colour-controlling capabilities. Or so I believe.

It worked! Now for the next challenge…



I was able to find time over the weekend to try out updating one and then both fixtures. Everything was just as you said. Thank you so much for the helpful advice. Now I need to determine if this is able to help me recreate most of what I had in place before or if I’ve lost all of those features due to the move to Edge and Tasmota. Any thoughts or suggestions would be most appreciated!

I used the H801 setting since those are the units I have.

Here are the items I previously had incorporated and are currently not working:

-Color temperature slider not working correctly in Tasmota interface or ST.
I don’t have W1 and W2 channels set up as it’s designed to be used. My RGBW strips didn’t have two separate white channels (RGBWW) so I just used one white channel for upper cabinets on one unit and used W1 for upper and W2 for under cabinet lights on the other unit. So on one unit it just fades the light out and on the other it just fades between the two white channel outputs instead of actually changing color temp of white. I can ignore that but previously I believe my controls just turned the RGB channels to full brightness for a cool white and the white channel for warm white.



-Missing programs
We had several animated virtual devices/buttons for things like police lights that was used in an alarm routine if the alarm went off, rainbow for our kids to enjoy watching that pulsed along with music; missing virtual devices that were created for each color split out and used in routines like for when water is detected it would show a specific color, blue; a smoke detector alarm routine that showed a specific color, red; virtual devices for w1 and w2 that split the channels into two different lights that we have above and below cabinets

I’ve also lost a lot of settings that I haven’t discovered if they can be set:
Like previously i had the lights set to slowly fade on/off vs now it is quick/instant on/off; previously I had a warm white default color when the units turn on vs now it shows the last color used

My programming knowledge is admittedly limited and so it was previously very helpful that everything was able to be handled within Smartthings. Perhaps I’ll need to do some more research and learning in order to program these as close to as they were before, but I’m willing to do the work if there is still the possibility of accomplishing any or all of the features we had before. If anyone can point me in the right direction I’d be very grateful!

1 Like

I looked into whether Tasmota has the capability for LED effects or animations. It may be possible through Berry Scripting, but I can’t yet find many examples, other than those in the Berry Cookbook. Then, the way to initiate the new command you create in Berry would probably be via HTTP in @hongtat’s Tasmota driver. I haven’t yet played with sending HTTP requests to the Tasmota devices through the driver.

As an alternative, take a look at this thread:

With this alternative, you would have to flash your H801 modules with yet a different firmware image, WLED.

Thanks @BartschLabs. I had found @hongtat and WLED through some searching and am following those threads as well and am hoping for some success!

I had also found @TAustin has a virtual device driver but am finding myself possibly out of my league on how to set it up once I get it installed. Once I create a virtual device I can’t seem to find a way to connect it to my actual devices to do anything.

1 Like

You should be able to use SmartThings routines or SharpTools rules to make a real device’s attribute modify a virtual device’s attribute and vice versa.

1 Like