[OBSOLETE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

Good idea, I will do that when I get a second.

Also, new firmware release (“version”:“2.0.5”, “date”:“Dec 12 2016 16:49:27”). This is just a bug fix release for the following:

  • Fix for device losing network settings when it can’t connect to wifi after power outage
1 Like

Hello. A newcomer asking for assistance here.

I believe I have been able to successfully flash the custom firmware. The led on the H801 was flashing throughout the process and the output from ESPEasy also seems to be correct (screenshot attached).

However, after removing the jumper from J3 and doing a power cycle the WiFi access point does not appear. I’ve tried with two different H810s and the result has been the same.

Is there anything I could do differently to get the access point working?

All and any help is greatly appreciated!

That looks correct. Try to remove the j3 jumper, the ftdi adapter, then power the device up with 12v on VCC and GND. Give it 30 seconds or so and it should appear.

Thanks for the suggestion! Tried a few times and was eventually able to see the access point on an iOS device. Doesn’t make any sense probably, but for some reason both my Windows PC and an Android smartphone weren’t able to detect the access poont. Strange…

Are you using the firmware that I posted last night? If so, I may have introduced a new bug in fixing the old one which is making the AP appear only after waiting several minutes. I’m running some tests on it right now.

Edit: Yeah, yesterday’s fix introduced that bug. The AP comes up after several minutes. I have rolled back the fix and uploaded it to github. I at least know what is causing the problem and should be able to fix it soon.

1 Like

Finally got all three H801 flashed and up and running! A HUGE thanks to @michaelahess for helping me get the flash process going. It really isn’t hard if you could see how all the cable connects are done. I ended up making a video to help out those like myself that have never worked with ESP firmware updates. I really needed something to hold my hand through the process so maybe this video will do that for someone else the way Michael did with me. (Firmware updating transfer starts around 7:00 in tutorial. )

Unbelievable awesome job @erocm1231 on the device handler and smartapps. So very impressive my friend! :clap:

The first video I posted before the tutorial above. It doesn’t show all the details of setup but was intended to show what the flashing looks like on your computer when you are doing it successfully. Flashing starts at 2:15 in this first video.

All the links are in the description of video but I’ll relist them here for ease of use. If you go to any of @erocm1231 github repos for the SmartLife Devices or Sonoff Devices and you can grab the appropriate firmware bin file including the ESPeasy flashing software.

ESPeasy flashing software

Lixada H801 WiFi RGBW Controller

FTDI USB to TTL Serial Adapter
But you can use these non-genuine FTDI versions for less money and but see the photos to get the version on the left with FTDI on the backside that has been used successfully for flashing; the one on the right with YP-05 on the back has had reported issues.
http://a.co/dk8SEyI Amazon (I got this one but when you receive it make sure you received the version with FTDI printed on the backside) I ordered an eBay version which is also available on Amazon by the way UPDATE: DO NOT GET THE eBAY or Amazon (YP-05 version) the FTDI on the left is the one I got from Amazon in both pictures. You can zoom in and see the silk screening on the Amazon version is of higher quality being sharper with higher detail. On the back of PCB it says FTDI232 on the Amazon one and YP-05 on eBay version. Do not get the YP-05 version like I did from eBay as I continue to see reports of bad loads. Unfortunately sellers are not necessarily shipping what they say they are shipping depending on the inventory lot.

A slightly more expensive that has a genuine FTDI chip is this FTDI adapter by Adafruit.

@MABeatty1978 says to make sure you have a soldering iron to change the voltage setting default on the Adafruit FTDI from 5v to 3.3v for the H801; no easy jumper to change here unfortunately. The official FTDI drivers you can download here at http://www.ftdichip.com/Drivers/VCP.htm and use the “Available as a setup executable” link in the “comments” of the Windows section.

H801 firmware

Jumpers Wires Male to Male, Female to Male, Female to Female
Link: http://a.co/gxP6t0l

A couple tips I learned along the way when I had trouble flashing the device:

  • I originally got the Armorview PL2303HX USB To TTL To UART RS232 COM Cable Module Converter to do the flashing and had nothing but trouble; I couldn’t find the working driver necessary for making it work on Windows10 plus its fixed at 5v from the USB and the H801 needs 3.3v. I switched to using the FTDI board and it went great. I think the issues were due to the Amorview using a faked FTDI chip?

  • I had trouble flashing from my USB hub, switched to a direct connect to computer worked great.

  • It was easy to connect the wrong Tx, Rx pins and get them reversed.

  • Do not plug in H801 power supply adaptor when flashing. Have FTDI power the H801 (H801 VCC 3.3v from FTDI pin4 VCC) ** to minimize communication issues!

  • For some of the devices the jumper cables didn’t have solid connections to the board, they wiggled too easily. So I simply put slight pressure on the connections of cables by pushing them with my finger or even flipping the device upside down and letting gravity put pressure on the jumper cables the entire time I started the flashing upload.

  • Here is a picture of the parts I used for flashing and how I hooked them all together. The FTDI uses the “old” style mini-USB connector not the current micro-USB that most devices have today. I still had one from years ago that I put to use.

All the wiring connected as follows

here is a picture of my setup. I have a blue jumper wire on H801 J3. FTDI pin 1 and 5 left open. FTDI jumper is set on 3.3v

H801 Rx to FTDI pin2 Rx
H801 Tx to FTDI pin3 Tx
H801 3.3v to FTDI pin4 VCC **Have FTDI power H801 to minimize communication issues!
H801 Grd to FTDI pin6 Grd

FYI, the photos are high resolution so you can zoom way in to see the connections and wiring up close.

Just testing out using a single H801 for controlling my super bright double row LEDs for the under cabinet countertop lighting on channel W2 and the RGBW which is for the top of the cabinets. It works like a champ!

Just for clarification since the photo isn’t clear here; I had to extend the white wire of the RGBW strip by soldering a small piece of white wire and I shrink wrapped it so that it could go to the other side of the H801 and get terminated on the W1. Then I had to do the same thing with the black wire of the dual White LED strip and extend it using the brown wire and terminated on W2.


Hey all,

I got my first H801 setup the other day, big thank you to @michaelahess for the help! Now my mind is already going nuts with project ideas.

I was curious what the best way would be to integrate a physical switch such as the switch @erocm1231 used in post 74 above to only turn on a white section of a rgbw strip and have the rgb section controlled via SmartThings. I am working on a project for my undercabinet lights and I want to be able to control the over sink lights via a switch to be used normally. See the picture below. The switch I want to replace is outlined in red, the blue line is where I want to have the white lights.

If I missed something similar to this in the thread, please just aim me to the post number. Thank you!

1 Like

I don’t have a monetary switch, just an old normal flip one, in my bedroom closet. Mounted in the wall. If I want the strip to turn on manually, I have it wired to j3 and just flip it. Disable j3 in the firmware if not using monetary switches so you don’t put it back in flash mode accidentally from a power bump.

I have an unmounted paddle switch attached to the controller in my office, cuz I’m lazy, same thing. I have default color set to a light blue, if i want it on outside my various automations, just flip the switch back and forth.

I’d recommend a monetary switch if you can find one that will look good for your application. I use voice and CoRE for 99 percent of my users so it hasn’t begins an issue with the WAF yet.

Hey, @erocm1231 that switch you used in post 74, looks like a normal style decora switch, did you modify that to be a monetary switch? The thread you have linked for the Legrand Adorne switch modified doesn’t look like the one in your video. I am looking for the Decora style switch you use in your video.

Thank you!

Stupid question but new to using the IDE in the UK, what do I enter for the repo


To install the app and handlers??

Amazing project BTW, have used a few fibaro’s but ordered a couple of these from china to play with now :slight_smile:

It was a normal Decora switch from Lowe’s. I modified it in the exact same way as the adorne switch in the post. I’ve actually done that to dozens of switches and they work pretty well.

Inspired by @C_Hobbs here Some front door Christmas LEDs.


Ok, thanks! I got a Leviton switch to try it and it has a metal bracket around the back, making it impossible to pry open. I’ll try a different brand. Thanks again!

I stick a small screwdriver or butter knife in the crack between the paddle and the switch housing (in the middle) and just pry it up.

1 Like

Ahhh ok - thanks!! I’ll give that a shot tonight.

I was thinking the other day and not sure if this is possible, but would there be anyway to set the switch up where if you single tapped it would do one command, such as turn on just white lights, and if you double tapped it would turn on RGBs?


I definitely have this on my to do list. I have been working mostly on a sdk related bug that has been hard to resolve. This has been taking a lot of my free time.


Do you happen to have the settings you used to create your fire effect?


Downloaded latest bin file which appears to be much smaller than any thing I have seen the videos and posted images. Flashed with no problem but wifi never shows up. Tired using 12v and still nothing.


1 Like

4 Actions

Fade to red (40%) for a random time between 100 and 1000 milliseconds
Fade to orange (20%) for a random time between 500 and 2500 milliseconds
Fade to red (60%) for a random time between 100 and 1000 milliseconds
Fade to orange (40%) for a random time between 100 and 2500 milliseconds

@nickelk13386 Make sure you have the firmware in the github repository. I rolled it back a few days ago because of a bug. I tested and uploaded it again tonight just to make sure.

If it still isn’t showing up, do a factory reset:

Finally got the bin to download correctly, flashed and works.

Great job