[OBSOLETE] SHM Delay Version 2.0

Mode Fix is set to On.

I have a 30 sec delay in SHM Delay. I did the test again and opened the Simulated Sensor before the 30 seconds and it went off… ?

Then there is something wrong with the delay profile. Try saving it in CLASSIC.

Ok. I think I did that but I will remove the Profile and add it back. My laptop gonna die any second as I’ll continue again in the am. Thanks so much for your help!

One other thing rt quick. I can open and close sensors in classic but not in new app. Does that matter ?

That is the latest. :crazy_face:

I followed the steps in section 23, installed the Simkypd app, saved but not published, enabled AOuth, installed Internet Keypad device handler , saved, published, created a simulated keypad using this DTH and set the 8 digit ID in the simulated keypad . The input from the simulated keypad shows pin received and on, partial or off but it does not actually changed the SHM state. However, if I change the state from the Classic app the status updates on the simulated keypad immediately. Tested on both the mobile app and web based url.

Any suggestion where to look for a fix?

Thanks in advance.

Edit: Update, hovering over the panic button for 3 seconds generated the popup to hit OK for the panic and it worked.

Are you saying this works with SHM and Classic, but not STHM and the new App?

I never tried the sim keypad with the new app, I’m 100% on Hubitat, and I no longer use ST. I know there are issues using STHM with SHM Delay so use Classic.

I am using it with SHM and the classic app. My “tested on both” statement refers to both meaning the classic app and the web based url.

Ok now I understand your issue.

  1. Make sure you have a valid Modefix profile
  2. Check if you are using routines, if this is a new install they are likely not available and you should be using Modes. See setting in globals.

Hello again. Did I read you are using Hubitat as well? If so, are you aware of any issues, especially regarding entry and exit delay? I am stumped still and considering trying Hubitat instead of Smart Things…
Thanks !!

I am 100% on Hubitat. Entry and exit delays are builtin, although you may want to enhance the system’s capabilities with my Nyckelharpa app

Hey @arnb or @oldcomputerwiz I have setup everything in the new app as your instructions suggest, but I am not getting any notification once I arming , disarming or putting it in stay. Am I missing a step somewhere?


Unfortunately, I have been forced to completely give up on using SHM Delay within the new app and STHM.

I have encountered too many errors and way too much unpredictable behavior from within the new app. I have moved my system back to the classic app and will stay there until the new app becomes stable or I change to another platform.

Sorry, I am not able to offer any assistance.

1 Like

Thank you @oldcomputerwiz for the reply. I was making sure that I didn’t miss something. I will keep using the classic app until I hear anything new. Thanks again!

That’s exactly what I would do.

Help. I literally have tried everything. I am sure my neighbors hate me right now because the alarm keeps going off while I am trying to get this to work. I have tried for over a year with no luck. I now have everything setup and the sim open/close setup and working to wait 30 seconds. the only problem is that any motion sensor in the house sets off the alarm. I have turned off all the sensors from being monitored but it still goes off. What do I do? every time a sensor goes off it says intrusion sim door. Please help. I also can’t figure out the 30 delay so that when we come home we have 30 seconds to disarm. It actually might be working but the motion sensor sets it off before allowing the time.

The simulated sensor is always shown by ST to be the culprit. However, if you have global setting “This app issues an intrusion message with name of triggering real sensor?” on it SHM Delay creates a message in the notification log with the name of the triggering sensor.

Assuming it’s a motion sensor add follow the instructions and add it to Delay Profile.

This is all documented at the top of this thread.

How do you create a modefix profile? All I see is Delay, User Sim keypad and Talker Profile

  1. Verify SHm Delay Modefix is installed (unpublished) as documented at top of this thread
  2. On phone open SHM Delay app, scroll to Mode fix Settings at bottom of screen, tap it.