[OBSOLETE] SHM Delay Version 2.0

I hate to bother you, but I’m at my wit’s end. SHM Delay Version 2 just suddenly stopped working today. The keypad (Centralite 3400) wouldn’t respond properly. I’d push Away or Nighttime and the PIN, and it wouldn’t execute.

I tried the keypad reboot method of holding the tamper key while replacing a single battery, and that seemed to go as expected, and it may have fixed the problem. I’ll see.

As part of my attempt to fix things, I deleted the SHM Delay profile, and tried to re-create it, and now I can’t. It hangs up at the “Next” screen after entering the real contact monitor to follow and the virtual contact to trigger. Hitting next does nothing. It tries to advance, and doesn’t, so I can’t save the delay profile. I tried reinstalling (but not publishing) the child app to no avail. Attached is a screen shot of my IDE.

Any advice?

Thanks so much for your very useful app and your time,


Never mind! I tried it one last time before bed and it worked this time. No idea why!

1 Like

SHM App stopped working this afternoon. I deleted keypad, app, device handler and reinstalled everything. SmartThings sees the keypad as Lowes Iris Keypad. The motion sensor gives information to the system.

The smartapp and children are installed, with the smartapp SHM Delay published.

When I go into the Smartapp on the phone, I can’t add users. There is no option to make a user and create pin numbers.

Please help!

Yes unfortunately I’m aware of the issue, it’s an undocumented cloud system change.

Sorry you tore your system apart attempting to fix it.

Similar behavior for me. I’m using the Centralite/Xfinity 3400 keypad and as ArnB says, Pin Arming does nothing now. The 3 lights just cycle endlessly. If the alarm is triggered, Pin Disarm doesn’t work either. I also deleted everything and reinstalled with no resolution, which I guess is now known. I was able to add users and delay profiles to the app after starting afresh, but of course that did not restore keypad function. If system armed/disarmed via another route, the keypad lights change appropriately (i.e. ModeFix works). It is only keypad input that is broken I think. This kind of thing gives developers a headache. ArnB, I appreciate your great app and hope the fix doesn’t take too long to get the keypad working again.

[Mandatory Update] May 8, 2019 21:45 EDT

Your system MUST be updated


  • Unable to Arm or Disarm, or set Panic from keypad device


  • An undocumented change to the SmartThings cloud platform caused the DTH’s createEvent statements for Pin and Panic processing to be ignored.

  • A big thank you to @bamarayne for determining the cause of the issue, and sharing the solution.

Enhancements and Changes

  1. Corrected the system failure.

  2. The updated keypad DTH includes support the the Iris V2 Alarm feature

I urge everyone to stay up to date, please update your system,

Do not use this DTH with other apps not specifically modified to handle the updated data format.

How to Install
There are two (2) modules associated with this update, both mandatory.

  1. SHM Delay (v2.2.9). Module should be Installed, Saved, and Published

  2. Centralite Keypad DTH Module, change Github repo , install, Save, and Publish for me.

  • Go to the IDE, click ‘My Device Handlers’, scroll to ‘Centralite Keypad’, click hamburger icon on left, scroll down, click Update
  • Change the GitHub Repository to SHMDelay (Version2) (The version in github miriad Centralite-Keypad master is outdated and will fail. Do not use it.)
  • Scroll down, click Update, click “My Device Handlers”
  • Click “Update from Repo”, select SHMDelay (Version 2), then select the Centralite Keypad to update.
  1. Install via the repository (preferred), from the following repo.
    Owner: arnbme (in upper case that is ARNBME)
    Name: SHMDelay
    Branch: Version2

Post Installation
No settings changes are required

RBoy DTH Users
Use Enhanced ZigBee Keypad Lock Version 01.08.00 or higher with SHM Delay module V2.2.9

Unable to get new DTH or SHM Delay modules with ST github interface
The source is available for manual update at




Thank you @arnb and @bamarayne! I appreciate all of your efforts!

1 Like

You are most welcome. Please take a look at the comments in the DTH and apply the createEvent and sendEvent changes to your custom UEI keypad DTH derived from M Pond’s DTH.

I just pulled the one you updated. I’ll make changes to the battery section to reflect the needs of the UEI keypad. The battery was the only change I made to the MP DTH to work with SHM Delay.

It worked as expected. I just tested the UEI keypad with my pin and it sent the disarm command and set the mode to Home. Fantastic. I can enable the siren again.

I would like to publish that DTH in the SHM delay documentation, please send me the Github repo

I’ll get it updated tomorrow and send it to you @arnb . I still need to clean up the debris from my projects today before bed and am rapidly running out of ambition. :sweat:

All, I’m having a bit of an issue here.
Background : my IRIS 3405-L (v2) Keypad started acting funny and then I realized the batteries were dead. I changed out the batteries, but then it wasn’t beeping anymore. I removed and reinstalled it from the network a few times (and I may of smacked it once…) and the beeping started up again! Except it stopped taking all PIN codes. I have both the “new” and “old” Smartthings apps on my phone, so I thought maybe the SHM Delay app stopped working for some reason. I removed and reinstalled that as per the instructions a dozen times… nothing… I then tried the old “User Lock Manager” and “Smart Lock” apps… they didn’t work either… The “new” Smartthings app does have a delay built in, but no keypad functionality, so I can’t use it and get rid of the old app. I tried looking at webCoRE, but I have no clue what the proper commands are for the keypad or how to set PINs in it.

What… do…I… do? Has anyone else been met with a IRIS 3405-L (v2) keypad that suddenly stopped working after changing the batteries? or was this a DTH issue since i updated that the same time as the batteries…

Scroll up a bit there is a MANDATORY update that fixes this issue.


@arnb , Thank you! I didn’t see that post. I changed to your DTH, but even after updating the latest SHM Delay on your repository, I’m still only on v2.2.8 (that’s what it says in the app). It isn’t allowing me to select the Keypad in the Global Settings within SHM Delay.

EDIT # 1: I installed your “internet keypad” DTH. I just noticed that you uploaded a new centralite DTH. just installed that one…

EDIT # 2: It works! scrolling up to donate!


Thank you for catching the version number discrepancy that is now corrected. It’s been a hectic day!

1 Like

Hi arnb,
I was on a business and just got home last night then realized my Iris keypad v2 can’t set armed, armed stay and disarmed anymore. Is this the same issue you mentioned? Thank you.

1 Like

Yes. Scroll up a bit there is a MANDATORY update that fixes this issue.

1 Like

I’m currently using the mitchpond DTH and am trying to follow the instructions for the mandatory upgrade. The app updated fine, but the only thing I see when I choose your repo to update from in my device handlers is internet-keypad.groovy. Do I need to remove the mitchpond DTH first? Thanks.

I don’t understand why that is happening, it’s working for me. I suspect it may be the namespace field. I’m going to change it let me know if it does anything

The source is available for manual updat at