[OBSOLETE] Qubino Flush 1D Relay, Flush 2 Relays, Flush 1 Relay, & Flush Dimmer

@erocm1231 Hey thanks for the work on this - Let me run something by you and see if I am interpreting this right - I want to use this in a 3 way switch configuration - if I have this right, (of course running Line an Neutral) The Load line between the switch and the light would go from the switch to I1 and then Q1 would go out to the light… Does that sound right?

No, this won’t do what you want. The inputs are for switches to cause the relay to do something on the output.

@erocm1231 for some reason, the toggle switch doesn’t seem to work. It doesn’t matter if I set it to push or toggle, I need to always turn it on and off to change the status of my lights. Also, when I turn it on using the smartthings app, it automatically shuts itself off again.

My Led bulb doesn’t seem to work well with the dimmer so that’s something I’ll need to fix. However, it seems strange that it would impact the toggle behaviour.

@erocm1231 I am having some issues with the Alexa integration. It says server is unresponsive. When I check the debug logs, I noticed that there is an error since I don’t have a connected temperature meter. Would it be possible to add a disable setting for the temperature readings? It might help the Alexa integration.

I am not using a temperature sensor and am still able to control master or child 1 or 2 independently with Alexa. Hope this helps track down the problem. I’m sure you have, but I’ll throw it out anyway. Remember to run discovery with Alexa.

I contacted smartthings support and they said it is a known issue. There is a potential solution where you reset your hub, disable the skill from Alexa (both via Alexa and smartthings app) and enable everything again. Unfortunately this didn’t work for me.
I’m on a contact list for engineering now.

I’m only having this problem for the qubino dimmer and I don’t have the same problem for my hue bulbs (connected without intermediate bridge). I will try to test other devices as well. If I control all lights simultaneous (hue and qubino) she replies with the expected OK.

I will post it here if I find a solution at some point.

I’ve installed the device handler and I’m able to control my lights now from the Smartthings App… which is what I wanted to do.

I was initially having trouble because I could not turn my lights off… toggling the button on the app turned the lights off then they came right back on.

After reading all of the comments, I took all of the bulbs out of the fixture, pressed the on/off button on the wall switch a few times, then tried only 1 of the bulbs. The on/off and the dimmer worked. I tried each bulb individually, and each one worked. Then I put all of the bulbs in.

I’m not using any external sensors. Is there a particular setting that the group likes to change? Thanks!

I’ve started having intermittent issues with the status of the relays in my Flush 2 Relay unit not updating in Smartthings the they’re off, anyone else see this issue?

It will sit their indefinitely in the On position until I manually refresh the device from the Smartthings app, then it shows the correct Off state.

Any ideas?



I have the exact same issue with my Flush Dimmers.

Is iT possible to make the child device pop up as thing with the flush 1D.

IT worked with the 2 flush relays perfectly.

But with the 1D i’m out of luck…


I am having great trouble configuring a Qubino flush on/off thermostat (ZMNHID1). I have installed all of @erocm1231 Qubino device handlers and tried all of them. The device rarely autodectects and when it does it detects as a Home Energy Monitor and changing the handler to any of the Qubino handlers makes no difference, there does not appear to be any communication to the device, no temperature is reported and I can not turn it on manually.

Any pointers would be greatly appreciated.

1 Like

Same for me.

@erocm1231 Just wanted to say thanks for these handlers. Great work as usual. I am, however, seeing the exact same issue that gazzer is. Just wondered if you had any ideas.

I installed my first Qubino Flush 2 Relay yesterday. I had your handlers installed already and the relay paired-up just fine with ST. But the status update thing is an issue.

EDIT: I wonder if this is related. Perhaps an issue with Z-Wave Plus in general?

Just casual observation over the past few days - my status seems to be updating a little better.

I’m also having trouble, with a flush 2 relay. One out if 5 Times the Q2 won’t update. When i prees refresh Button iT Will.

That’s probably about what I am seeing.

The parrent and child Q1 tile do update!
And when i hit refresh BUTTON iT also updates.
Swiping to let it refresh won’t work

I’ve got 4 of these dual relays. This is the last one i installed today and is the only one having troubles

Hi, and thanks alot for this Device handler! Everything is working great, but I have one issue With Alexa integration.

I am using the qubino flush dimmer, and when I give commands to Alexa, it Works, but it replies the following phrase: “smartthings isn’t responding” on whatever command I give. Both “turn on/off” and set dimmers to a certain Level.

I think it has something todo With the phrase pasted below from my log, but since I am a terrible noob 2000 turbo in this game, i’d rather post the issue here and hope for the best.

11‎:‎47‎:‎17: error groovy.lang.MissingMethodException: No signature of method: script_dth_373293e5_d466_425a_8355_73c7cf052781_ver_0_1.logging() is applicable for argument types: (java.lang.String) values: [Adding MultiChannel association group 1]
Possible solutions: toString(), ping(), toString(), command(java.lang.String), main(java.lang.String)

Any idea’s?

Have you logged in IDE on pc en changed Home energy monitor into the device handler of erocm?

I have the same issue, did you manage to sort it?

@erocm1231 i have the same issue as above, can you help?

Switch in off position, on and off work from the app
Switch in on position, light turns on, app shows on if i turn it off with the app it turns the light on for half a second and the light comes back on.