[OBSOLETE] OSRAM Lightify Smart Dimmer Switch (button controller device handler and smart app)

I have tried pressing with the holder off. I have 3 of these dimmers and
the same thing happens with all of them. It recognizes when the button is
released, but doesn’t recognize it being held.

Here is the log when holding and releasing the *up *button:

4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:21 PM: debug stop brightness
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:21 PM: debug catchall: 0104 0008
01 01 0140 00 850D 01 00 0000 03 00
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:21 PM: trace Executing
commands-- state:[lastAction:1485208281087, pressed:0, buttonNumber:1,
boundonoff:true, dimmer:100, boundnetwork:false, brightness:100,
brightening:true, dimming:false, battery:66, value:raising brightness,
lastHeld:up, on:on, bounddimmer:true] commands:[st cmd 0x3A94 0x03 8 4 {ff
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:21 PM: debug Living Room Dimmer
commanded on
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:21 PM: info Brightness commanded
to 100.0%
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:21 PM: debug adjusting
brightnessup from current 100
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:20 PM: debug Button held-
raising brightness commanded
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:20 PM: debug catchall: 0104 0008
01 01 0140 00 850D 01 00 0000 05 00 0032

Here is the log when holding and releasing the *down *button:

4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:10 PM: debug stop brightness
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:10 PM: debug catchall: 0104 0008
01 01 0140 00 850D 01 00 0000 03 00


I have tried Motley’s Device Handler. The switch is properly detected. Switch presses are detected and logged. However, when I add a smart app to control the switch’s output (tried both Smart Lights and Double Tap), the switch is not presented for selection. Instead, I just see my other light bulbs and plug in dimmer.

Obviously I’m missing something . . .


I think you have to use the smart app associated with the device driver.

There are a few other version out there. I created one that shows up a switch, and then you can use any app that works with a switch to control you lights ( I use dim with me). This will work with Amazon Echo, who apparently doesn’t do buttons.

Also @adamoutler, created a device driver that binds directly to up to five devices and does press and hold to dim.

Hope this helps!

1 Like

Thanks. The first part of your post made me go back and re-read Motley’s posts. I then saw that this is configured as a button, not a switch, to Smart Apps. I’m able to see it using the Button Controller.


I just bought four of these and have the same issue.
I’m going to try debugging myself soon here.

I updated Motley’s smartapp for if you want the various buttons to trigger routines instead of individually hitting lamps/lights:

Awesome. Thank you. I hadn’t been able to get them to work as expected. I’ll try your smartapp and see how things go.

Same here, device works, except for: * held down 'catchall: 0104 0008 01 01 0140 00 3A68 01 00 0000 01 00 0132’
That command isn’t coming through, just the button release, released 'catchall: 0104 0008 01 01 0140 00 3A68 01 00 0000 03 00 ’

Net effect:
push up/down work
hold up works
hold down does not work

very welcome. works great for me except for a) I didn’t intend the up and down hold to be required and b) the down hold still doesn’t work, but that’s a device handler issue not a smartapp issue.

I’m going to try adding a default section to the switch statement in the device handler. I suspect it’s just not being correctly parsed and since there’s no “oops, I don’t know what to do with this” section to the code it’s just failing silently.
I’ll post my results here when I’m done.

I picked up the Osram 4 button “switch” - can this DTH be adapted to accommodate the 2 extra buttons or do I need to look at starting from scratch?

Thanks in advance for any advice!

1 Like

I gave that a try, and didn’t have any luck. Any luck on your end?

none. It appears that they’re just not firing anything at all.
I should probably turn up debugging on the one I use with a different device handler and see what it outputs…

probably from scratch - though if you look around you’re far from the only person to want to use it so maybe it’s already been done.

Would you guys mind creating a new thread to troubleshoot the 4 button osram device? I keep notifications on this one active in case the developer updates the DTH or something, and it would probably make more sense for a different device to be discussed in a different topic. Thanks.

1 Like

The OSRAM Lightify Smart Dimmer Switch now works “natively” without custom Device Types or Handlers.

Recognizing the amazing work done by Adam, Michael, etc to create far more comprehensive utilization of these switches / buttons, I did want to clarify for anyone looking to use this device as a simple button controller - it works out of the box with ST. I felt obligated to post this clarification, because I, like so many others, just wanted a button controller that

a) Doesn’t require custom device types or handlers
b) Communicates with the ST Hub (Not directly to bulbs, etc)
b2) Giving me the ability to control or initiate any action, control any number of devices, etc using a SmartApp
c) Gives me 2+ “buttons” (This one has 4 when you use Button 1 and 2 along with long presses
d) Could look relatively normal installed on a wall (I would ABSOLUTELY prefer a main powered scene button controller that could be installed in a switch gangbox.

Other than the desire for a main powered device (like the Leviton VRCS4, which I believe still requires custom DTH), this switch did everything out of the box.

I pulled the battery tab; it connected to ST as a “ZigBee Button;” I gave it a name; It doesn’t show any buttons in the ST app when you pull up the device, but the 4 buttons are there - you can easily access them in any Smart App:

SmartApp - Automate Lights & Switches
What do you want to [control]?
What to you want it / them to do?
How do you want to trigger? --> "Button Pressed / Held"
Which Button --> Choose [Whatever you named the OSRAM Dimmer switch]
Button Number --> Choose 1 or 2
Button Action --> Choose “Pushed” or “Held”

It’s all there. You can use the 4 “buttons” to perform any action you want in ST - Close a garage door, turn on a bunch of lights, change the color of lights (scene setting), etc.

I’ve had no problems with the device at all. I have searched the boards relentlessly for a good (enough) button controller option beyond the handheld remote, and I just wanted to post this here to help anyone else with the same questions / desired application.

Now if anyone knows of a main powered option that would fit nicely in a switch housing and works as easily out of the box…


Several ppl on amazon said they couldn’t get the 4 button model to work with ST, could it be that only the two button works?


That’s a completely different device. Sylvania currently makes three different button devices.

This thread is for the “smart dimming switch,” model 73743


You are asking about the “button switch” model 74099


Please ask your questions about the button switch in the threads about that device.

It doesn’t really have anything to do with this particular thread except that they are made by the same manufacturer. :sunglasses:

I bought the Osram Smart+ Mini switch : https://www.amazon.co.uk/Osram-Smart-Switch-Wireless-White/dp/B074PYT9R4/
It’s a dimmer switch which looks similar to the SYLVANIA, but has a rubber cover. It’s not recognized by ST hub. Anyone else had any luck with it ? Works fine with Osram bulbs by itself, without the gateway, just can’t get ST to recognised it. The Smart+ bulbs work fine with ST, so I assumed the switch might as well.

I’m having the same problem with the Osram Smart+ Mini switch. I don’t have any Lightify bulbs so can’t test it with that, but I’m not convinced I can even get it in pairing mode - I’ve done the hold down the middle and bottom button per the instructions but it doesn’t keep flashing blue like I’d imagine it would.

Would love to get this paired with Smartthings as a Zigbee controller.