[OBSOLETE] OSRAM Lightify Smart Dimmer Switch (button controller device handler and smart app)

That’s a completely different device. Sylvania currently makes three different button devices.

This thread is for the “smart dimming switch,” model 73743

You are asking about the “button switch” model 74099

Please ask your questions about the button switch in the threads about that device.

It doesn’t really have anything to do with this particular thread except that they are made by the same manufacturer. :sunglasses:

I bought the Osram Smart+ Mini switch : https://www.amazon.co.uk/Osram-Smart-Switch-Wireless-White/dp/B074PYT9R4/
It’s a dimmer switch which looks similar to the SYLVANIA, but has a rubber cover. It’s not recognized by ST hub. Anyone else had any luck with it ? Works fine with Osram bulbs by itself, without the gateway, just can’t get ST to recognised it. The Smart+ bulbs work fine with ST, so I assumed the switch might as well.

I’m having the same problem with the Osram Smart+ Mini switch. I don’t have any Lightify bulbs so can’t test it with that, but I’m not convinced I can even get it in pairing mode - I’ve done the hold down the middle and bottom button per the instructions but it doesn’t keep flashing blue like I’d imagine it would.

Would love to get this paired with Smartthings as a Zigbee controller.

@Motley - Received and installed my first of these switches today. Paired easily w/your DTH and functions great w/the simple programming in the SmartApp you provided. Solves a problem I had where I didn’t want to have to stuff another smart switch into a crowded box, so being able to just mount the switch over the box and control w/your DTH/SmartApp was perfect!

Excellent stuff - thanks very much!

Hi there! I’m not a code person AT ALL so have no idea how to correct this. I was able to install the binder with no problems, but the first app won’t install. I keep getting this error:

No signature of method: script_app_metadata_089d2143_f222_444b_a26a_d68c921ed619.metadata() is applicable for argument types: (script_app_metadata_089d2143_f222_444b_a26a_d68c921ed619$_run_closure1) values: [script_app_metadata_089d2143_f222_444b_a26a_d68c921ed619$_run_closure1@7e54737a] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

Do you have a fix or know what I could do to fix it myself? I’m a total noob to all this, but I’m assuming you must have both apps installed to properly dim the switch. And just to confirm…in theory this will replicate “live dimming” on the lightify switch so that when you hold down a button it will gradually change the level of the target. Thanks!

Make sure you’re adding the device handler and the smartapp.

Each one goes in its own section of the IDE.

Edit: also it’s not entirely necessary to install this device handler and smartapp anymore. There’s a generic device handler that works with it now, and you can use it as a button controller in the ST mobile app. Not sure whether you can dim with it that way though.

Curious if this remote can support multiple bulbs (4) as a group. i.e. 4 bulbs in one fixture.

Using the smart light app, you can select multiple lights for it to control. Or, using the trendsetter community app, you can group them together so that they are in sync. (Search the forum for trendsetter)

I have a bunch of these setup as Zigbee buttons to control all my Hue lights. I also have two Hue dimmers and I love the ability to dim the lights. The reason I went with a bunch of these switches was so I could cover up the existing light switches so people don’t switch them off.

Anyway, I’ve tried using the universal device handler and entering the network device id into the properties of one of these buttons and it doesn’t seem to do anything. Am I doing something wrong?

I just use the standard Zigbee Button DTH and SmartLighting to do the job. It also keeps it local.

Yes, that’s what I’m doing at the moment, but I’d like to have the dimming feature.

1 Like

I’m not seeing anything in the battery tile:

If I wanted increase the range of brightness in your smartapp from 10-90 to 10-100, would I just change the values here:

section(“Set level for button 1 hold…”){
input(name: “upLevel”, type: “number”, range: “10…90”, title: “Button 1 level?”, required: true)
section(“Set level for button 2 hold…”){
input(name: “downLevel”, type: “number”, range: “10…90”, title: “Button 2 level?”, required: true)

with “10…100”?

Is this particular DH no longer supported? Looks like last commit was a while back. Im just trying to get this device to work in ST, and then make a webcore for it. Right now, the default handler intermittently works.

For those that stumble on this, there are 3 (maybe 4) handlers. There is a good FAQ on the topic

Ive tried to get dimmable functionality in webcore with my own handler – its a work in progress:

at least 3 or 4. I created a controller based off of this one that treats the device as a virtual switch. works well for me…

@nsweet Thanks! Did you ever solve:

I have been trying to figure out how to have the hold continue to raise or lower the level, but have been unsuccessful

I came up with a way based off @adamoutler version - if you want to grab it:

I wonder if the virtual switch would make things cleaner for me… Thanks for posting!

I did a quick update for a version 2 – no real improvements outside a little code clean up

The new ST app and this act a little off.

I had the top button set to turn on some lights, and the bottom button set to turn off some lights. Now, I’ve migrated to the new smart things app, and it’s only showing up as one button/device. Regardless of which of the two ends I push, some lights turn off, others turn on. It’s a sh*tshow. Any advice? Does the new Smartthings app support multiple actions/actuators on one device?

How can I get this device working with all the recent changes to smartthings?