[OBSOLETE] OSRAM Lightify Smart Dimmer Switch (button controller device handler and smart app)

Do I just need the DTH and no smartapp if I simply want to use this to trigger an existing ST element (a smart switch or smart outlet) to come on or off?

Look at what I wrote three posts up :point_up_2:

1 Like

Thanks…my bad. :slight_smile:

Hi all,
I got the switch to pair, but it only recognizes one of the buttons (the “on”). How do I get the hub to recognize both the on (the top button) and the off (the bottom button) conditions? I’m controlling a smart plug so that I can turn on some lamps in a room without a switched outlet. It’s like the pairing only recognizes “button 1” even though the “recent” activity will show button 1 and button 2 presses or holds. When trying to use the Smart Lighting app, it only seems to recognize button 1. What am I doing wrong here?

Also, It doesn’t show the battery percentage. It seems as if it isn’t using the device handler I installed.

Could be. If you go to your device list in the IDE, you can select it and see whether it’s using this custom device handler or another one. If it’s not the right one, click the drop down menu to change it.

I ended up changing to Adam’s code and it works good!


I’ve got this mostly working, although with a delay and occasional misfires.

I’m using with 2 Cree bulbs thusly:

  • Motley’s device handler (buttons)
  • Button Controller Smart App
    • Button presses and helds are mapped to Routines

Such that there are three states:

  • Both lights on (press Button 1)
  • Both lights off (press Button 2)
  • Both lights at 10% brightness (hold Button 1)

I’ve done it this way because I intend to also control a switch that turns on/off an incandescent lamp, but my setup feels over-engineered. I’m using a smart app AND routines, which seems like a gross overuse that may be responsible for the 1-2s delay between input and reaction. I tried doing this with direct control per bulb, but that way only seems to recognize a single button for the whole switch.

I’ve also noticed that the OSRAM switch occasionally fails to register button presses. I’m thinking this may have to do with the ST hub being too far away from the switch?

If anybody has advice on how to simplify this setup to achieve the same result, I’d be happy to try adjustments.

I’ve been trying to setup the Osram Lightify dimmers with a couple different Osram bulb scenarios but no matter what I do, it won’t recognize holding the down button. It recognizes the button up press, button down press, and button up held, but not button down held. I’ve tried motley’s device handler and @adamoutler and @Motley and neither works. I can turn the lights off and on, but dimming won’t work. Everything works in the app but not with the actual switch. I have 4 of these dimmers and 2 of them so far with the same results.

I’ve tried it with 2 OSRAM LIGHTIFY RT5/6 RGBW recessed lights and with a single OSRAM LIGHTIFY Smart Connected Light A19 RGBW bulb.

Any ideas what I’m doing wrong?

I’ve been using this DTH for a while now, since it works better than any of the others for button smartapps. It has been working great. I recently made a few changes to report button information just to make it easier to use with button smartapps.

capability "Holdable Button"
def installed() {
    sendEvent(name: 'numberOfButtons', value: 2)

I also tried to get the battery level to report but so far I get a level of 88% on all 3 of my remotes so I don’t think that part is working yet.

If you have live logging running do you see anything show up when you hold button 2 (down)?

Yes, done live logging and nothing happens on button 2 held. Button 1
press, button 2 press, and button 1 held, all show proper logs.


1 Like

It should always show Parse returned $device.displayName button 2 was held in the live logging, maybe try pulling your button out of the holder and trying it? The holder has a subtle notch to require it be installed only one way and if it is in there wrong maybe that is interfering with it somehow. Did you say you have some that are working? If so and they are all using the same DTH, I’d guess it is a HW issue or maybe try removing one of the bad ones from the hub and add it back to see if that helps.

I have tried pressing with the holder off. I have 3 of these dimmers and
the same thing happens with all of them. It recognizes when the button is
released, but doesn’t recognize it being held.

Here is the log when holding and releasing the *up *button:

4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:21 PM: debug stop brightness
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:21 PM: debug catchall: 0104 0008
01 01 0140 00 850D 01 00 0000 03 00
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:21 PM: trace Executing
commands-- state:[lastAction:1485208281087, pressed:0, buttonNumber:1,
boundonoff:true, dimmer:100, boundnetwork:false, brightness:100,
brightening:true, dimming:false, battery:66, value:raising brightness,
lastHeld:up, on:on, bounddimmer:true] commands:[st cmd 0x3A94 0x03 8 4 {ff
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:21 PM: debug Living Room Dimmer
commanded on
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:21 PM: info Brightness commanded
to 100.0%
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:21 PM: debug adjusting
brightnessup from current 100
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:20 PM: debug Button held-
raising brightness commanded
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:20 PM: debug catchall: 0104 0008
01 01 0140 00 850D 01 00 0000 05 00 0032

Here is the log when holding and releasing the *down *button:

4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:10 PM: debug stop brightness
4477aa9d-a00c-4b95-b94d-96d847245c6e 1:51:10 PM: debug catchall: 0104 0008
01 01 0140 00 850D 01 00 0000 03 00


I have tried Motley’s Device Handler. The switch is properly detected. Switch presses are detected and logged. However, when I add a smart app to control the switch’s output (tried both Smart Lights and Double Tap), the switch is not presented for selection. Instead, I just see my other light bulbs and plug in dimmer.

Obviously I’m missing something . . .


I think you have to use the smart app associated with the device driver.

There are a few other version out there. I created one that shows up a switch, and then you can use any app that works with a switch to control you lights ( I use dim with me). This will work with Amazon Echo, who apparently doesn’t do buttons.

Also @adamoutler, created a device driver that binds directly to up to five devices and does press and hold to dim.

Hope this helps!

1 Like

Thanks. The first part of your post made me go back and re-read Motley’s posts. I then saw that this is configured as a button, not a switch, to Smart Apps. I’m able to see it using the Button Controller.


I just bought four of these and have the same issue.
I’m going to try debugging myself soon here.

I updated Motley’s smartapp for if you want the various buttons to trigger routines instead of individually hitting lamps/lights:

Awesome. Thank you. I hadn’t been able to get them to work as expected. I’ll try your smartapp and see how things go.

Same here, device works, except for: * held down 'catchall: 0104 0008 01 01 0140 00 3A68 01 00 0000 01 00 0132’
That command isn’t coming through, just the button release, released 'catchall: 0104 0008 01 01 0140 00 3A68 01 00 0000 03 00 ’

Net effect:
push up/down work
hold up works
hold down does not work