[OBSOLETE] Original & Aqara Xiaomi Zigbee Sensors (contact, temp, motion, button, outlet, leak, etc)

Good question. :grinning:

I don’t actually own all of these sensors, and the Aqara motion sensor with illumination is one that I do not have.

I have only worked on the DH enough to get it functional based on debug data others have posted.

Your welcome to make the changes and make a pull request. Otherwise I will look into it when I get a chance.

@ArstenA I paired my Temp/humidity sensor, it became unavailable after two hours. How do I get it back?

1 Like

Delete is and try again.

How are you adding it? Use the app, and add a thing.

Try this, near the hub:

  1. On the sensor, hold the button until it flashes, then release and wait until it flashes (takes 10 seconds?). This should reset the sensor.

  2. In the app click add a thing.

  3. Press and release the button on the sensor. Wait 10 seconds for the sensor to stop flashing.

  4. Continue step 3 until the sensor appears in the smart app. May take 5-10 presses.

  5. In the web interface look at the hub events, you should see th catchall from the sensor and also a zbjoin.

  6. Leave the sensor near the hub and hope it starts to report battery.

  7. If it fails, try, try again…


Yes that is what I did, started showing battery. Only 51% battery. I hope I can open the door for the battery change, I tried with a coin. Not sure if it counter clockwise or what to open it. A nickle didn’t work. Has anyone got it to open?

@ArstenA I believe the barometric pressure capability is not listed in the aquara temp sensor device handler. Can we add that? I’m not sure how to fix it myself. Also, someone on GitHub suggested a fix for the motion/lumen sensor to convert the light measurement to lux instead of percentage.


Tested with Aqara Motion Sensor and Aqara Contact Sensor, worked flawlessly! Great work!!

Reporting all the right measures as well, as my sensors are relatively close to the Hub no loss and response time is great.

Is it the little round one? It’s crazy difficult to open. I ruined one once trying everything from a nickel to whatever. What has worked is to actually stick it on to something and then you can twist and open it. Maybe someone else has a better suggestion.

1 Like

Is it just the center that opens or the whole white back? I tried opening just the little coin center and it tore the coin slot.

Had to change mine today anyhow (easily 6 or 7 months) - hope this helps

Whole thing, mounted with a 3M strip,

The back after rotating the front off - it’s just a short twist counter-clockwise- but sticking it to something is all that worked for me - the slot on the back just got messed up

The front where battery is




Thanks for that. When you received yours what percentage was the battery?

@ArstenA Thanks for GitHub

Had a hell of a time pairing 10 total Original & Aqara Xiaomi Zigbee Sensors the last week or so.
3 Aqara Xiaomi temp/humidity Sensors, 5 Aqara Xiaomi motion Sensors and 2 Original Xiaomi motion Sensors.
Great price but not sure the savings was worth all the time I put into them.

tried everything from changing all the batteries to wrapping in tinfoil with the hub during pairing.

Only way to get them paired was to kill all the power to my house except for the SmartThings hub V2 and the internet (which are on battery back ups) then pair them. I then lost all my other zigbee devices and had to re-sync them one at a time a few came back just by powering on and off again.

All working yesterday now the total SmartThings crash today just no luck.

Followed your instructions and removed the back. Changed the battery with new one. It still shows 55% same as it was with the old battery. Maybe it takes time to sync up. Did yours go to 100% as soon as the battery was changed?

Can you go to the IDE logs and wait for it to report the battery? It is about ever hour. Once you get a report please send me a PM with the raw message. I do not have any original temp sensors, maybe that DH is not parsing the battery correctly.


It may be Smartthings’s side a problem. They have some trouble from this morning in North America/

Platform Outage Subscribe Investigating - Some US users may be unable to load the SmartThings app, control devices, or access the web UI. We are currently investigating. Jan 4, 07:05 EST

1 Like

Sounds like you may be hitting the 32 device limit?

why are there two device handlers in the bspranger repo? eg xiaomi motion sensor and xiaomi aqara motion sensor. same for the other temp, door, outlet, etc… Do they behave differently ?

any way of identifying them via device details or by shape ? i remember a few aqara boxes when they came but have thrown the boxes away…

yes the aqara and “original” sensors do behave differently. battery reporting and a few other things are different.

Update your original xiaomi temp/humidity DH. I updated the battery reporting. Like I said before I do not have one of these to test with. but if I didn’t screw up the battery will probably report correctly now.

oops at 35 (1 Xiaomi aqua motion sensor does not have a zigbee id in ide but still working) now with the new 10 Xiaomi but all appear to be working guess I am maxed out now

Ok thanks, How do i identify what i have?
Btw great that you picked up the repo, much appreciated!

Best regards,