[OBSOLETE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

The key to determining sensor vs. no sensor is a contact sensor. Your sensor does have that capability, I assume? The accelerometer makes no impact there. For simplicity sake at the moment, I suggest leaving the accelerometer empty and just specify which contact sensor device you’ll be using for the door. Once you’ve got that selected, it should automatically pick up the correct device type and create the door device for you.

Makes sense now, I kept just choosing an accelerometer sensor which is how my multi is setup but I get now that it is just treating the status of that sensor as the status of the contact sensor. Made that quick change and works perfectly now, Thanks so much for the code and the fast support.

Best thing about ST is the community.

Great work on this @brbeaird - what is the current state of this community integration? Is it mostly working? I am considering a LiftMaster 8500 Elite Series opener (for a 10 foot door) and wondering if this will work (at least at this moment in time). I would much prefer a device that connected directly with the SmartThings hub and didn’t hit Chamberlain’s servers but maybe that is too much to ask.

I also admit to being somewhat out of the loop, and therefore apologize if these are dumb questions :slight_smile:

This has always been one of my most reliable apps. Jinx alert.

1 Like

@Ben I am a complete newbie. I just bought smartthings (migrated from veralite) and I own a liftmaster 8500. I just finished installing this smartapp and I can confirm that it is working flawlessly. Thank you Brian for developing this!!!

1 Like

Yep, it’s fully working for me! I’m just as invested as everyone else using this, so as long as it’s possible to keep the integration working, I will do so.

If you want a garage door integration that doesn’t hit Chamberlain servers, you should probably buy a different brand altogether. The only way to access the remote door functionality is through their mobile app or by hitting the API with an integration like this one. But that said, as far as cloud-based integrations go, this one has been quite reliable for me.


does anyone know if this will support the new homebridge that was launched? b

I have now downloaded the smartapp yet, but does the device type/smartapp give access to turn on the led light and can be able to turn it off if I had a motion sensor in th garage?

No, this can’t control the light on the door opener itself. For whatever reason, Chamberlain decided not to add remote control to that. I wish they had.

@brbeaird I’m using a LiftMaster and suddenly my devices stopped working. Everything used to work just fine and I changed nothing on my side. Prior to this I could see the status of my door, open & close the door and the status would correctly change. I tried to uninstall and reinstall hoping that it would fix itself and am now seeing some strange things. At first the status stays at “Unknown”. Then if I click on the button to “Open” the button changes to “Opening” and the tile status says “Opening” but never changes. When I click on the close button it changes to “Closing” but the main tile still stays at “Opening” now the main tile is stuck at “Opening” the open button is stuck at “Opening” and the close button is stuck at “Closing”. The device logs show the following:

ava.lang.NullPointerException: Cannot invoke method eventsSince() on null object @ line 510
Door: Left Door Garage Opener: Updating with status - unknown - from sensor null
refresh called from Left Door Garage Opener
Request received to update door status to : unknown
Garage door close command called.

Any idea on what could be causing the sensor issues?

Does the door open and close via the Chamberlain MyQ mobile app? Sometimes you need to reload it on that app and open and close it a time or two, and then it’ll come back online.

The door opens and closes everywhere but in the app the status is broke. It’s like it no longer understands how to know if it’s opened or closed. If I stand I’m in my garage and see that it’s closed and hit the “Opening” button it actually opens, but the status never changes.

Does your contact sensor in SmartThings show the correct value? If you assigned a contact sensor to the door in the SmartApp, it definitely needs to get a reliable status from that sensor or weird things will happen.

I just fear we are at their whim with regards to if they are feeling like they want to integrate or break things that given week.

Thanks, Brian! Got this installed and up and running in just a couple minutes. Works like a charm!

1 Like

Awesome integration… wanted to let you know about a neat trick that worked for me when you can’t get a reliable sensor for open/close. In my case I have an exterior gate with a Liftmaster swing opener. Since the gate swings open a tilt sensor is not a viable option… and as I found out there are not really many(or any) reliable outdoor rated z-wave/zigbee contact sensors. So here is what I did:

  1. Enabled email notifications from MyQ for open/close
  2. Setup Gmail filters that label the open/close emails separately(ex: gate opened, gate closed)
  3. Setup a virtual sensor using the Universal Device Type/Translator([RELEASE] Universal Virtual Device Type and Translator)
    3.1 Set the input of the virtual device as a on/off switch
    3.2 Set the output of the virtual device as open/close (on = open, off = close)
  4. Head over to IFTTT and setup a If This rule based on new Gmail w/ label(ex: gate opened label) and Then That to toggle the virtual switch(again gate opened = switch on)
  5. When setting up MyQ lite just set the sensor as the new virtual sensor and voila… fully working myq lite w/ sensor

Hope this helps someone else…


Any idea what I could be doing wrong? I published both the device handler and app, but nothing appears in the mobile app under “my apps”.

Look in Automation: Smartapps

You may have installed on the wrong shard (server). Have you installed custom apps or handlers before? If so, are those items showing in the IDE where you installed the myQ stuff?

Anyway, here’s details on the shards. It’s easy to log in to the wrong one.

Thank you, that fixed it!