[OBSOLETE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

Just installed and have MyQ Lite working well with 3 doors, a gate operator and 3 garage lites. Great app brbeaird, thank you. One minor issue I thought I would share in case anyone else has same issue. Two of my doors have tilt sensors, 1 door does not and the gate does not. The set-up did not seem to like a mixed configuration of sensor/no sensor. On the first set-up the two units I associated with sensors still showed up as no sensor versions upon completion. When I changed them to sensor version in IDE they did not communicate with the previously associated sensor. After unsuccessful re installs, here is what worked for me. I installed all 4 as sensor versions, adding open/close tiles for those that don’t really have a sensor. I temporarily associated them with another random sensor. After install I changed these 2 back to no-sensor devices in IDE. So far so good.

Yes, there are certain combinations that give the app fits. I’ve had this on my list to fix, but it will probably not happen until I get around to rewriting the entire thing with the new API dev tools (see announcements category for more details related to that).

I HAVE HAD PROBLEMS SINCE LAST YEAR. STILL CANT GET IT WORKING. I removed EVERYTHING and added the device handler and SmartApp back in and not SmartThings doesn’t even see it as an installed app. No trace of it in the SmartThings app.

Really frustrating cause one of the reasonsI replaced my garage door was to get SmartThings to control it. I am an experienced systems engineer and this is still knocking me on my behind with not working.

Does this app need Oauth?


No, it does not need Oauth. If you’re reinstalling via Classic app, keep in mind you’ll need to scroll down into “My Apps” to find it and install it again.

I absolutely know that and it does not sho under my apps.

Sorry you’re having trouble. Another possible route you could try if you haven’t already is installing the community installer ([BETA] Community SmartApp Installer) and then trying to install this SmartApp through there.

1 Like

Is anyone having login error issues? Just yesterday, I started getting a “MyQ command failed due to bad login” errors. I verified my credentials in the smart app settings but it indicates my username or password is incorrect. I’m able to use the regular MyQ app with these same credentials without issue. Overall it’s worked perfectly up until yesterday.

1 Like

Yep, mine is dead at the moment. Been playing with it in Postman to figure out what changed. No luck yet.

Found the issue. Username and password attributes are now case sensitive and begin with capital letters.

I pushed an update to the SmartApp code to fix it. You’ll want to grab that and update yours to get working again.


Thank you for everything you do for the community.


Agreed and NOT AT ALL looking forward to this all being taken away…hopefully it will be coming like all the integrations promised…NEVER. :wink:

1 Like

I just installed and updated via the community installer method. First time using it, new garage door opener. The MyQ app works, but i cannot login via MyQ Lite. I am getting the Username and Password error. I have tried to make sure i am up to date from all of the repos

I’m seeing an HttpResponseException asbelowwhen I try to configure the SmartApp. I appear to have everything updated. Any ideas?

 9:49:04 AM: debug lightVersion: 3.1.1
 9:49:04 AM: debug doorNoSensorVersion: 3.1.0
 9:49:04 AM: debug doorVersion: 3.1.1
 9:49:04 AM: debug latestVersion: 3.1.3
 9:49:04 AM: debug installedVersion: 2.0.3
 9:49:04 AM: debug previousVersion: 2.0.3
 9:49:04 AM: error groovyx.net.http.HttpResponseException: Bad Request @line 840 (apiPostLogin)

Your SmartApp shows 3.1.3?

1 Like

I had forgotten to publish the update for myself. Thanks for that.

It seems to be working better, but one of my doors is very slow to update the virtual contact sensor after a close operation. Opening is instant.

I’m using IFTT-linked virtual contact sensors to update the status. Perhaps it’s just an IFTT delay, as I don’t see it updating from that direction.

If I recall, the old DTH had a configuration option to choose a contact sensor; I don’t see that in the new one, even though it’s still available as a state item on the existing device as attached.

@brbeaird Just want to say thank you again. I didn’t use the community installer but I went into the IDE and updated my existing device handler and smart app code with the new code from the repo, I then uninstalled and reinstalled the smart app on my phone. All is working great now.

It does look like MyQ now offers free 2 year integration with Google Assistant and IFTTT, but they don’t allow you to OPEN the door… That is a shame.

1 Like

Never say never, friend! I do believe an official integration will come eventually.

In a similar fashion, an official MyQ integration with SmartThings could also be limited. For that reason, I have begun the process of writing a replacement version of this that uses the new SmartApp endpoint API. It won’t be quite as simple to setup as this version, but I’ll try to make it as easy to follow as possible.


When you tap through your door setup, you should see the option below it to select an associated door contact sensor.

1 Like

You are awesome! I’m all in for whatever you come up with…easy or not. I really appreciate the time and effort you put in. I wish you could develop EVERYTHING I need in my life! :wink:

1 Like

I’m still not able to login. I installed using st-community installer. I am able to login using the myq app. The smartapp is published and up to date and I can see it in the list but cannot login.

“The username or password you have entered is incorrect. Go back and try again.”

Please help