[OBSOLETE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

Just my feedback. I updated the app and DTH just by doing an GitHub update (not copy and paste) and everything updated correctly. I ran through the smart app to refresh everything that was successful also. I only have a single door but it is working in both classic and the new connect app.

There is a bug in the connect app that holds onto old DTHs even after they are updated. So will most likely have to delete your garage door object and then run through the smart app again to have it recreated. It should work in the connect app after that.

I’m not familiar with that method. I went to “https://github.com/brbeaird/SmartThings_MyQ” and replaced the code from there. When I deleted everything and installed from scratch I used the same link. I did notice this as well in regards to the version:

Keep in mind I had flawless performance with the previous version. I suspect it’s something I’m doing, but, I have no clue what. That’s why I deleted everything and tried to start from scratch but I’m not having much success.

It’s definitely possible I broke something. Let me see if I can dig in a bit deeper and maybe simulate more doors on my end.

I can call on them in a Routine and they will also operate…

I couldn’t delete the SA or DH until I removed the doors

Yep, I made a few typos that broke the setup process for more than 3 doors. I pushed another update that should hopefully fix that now. @wolfewl - let me know if that works for you.

I would also recommend checking out the Community Installer SmartApp. Once you have that running, you can open it, choose MyQ Lite, and just hit a single “update” button to get the latest App/Handler code installed in your environment.

As far as deleting goes, yes, there is a known issue with SmartApps where you cannot automatically delete devices that are used in routines and things like ActionTiles. You have to manually go in and force-delete the doors first, then you can delete the SmartApp.

Thanks, Brian.

Yes, that solved the limitation of doors. I now have five!

I’m still having the issue of not being able to control my doors from My Home tab (where it has all devices listed and shows open/close to the right of each door). If I go into the door itself (from that same screen) I can control it. I can also control it using a routine. I used to be able to control them from the My Home screen… Any ideas? It’s really nice to be able to control them all right there in that view with a quick click.

I didn’t do this as the setup video link seems to be broken and at this point I figured I better just stay with what I know. I will look into it though! Looks really useful.

It appears not being able to operate the door from the My Home tab (flashing to UNKNOWN when tagged and no action taken) is also causing issues with my webCoRE programming. My program that reports if the door changes from “Open” and the contact doesn’t show closed after 30 seconds isn’t function properly. It’s sending alerts when they open now.

With the most recent update, my garage door keeps showing as Unavailable in the Classic app or Disconnected in STSC. I can still operate the door and it changes to normal status but after awhile it goes back to showing as Unavailable.

I woke up to all of the doors being unavailable, I’m not sure where to go from here… I think I’m seeing what you are. I can not operate my doors unless I go into the device. It just flashes UNAVAILABLE and returns to it’s previous state.

Is there a way I can go back to the 4 door version and make sure it’s not me? It was flawless.

That’s really odd. Seems to be working fine on mine. I went ahead and reverted some of the changes to the device handler (I don’t think the door limit changes would have impacted this piece).

Can you try updating to the latest door device handler version and see if that helps?

1 Like

Just to insure I’m using what you think I am… I’m downloading from the following link:

This is where I’m supposed to be, correct?

Yes, that should do it.

That fixed my issues of not being able to control the doors from the My Home screen. It also fixed the issue with my webCoRE piston. Now I can tap them and they as they should. Thank you!

1 Like

I have had the new device handler installed for 1.5 hours now and it hasn’t gone unavailable. Thanks! :slight_smile:

1 Like

:frowning_face: I’m not sure what to do…? I’ve run the Z-Wave Repair Utility 3 times in hopes of solving this, but it doesn’t appear to help. This morning when they were unavailable I went to each device and operated it and it resolved the issue. That’a not the case now.

Do you have Device Health turned on? If so, could you try turning that off? I have no idea what “Unavailable” really means in the classic app anyway.

What does it look like if you click on one of those Unavailable doors?

  • Yes, I have device health turned on. I’ll turn it off

  • When I click on it, it appears as usual but has a grey bar across the top that says it’s unavailable. It still seems to operate.

I went in to take a screen shot for you and now they are all “available”? I don’t know enough about ST to give you much to go on… All I know is everything was great after the new DH this morning. There was a funky instance that appeared to be widespread in the community where I couldn’t view my devices for about 30 minutes. Everything appeared fine after that, then when I opened ST I was greeted with “unavailable” again for two doors. Now, (one hour later) all is good again…

My GD is unavailable again. :frowning:

Just feedback: Woke up this morning and I still have all of my doors. Device health has been off since last night at Brian’s recommendation.

1 Like