[OBSOLETE] LutronPro Caseta v1.0

You’re talking about the Lutron Caseta app on your phone (or tablet), right? Any chance your app has the wrong notion of the the SmartBridge’s local IP address? (E.g. if at some point the bridge obtained a new IP address from your router’s DHCP server but the app didn’t update itself accordingly, or contrawise, if you had set it to a static IP address at some point.) Since you do know the working bridge’s local IP address, you might check that against the app’s Advanced/Integration/Network Settings. If different, you could just set it manually in the app to match, or reset the bridge to DHCP IP acquisition by pressing the bridge’s little black button for 20 seconds.

Aside from local IP issues, any chance you’ve changed firewall settings or anything of that sort that would prevent the bridge from reaching outside the local network to Lutron?

I coincidentally am working on my Lutron system this evening and just added a new dimmer and it’s working ok for me. Both the Lutron app and SmartThings app.

@BHO Yes, the caseta app (Android).

I don’t think it got a different IP - I gave it a static entry in the router, but either way, I can’t actually get that far in the app, it never actually connects. It tries, then times out and I get to retry or ‘help’. If I log out, my options are limited to the getting started guide, the sign in button and the ‘contractor mode’ button.

Having just mentioned the contractor mode, I had a ‘screw it’ moment and clicked through with my “installer info” (i’m not an installer…) which then found my bridge… but I’m hesitant to proceed as I have this sinking suspicion its going to nuke the setup… (there’s a disturbing lack of “are you sure” prompts…)

At one point in time I had the regular smart bridge and then moved everything to the pro (at the time I was willing to nuke the setup), but I’ll be damned if I can’t get a notion of what on earth happened… I did switch from an older TPLink VPN router to an Edgerouter 4 recently, but as soon as I noticed this, I tried going back to the TPLink and still no dice, so I’d say its 50/50 as to whether or not its a network thing - though, I suppose switching borked something and by the time I switched back, whatever was/is borked couldn’t be un-borked…

@AdamHLG - I’m figuring its something with my setup. When the Lutron guy was still replying to my email, he said they could see the mac address that I’d sent them on their servers… The Fing app they have you use to diagnose things reported that the Lutron hub was made by Phillips (which I’ve no doubt was a total fluke), but when I mentioned this, the guy seemed… offended lol - and now they don’t seem to want to talk to me anymore (I have this picture in my head of some guy poking his nose up in the air at the mere suggestion…)


Ha… I guess I’m a contractor now… that seems to have fixed it - or let me in anyway… all I really needed was to pair a dang dimmer!

Hopefully thats the end of it - appreciate the input, if it comes up again, I’ll be sure to bug you guys again :wink:

On a side note. is it possible to use the LutronPro smart app to allow a pico remote to control my Chromecast Audio groups (Volume up/down, next/previous track etc). I would love to be able to use my spare remotes for whole home audio controls…

It looks like you MIGHT be able to cobble something together with the use of this project to provide the Chromecast Audio interface: [RELEASE] cast-web 1.0.0 - Chromecast Device Handler & SmartApps . Possibly with Webcore in the middle… it would depend on whether that Chromecast handler can “see” and use the virtual SmartThings buttons that are created for the Pico buttons. I would guess that it might be kind of sluggish for continuous-press functions like volume changes.

One note of caution: that Chromecast handler has an architecture similar to that of LutronPro v1 (and LutronPi v2): a SmartApp and its device handlers talking to a node.js program out on a LAN device (like a Raspberry Pi or other computer). As noted above, SmartThings only seems to allow one internal device per LAN device port, so you’d have to host the Chromecast handler’s node.js program on a LAN device other than the one hosting the LutronPro/LutronPi node.js program.

Would be nice if you could get replacement covers for the remotes with appropriate labeling etc. I mean, I’ve got a label maker, but its just not quite the same :wink: Where’s my sharpie…

You can actually buy Picos that are already marked with audio control icons, but they’re kind of rare and expensive


The day has come. I need to go beyond the 50 switch device limit. And you are the man to take me to the promised land!

I ordered another RPI , 4 Picos, and 5 switches, and another Lutron Bridge Pro (it say pro2 now - hope that is ok or same thing). It is my intent to build this RPI, get your code, and try and get my 2 lutron bridges operational with your code and the new RPI. Or at the very least run Nate’s old code on the first RPI as it is now, and add the new RPI with your code and the new Lutron bridge.

It will take about a week or so to get the stuff. I will let you know how it goes. If all goes well, my goal is to decommission the first RPI and have the new RPI with your code find both bridges and have a single list of devices in SmartThings. I don’t care if I lose the old scenes and triggers etc. This is an investment in the future. Thanks for your hard work I guess I will help pave the way here for others that want to jump on board.


The promised land! I hope so; I’ll try not to whack any rocks more than once.

I have some confidence that it’ll work for you; I’ve been running with a dual Pro + non-Pro setup for quite a while, though admittedly with my many fewer devices. Both bridges are run through a single Raspberry Pi Zero with the LutronPi node server it also works with a Windows 10 server here).

But yes, you’ll be the multi-bridge pioneer out in the wild, so far as I know, so please keep us posted here. I will certainly try to diagnose and resolve any problems you encounter, if I possible can do so.

If you run into any problems with the LutronPi node server (on your RPi) automatically discovering the Lutron bridges on your particular network, as some folks have, let me know, but also look at the static addressing options mentioned in the Readme.

1 Like

p.s. I don’t know what differences, if any, the Pro2 Lutron bridge has - I haven’t tried it myself nor heard anything – so all I can do for now is cross my fingers that Lutron hasn’t made any killer changes to the authentication scheme (like they did last year). Or anything else, for that matter.

If the pro2 has an issue I’ll return it and get the original pro. Unless it’s a simple thing to diagnose. I’m a lawyer not a programmer. It’s amazing I got this far to understand and setup an RPI for Nate’s program and got it to work! I assume this will pretty much be the same thing. I really appreciate your willingness to help!

Lutron only sells the Pro2 hub now. It includes support for Apple HomeKit. Users who are buy the original “Pro” model, new in the box, are finding that it will not register with Lutron’s servers. If you contact Lutron, they will arrange a swap for a Pro2 bridge. This has something to do with the fact that Lutron updated all of the firmware on the original Pro bridges, and new Pro bridges can no longer be registered.

Sounds similar to when Wink had a certificate expire in their Gen1 Hubs, and if yours did not get the update before the cert expired, you ended up with a brick. Wink allowed me to ship my old hub to them, and they actually manually flashed the board and shipped it back. I only use it to update firmware on an few devices.

1 Like

Well then our path is set! Let’s do this! Amazon says my switches and RPI will be here Tuesday but it will be a week till the bridge is delivered. Anxious to get started now that I pulled the trigger.

Aha, it seems that all my work was done with a Pro2 anyway, so: a non-issue. Dan’s note explains it: the Pro not-2 bridge was the one before they added HomeKit/Siri capability, which was ages ago.

1 Like

For those watching the play by play, I received the new RPI kit and all the new Caseta devices… this would be devices 48, 49, the magic 50, and the new taboo beyond-the-bridge limit 51- 57 switches and Picos.

My second bridge Pro is slated to arrive Tuesday. I will in the meantime build the RPI this weekend and get it up on the network.

I believe that when this second Lutron bridge arrives, I’ll need to set that up with a different Lutron account. I seem to remember that the SmartThings hub can only connect to one Lutron hub due to API limitations. I don’t want to screw anything up. I have a second Gmail alternative email address so I am going to keep this new bridge completely separate in all respects, including it’s own dedicated existing RPI, and then let the SmartApp do its thing and integrate everything that way.

Anyway more to come. Wish me luck on the RPI part. Remember if I can do this, any of you newbies can do it. I can barely visualize this roadmap let alone implement it. I think I got this.


Adam, you are correct; the additional Lutron bridge will have to be connected to a separate Lutron account. Rather than using an entirely separate email account, you MIGHT get away with just dropping a dot . into the middle of your regular Gmail account name (eg adam.hlg@gmail.com vs adamhlg@gmail.com). Gmail will consider those the same address, but Lutron will probably see them as unique. Might be a bit simplifying, if it works.

For my test bed here, I set the second bridge through an app on an old android tablet I had kicking around; that saved switching my phone app back-and-forth between Lutron accounts.

The LutronPi node server will walk you through setting the user id/password for each of the Lutron bridges the first time you start it up ( if the bridges are discovered on your network, as they should be). It keeps track of which is which by their respective serial numbers, which are printed on the back of each bridge.

1 Like

Update:. This has been unbelievably easy! I built the RPI, installed the node server app, installed the second bridge pro, installed the SmartApp and device handlers, ran the node server, entered the credentials for both Lutron bridges, started the SmartApp, it found the RPI, and found a bunch of switches and Picos!!!

I cannot believe it works! I mean I believe it, I just can’t believe it worked for me!

I then stopped in my tracks because I have some cleanup to do. I need to decide which switches and Picos I should move/place on each Lutron bridge before I go any further.

Question:. I assume at this point that my original RPI with the prior version 1 node server can be decommissioned. I also assume I can remove the associated SmartApp and device handlers for the version 1 SmartApp from SmartThings. I base this assumption on the fact that the new RPI with the version 2 node server and associated smart app and device handlers will handle everything now. Just making sure.

Also, would it be the best practice at this point to remove the official Caseta SmartThings integration entirely and use this new version 2 node server and RPI to handle all things Caseta in my SmartThings environment? This would certainly simplify everything however am I losing anything by doing this?

I will post a follow-up when the clean up portion of the project is finished. So excited.

Hey @AdamHLG that’s extremely welcome news - congrats. To answer your questions:

I’m pretty sure the LutronPi (v2) setup completely duplicates all functionality of the LutronPro (v1) setup, so yes: that original RPi and its v1 node server can be decommissioned, along with its associated SmartApp and device handlers.

Of course the new LutronPi SmartApp will create new SmartThings devices (via its own handlers) for all the Lutron devices that its sees on your original bridge. So if you have any of the original devices ‘plugged into’ SmartThings automations, that will have to be re-done in SmartThings. (That’s the pain-in-the-neck part of all this.)

As for the official Caseta integration: I can’t tell you for sure as I’ve never tried it (oddly enough). But if it all it’s doing is providing a lot of duplicated lighting devices, then it can probably be dispensed with. OTH if you find that the official integration is providing something that the LutronPi setup does not: let me know what that is; I’d be very interested! For one thing, it may very likely have more extensive shade control; that wouldn’t surprise me.

Aside from the Pico functionality, you’ll find that the LutronPi (v2) version of the Lutron lighting also provides ramped on and off timing, if you want to use that. (For Pro bridges only)

If you nose around in the Pico device settings (the ‘gear’ icon in the upper right), you’ll find some options like: selecting a ‘favorite’ button that will then appear on the main SmartThings Home screen; whether a button ‘hold’ times out after 6 seconds; whether each button is the standard Push/Hold or instead Push/Repeat or as a Press/Release (like a SmartThings contact). Also, even in the Push modes, the Pico buttons simultaneously act as SmartThings buttons AND contacts, which might be useful for ‘do this while pressed’ automations.

A Pico also has an option to loop its in-app virtual button presses through/to the Lutron bridge and back to SmartThings (so the Lutron bridge thinks the real Pico button was pressed), or to drive SmartThings automations directly (rather than waiting for the Lutron bridge to respond.) That latter mode allows non-Pro bridge Picos to work from virtual app buttons and still also drive SmartThings automations from those app buttons (just not from the real Pico buttons).

Also, if you hadn’t noticed it, in the LutronPi SmartApp setup is an option to turn on notifications. If enabled, this will provide SmartThings notifications when the LutronPi node server goes offline or online and when device complement changes on any of the bridges (e.g. when you add a Lutron device from the Lutron app).

Keep us posted on your progress, if you don’t mind!

1 Like

Of course I don’t mind! I am resetting everything anyway. The contractors are here in the house installing the last of the Casetas today. Once they leave, I will get to work cleaning up the placement of devices on the respective bridges and deleting the old apps etc. I will post a thorough follow up.