[OBSOLETE] Lutron Connected Bulb Remote

Thanks so much. It’s very nice to know that there’s a helpful community here eagerly ready to help!

Quick question: is there a thread or post with any directions on how to pair the Lutron remote to ST? I’ve Googled around and found some discussions on this but no actual solutions.

Apologies if I missed it.

Many thanks again,

Factory reset the remote by holding the on and off button down for about 15 seconds. The LED on the remote should turn off when it’s been reset. Don’t do this too close to any bulbs because it might reset them. Press a button to verify that the remote is no longer paired to your bulbs.

To pair with ST. Install the Alpha devicetype in this thread first (search the forum for “FAQ custom code” for info on how to install it). Move close to the hub and start the Connect New Device in the mobile app, then press and hold the top button (like you are pairing the hub as a bulb). The remote should be recognized as a new device.

1 Like

Yeah I got as far as resetting all the stolen bulbs and the remote and re-pairing the bulbs to ST, and even pairing the Lutron remote to the ST hub by holding it nearby with the power button held, as you suggested. ST found it as a ‘thing’, but of course I didn’t have the Alpha device type installed so when I repaired the remote to a bulb, it stole it again.

I’ll give the custom code FAQ a read and try and get the device type installed. Thanks!

One more question: after installing the Alpha device type, I’m assuming ST will now see the Lutron remote as something more than just a ‘thing’. But how will that itself stop the Lutron from stealing bulbs when I then pair the remote to the bulb? In other words, how does ST’s understanding of what the Lutron remote is help here, when the Lutron remote just steals the bulb?

Is it because after ST understands what the Lutron remote is, it’s OK for the Lutron remote to steal the bulb, because ST will ‘listen’ to its command and therefore not fall out of sync with the bulb(s) the Lutron remote operates?

Also, I need to clarify something regarding Hue Taps vs Lutron connected remote. They interact very differently with ST. While the Hue Tap, like the Lutron remote, does cause ST to fall out of sync with bulbs, at least it doesn’t ‘steal’ the bulb. And ST can continue to send commands to Hue bulbs after they’ve been operated by Hue Tap. In other words, if Hue Tap turns my Hue bulbs off, sure ST doesn’t register them as off and still registers them as ‘on’, but this isn’t a big deal: in ST for that Hue bulb I just hit ‘off’ (which does nothing) and then hit ‘on’ and then ST turns them back on. So at least ST can continue working with the bulbs, which isn’t the case when I operate the bulbs with the Lutron remote.

In other words, Hue Tap is friendly with ST, while the Lutron remote isn’t. Of course, although I can hit ‘off’ and then ‘on’ to turn the Hue bulb(s) on again after the Hue tap turns them off, I don’t know if ST actions/apps would continue to work – in other words, if the last known Hue bulb state to ST was ‘on’, but then I turned that bulb off using Hue Tap, but then ST got a motion trigger to turn the Hue bulb on, would it? Since it still thinks the bulb is ‘on’, can it still send an ‘on’ command? In other words, does it not really matter that ST falls out of sync, as long as it sends the necessary commands? I don’t know, will have to try, but let me know if you know.

But does anyone know why the Hue Tap can be far more ‘friendly’ with ST than the Lutron remote? Is it because the Hue Tap isn’t binding directly to the bulb, but instead sending commands to the Hue bridge? Even then, ST does fall out of sync despite being connected to the Hue bridge - which is odd. When Hue Tap sends an off command for a Hue bulb to the Hue bridge, since the Hue bridge is connected to ST, shouldn’t ST understand that the Hue Tap told the Hue bridge to turn that bulb off?

I feel that the Lutron remote should almost come with a warning that says that it can really make things difficult by stealing bulbs - it stole my Hue bulb from the Hue Bridge/ST/Echo and I don’t even know how to get this particular Hue bulb ‘back’. I even tried TouchLink to no avail. So now I have a dead Hue bulb… which I guess I’ll have to try resetting using a Hue Dimmer remote, but I digress.

Many thanks again,

Having the devicetype installed or not shouldn’t have mattered. Once the Lutron is paired to ST, it should keep the bulbs on the ST network and have “joint” control of them. Are you sure they were “stolen” off the ST network and not just out of sync? Try changing the level of a bulb with the slider in the mobile app. One other quirk of the Lutron remote is the “off” button appears to send a level 0 command to the bulb, so if you subsequently turn it “on”, it won’t produce any light because it’s still level 0. The “on” button on the Lutron will go to 100%, so that works fine, and you can just send a level command from ST too.

It definitely still steals the bulb, despite being paired to ST. I tried all the things you suggested - the ST just totally loses control over the bulb when I pair the Lutron remote to it. No state changes are updates, no control, nothing.

I haven’t had a chance to try to load the device type yet though. Will try to get to it this weekend. How does the Lutron remote pairing to ST allow it to not ‘steal’ the bulb? Does that put it in some different mode? I’m a little confused as to how simply pairing to ST would help, unless the pairing allowed the Lutron remote to tell ST to control the bulb, as opposed to controlling it itself. Or does it simply ‘know’ not to steal a bulb once it’s also paired to a hub?

Has anyone successfully actually gotten this to work? Would like to know if there really is any hope here, otherwise I’ll just go the route of the Leviton ELV dimmer with dumb bulbs. Although I may do that for the majority of the home anyway because I like the Philips WarmGlow dual LED bulbs that get warmer as you dim (they emulate the behavior of halogens quite well). I do prefer the clear glass dome of the GE Links though - they give the entire room a sparkle. But the light looks so sterile upon dimming… I wish Philips would make WarmGlows with clear domes, or GE Links make their bulbs with dual LEDs to warm as they dim. But I digress.

Thanks again!

1 Like

I have this working. Both ST and the remote control the bulb.

The remote creates its own zigbee network and “steals” the bulbs on to this newly created network; however, once you pair it to ST it becomes a secondary controller. It’s already part of a network, so it doesn’t need to create one. Pairing it to a bulb after it’s a secondary controller doesn’t change the network either one is on.

When you paired it to ST, did it show up as a ‘Thing’? Then you pressed and held the top “on” button near the GE Link until the bulb blinked several times and stopped? After that, the bulb should work with both ST and the remote. State changes made by the remote will only update in ST if the attribute reporting for the GE Link is working properly. It is for my bulbs as well as others in this thread.

Did you factory reset your remote first?

Hi guys,

Yes, I followed exactly what you did. I did reset the remote first as well (by holding the on/off buttons simultaneously for ~20 seconds). Just not working; it steals bulbs every time.

I’ll try installing the device type first this time. Do I need to update my GE Link bulb types or something there as well? I haven’t done anything with respect to the bulbs themselves…


Also, should I be using the alpha device handler posted in the first post of this thread (by workmonk), or the one you posted, Scott? I must admit, the instructions you posted along with the alpha device handler in your post (post #27) means nothing to me, sadly - I kind of feel like an idiot/total n00b :slightly_smiling:

Thanks again!

Quick question… so with the alpha device type, the remote will play nice with smartthings, per the comments.
Does that mean that I can use the remote to trigger things within ST, like run a routine?
Or will it only work with zigbee bulbs, through smartthings?

Thanks in advance!

Nope. Only controls the bulbs.

I am finally getting around to trying this with 2 types of bulbs - the Lightify BR30 and the older Sylvania Ultra IQ BR30. The issue is, I don’t know what any of the code means, specifically, I don’t know how to identify which value is the ‘endpoint’. I thought that as I filled in data on your smart app, on the mobile app, I would see data scroll by which would help identify the endpoint, but nothing happened. I stared at forums and guides and all sorts of documentation which I do not begin to understand. How do I identify the endpoint of any of these bulbs I wish to link to the Lutron Connected Bulb remote? Then after that, is the last four digits in your trace catchall phrase the GroupId?

You should be able to find the endpoint by looking at the device details for the bulb(s). In the IDE on the My Devices tab, click on one of your bulbs and it should list the endpoint for you. Both of those are probably endpoint 03 like my Lightify bulb. Manufacturers appear to stick to one endpoint number.

To make this work you have to pair the Lutron to one of your GE Links the normal way, so you can read the groupId from it. You should be able to unpair the GE Link after.

Then, yes the groupId is the last 4 digits in that trace catchall. For your bulb the last part will probably be 8 digits long starting with 0701 followed by the groupId.

Thank you for your response. I did find the endpoint after a bit of poking around but I was not aware of how to find the GroupId without your response. I followed your instructions but the remote is not working on the GE Link bulb (v2 device type). It showed the GroupId and even laid it out in a stand-alone line of log. There were two catchalls in quick succession for what look to me like the same device. Neither start with 0701, and the last 4 were both 0800 which is what i used in the lutron smart app. It also now shows 0800 Group ID under the Lutron Device in IDE. But no worky with the buld. Any thoughts here?

Here are my logs from starting live logging until something irrelevant came up (my dog getting home):

b4bf8527-d7c9-4934-ba78-e310aa059f0f 9:47:03 PM: debug Parse returned Bosco! has arrived
cb43a53d-1c4f-4516-84ef-6aa3c9db3ebb 9:47:00 PM: trace modeOk = false
cb43a53d-1c4f-4516-84ef-6aa3c9db3ebb 9:47:00 PM: debug Contact has stayed open long enough since last check (180230 ms): calling sendTimedMessage(open)
b7751ed4-a17d-49d4-944b-dac1a512e785 9:46:26 PM: trace NON-HUE EVENT desc: 01 C05E 0820 02 04 0000 1000 FF00 FC44 08 1000 0003 0006 0008 0004 0005 0000 FF00
b7751ed4-a17d-49d4-944b-dac1a512e785 9:46:26 PM: trace Location: desc: 01 C05E 0820 02 04 0000 1000 FF00 FC44 08 1000 0003 0006 0008 0004 0005 0000 FF00
b7751ed4-a17d-49d4-944b-dac1a512e785 9:46:25 PM: trace NON-HUE EVENT ep_cnt:1, ep:01
b7751ed4-a17d-49d4-944b-dac1a512e785 9:46:25 PM: trace Location: ep_cnt:1, ep:01
b7751ed4-a17d-49d4-944b-dac1a512e785 9:46:25 PM: trace NON-HUE EVENT desc: 01 C05E 0820 02 04 0000 1000 FF00 FC44 08 1000 0003 0006 0008 0004 0005 0000 FF00
b7751ed4-a17d-49d4-944b-dac1a512e785 9:46:25 PM: trace Location: desc: 01 C05E 0820 02 04 0000 1000 FF00 FC44 08 1000 0003 0006 0008 0004 0005 0000 FF00
b7751ed4-a17d-49d4-944b-dac1a512e785 9:46:25 PM: trace NON-HUE EVENT ep_cnt:1, ep:01
b7751ed4-a17d-49d4-944b-dac1a512e785 9:46:25 PM: trace Location: ep_cnt:1, ep:01
b7751ed4-a17d-49d4-944b-dac1a512e785 9:46:23 PM: trace NON-HUE EVENT join
b7751ed4-a17d-49d4-944b-dac1a512e785 9:46:23 PM: trace Location: join
b7751ed4-a17d-49d4-944b-dac1a512e785 9:46:22 PM: trace NON-HUE EVENT join
b7751ed4-a17d-49d4-944b-dac1a512e785 9:46:22 PM: trace Location: join
a15d3596-5ffd-42f2-85b6-86ee5d96d9df 9:45:56 PM: info [type:switch, name:switch, value:off]
a15d3596-5ffd-42f2-85b6-86ee5d96d9df 9:45:56 PM: debug description is on/off: 0
91b49b7f-04e1-46b4-b852-c0476241a1a2 9:45:55 PM: info [type:switch, name:switch, value:off]
91b49b7f-04e1-46b4-b852-c0476241a1a2 9:45:55 PM: debug description is on/off: 0
06dac2ad-ffba-4f2e-98b5-8c096ac38b41 9:45:54 PM: info [type:switch, name:switch, value:off]
06dac2ad-ffba-4f2e-98b5-8c096ac38b41 9:45:54 PM: debug description is on/off: 0
e93f5fbb-ad11-4dbd-a42f-44f9fec69d2d 9:45:54 PM: trace catchall: 0104 0004 01 01 0000 00 4239 01 00 0000 00 01 000800
e93f5fbb-ad11-4dbd-a42f-44f9fec69d2d 9:45:53 PM: trace catchall: 0104 0004 01 01 0000 00 4239 01 00 0000 03 01 8B0800
2d6b0f21-3882-454d-9602-295fc64ba0a7 9:45:53 PM: debug Group Id for this remote is: 0800
2fb88ea7-7b45-4b29-806f-0b6b240e9b0d 9:45:41 PM: debug Parse returned [name:battery, value:77, descriptionText:Back Door battery was 77%]
2fb88ea7-7b45-4b29-806f-0b6b240e9b0d 9:45:41 PM: debug Battery
2fb88ea7-7b45-4b29-806f-0b6b240e9b0d 9:45:41 PM: debug Desc Map: [raw:7BCE010001082000201C, dni:7BCE, endpoint:01, cluster:0001, size:08, attrId:0020, encoding:20, value:1c]
2fb88ea7-7b45-4b29-806f-0b6b240e9b0d 9:45:41 PM: debug description: read attr - raw: 7BCE010001082000201C, dni: 7BCE, endpoint: 01, cluster: 0001, size: 08, attrId: 0020, encoding: 20, value: 1c
cba3fed8-3720-400b-819f-7d461fe4d80f 9:45:32 PM: debug off()
cba3fed8-3720-400b-819f-7d461fe4d80f 9:45:32 PM: trace stopAction()
035a6a1e-94cd-4381-8ceb-44b400c9fd74 9:45:32 PM: trace Bulb is Off
e93f5fbb-ad11-4dbd-a42f-44f9fec69d2d 9:45:06 PM: trace catchall: 0104 0004 01 01 0000 00 4239 01 00 0000 02 01 0800
ed1bdcf4-cfba-4fc7-9d1e-0703c75f3eec 9:45:06 PM: debug Parse returned [[value:44, unit:F, name:temperature, isStateChange:true, displayed:true, linkText:Breezeway Motion Sensor, descriptionText:Breezeway Motion Sensor temperature is 44°F]]
9:44:52 PM: info Waiting on events…
9:44:52 PM: info For past logs for individual things go to the My Devices section, find the device and click on the Events link on the device information page.
9:44:52 PM: info This console provides live logging of your SmartThings.

So I went and joined the GE Link bulb directly with the remote (top button for 15 sec) and it controls it just fine. it also updates the state in ST. Great. BUT, I want to use it with the Sylvania and Osram BR30s, not the one lone GE Link I have.

I went and connected my sylvania bulb back to the hub, tried to add it to the remote. It does not and never has been willing to join the remote via the button 1 pairing (from what i have read it’s the same ZLL/TouchLink/firmware issue as Osrams). So I tried to add it via the Lutron remote smart app. No results.

I appreciate any help you can give. Seems like this is totally possible, I just don’t know how to do it.

Your groupId still isn’t correct. It looks like you tried to get the groupId from the GE Link before you paired it to the Lutron. 0800 is actually saying 08=8 group slots open and 00=0 filled. That’s why you should see 07019999 where 9999 is the real groupId.

Now that you have the GE Link paired, try the top half of the SmartApp and live logging step again using that GE Link there. (Tip: when live logging as a device populates to the log they show up along the top. Clicking on them limits the logs to that device. Might help isolate what you’re looking for.)

Once you get the groupId, input it and select your Osram bulbs in the bottom half along with the endpoint for them. (BTW: the Osrams can’t pair direct because they are ZHA, not ZLL)

So I finally got my Lutron bulb remotes playing nice with GE Link with Smartthings - all it required was a proper order of operations. First load new alpha device type, publish, (all in a web browser app) then factory reset your remote, then pair again with ST as you tell ST to find something new. It should find Lutron Connected Bulb if you’d done your homework on the webside (PC access of the website to get device code in there and published, as per the FAQ). Oh and I used the old code from workmonk at the beginning of this thread, so I didn’t do any of the stuff Scott mentions (should I?)

In the end, once I got the Lutron remote on SmartThings, and as long as I first paired a GE Link bulb to ST, I could the pair my Lutron Remote to the bulb, and it wouldn’t steal it. States are updated to the ST hub/app. I suppose previously when I didn’t have the devicetype installed for the remote, something went wrong and the remote would still continue to steal the bulbs. But not anymore. Now they both access the bulbs. Exactly what I wanted! Bulbs can still be very ‘smart’, working with smart apps, but when you need just quick, physical hard access, you go for the Lutrons, and that doesn’t just break everything.

I was very excited about this, as it may have solved one of our major issues overall. But sadly I now am not able to pair the Lutron remote with Hue bulbs (just the generic dimmable soft white kind). These bulbs are on my Hue Bridge, which are then all connected to ST. That all works, but my Lutron remote (that’s paired to the ST), just won’t ‘bind’ to the Hue bulbs.

Any ideas why? Would this require a Lutron remote first paired to the Philips hub instead - if so, is that easy? If I remember correctly, before I paired my Lutron remote to the ST hub, it could easily control a Hue Lux. Will have to try that again with a new remote.

So many questions now! Hoping someone can help.

Also, I’m not sure what all the other code/discussion is about - things are at least working for me with GE Link bulbs… what is it those topics of finding GroupIDs, etc., are related to? Seems to me right now I’m almost just set. What else should I be thinking about?

Many thanks in advance!

So I am just now seeing this post. Currently my Lutron remote is just installed as a THING. Would installing and using this device handler help with any potential issues I am might be facing?

Don’t worry about any of the other stuff if it’s working for you and your GE Links. The other topics about GroupId and such are for trying to get it to work with bulbs that can’t complete the pair process because they use a difference zigbee profile.

Yes, it would have to be paired to the Philips hub, but it can’t be paired to both Hue and ST at the same time. Even though the Philips hub is connected to ST, they each have their own zigbee network. They connect to each over hub-to-hub with ST sending commands to the Hue bridge, which then sends zigbee commands out to Hue bulbs. The Lutron can’t be on two zigbee networks at once, so you can’t have mixed control like that. I wouldn’t pair the Lutron to the Hue bridge. Look at the Hue Dimmer Switch if you want a similar device specifically designed for Hue. Again, you will not have cross-hub control though. Your best bet to control all your bulbs is to move them all to one hub. You should be able to pair GE Links to Hue and have them all there.

I believe Lutron makes several mounting options, but I don’t know how well they work in multi-switch gangboxes.

Another option may be the Osram Dimming Switch. It’s designed to fit over a traditional toggle switch, essentially locking the switch in the on position.

A community user has it working with ST, although it still has a couple bugs to work out.

1 Like

It really shouldn’t. The only thing the devicetype does is recognize and label it as the Lutron Remote. It also has debug logging for any messages from the remote to the ST hub, but the remote doesn’t send any that the hub can see.