[OBSOLETE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

Not just you, or just the old firmware, got this on both my keypads (one at 80% now and the other at 60%) for about a day, probably got 10-15 warnings in total.

I think this was probably an error on the ST side, and not actually related to the keypads themselves.

I am considering​ to order an iris smart hub on eBay some are listed for $20 or so may be worth it but not sure whether it is the gen 2 that I should after

Do the centralite have the same firmware issues as the iris keypads? I just got off them in the mail today

@nychan : Definitely need the gen2 Iris hub to firmware update these, the gen1 can’t talk to them. ~$20 is what I paid for mine (Just for this reason. Batteries every 3 months was going to cost more than $20 pretty quick).

@Themlruts : I haven’t heard anyone mention the Centralite (Xfinity) keypads having battery issues or LED sticking, but I also think there are fewer people using those (The Iris keypads are a bit easier to get, I think)


Thanks for the info just wonder what does the panic button do? I can see it is logged in the device handler but seems it doesn’t do anything or there is some way I can configure it to point is to my alarm?

Just found the panic button only works when it is in armed mode this little device is great

I got one of my keypads paired. I can use codes to arm and disarm. Does the smart alarm app still work? I know the user lock app as delay on exit. But not on entry.
I know the smart alarm app has this feature.

@tyler can I know if there is any plan for official support from smartthings this is the great missing piece for home security with smartthings and we cannot update the firmware OTA as it is not an official works with smartthings product? But many iris products are certified

@nychan : The panic button should work while armed or disarmed, if I remember right.

The panic button triggers a “button pressed” response (I think it’s button 1). I believe it also triggers a “contact open” event (followed by a contact closed event), so it can be easily included in situations where an alarm app doesn’t respond to buttons.


Smart Alarm does still work, but you’ll want the versions listed at the top of this thread, instead of the “official” version, which does not include support for the keypad messages.


Thanks Zack I think I figured it out after reading the 5xx posts second time

For some reason when I disarm it still shows armed stay on the keypad but it’s disamrmed in smh

I figured that out. Disregaurd. I do have another issue. SmartAlarm doesnt seem to be updating. Example
if I run a routine say night. It changes the mode to night and arms stay.
I then type in my code and it seems to disarm in SMH but not in SmartAlarm it still thinks it Arm/Stay
Not sure why its not updating.

Make sure you have the Good Morning, Good Night, etc routines set in User Lock Manager under Keypad Settings -> Routines, otherwise it just sets the SHM state, but not the location “mode” (which is what SA watches)

To be clear, you can trigger routines with the keypad. And obviously change SHM states. But I’d there a way it can just trigger a routine, or does it have to change the SHM armed/disarmed state?

I want to use this to trigger a routine which “turns off a switch”. It will be outside (rain proof box) which is used to interrupt power to a magnetic door lock on my patio door. This way I have an adequate way to open it from the outside. But I do not want it to interact with SHM which mirrors my monitored alarm state for informational purposes.

There’s not a simple way in the UI to disable the SHM interaction, but if you comment out line 1396 of User Lock Manager ( Change “sendLocationEvent(event)” to “//sendLocationEvent(event)”), it should prevent any interaction with SHM, and just run the routines.


1 Like

I must say this is a great smart app. I paired up one keypad. Working great. I paired up another works great except now I’m not getting beep on door open. When I had only one paired it beep twice. I swear I thought I saw a setting to change the number of beep. I was look at making just 1. Not sure why they stopped. I have two more keypad to add. Bedroom and basement.
Let me know your thoughts. Do you have a place to donate to you?


I’m working on a smart app that is focused on the CentraLite keypads… using the dth you provided above, does the panic button work for you?

Never mind, I got it working in the app.

Hi everyone. I have scoured this thread, and unfortunately I still cannot get this iris keypad to pair. I installed the DTH and the smartapps in the IDE. Nothing is showing up for devices. I’m getting two short blinks so the keypad is in pairing mode but the smartthings app lists it only as “Thing” and then when I connect to it, it says “tiles missing” in which case I cant do anything.

I appreciate all of your help, I’m pretty new at this as you can tell so I probably made a dumb mistake somewhere.

Edit: Here is what I see for the devices “fingerprints” not sure how to edit this though

endpointId:‘01’ profileId:‘0104’ deviceId:‘0401’ in:‘0000,0001,0003,0020,0402,0500,0501,0B05,FC04’ out:‘0019,0501’ manufacturer:‘CentraLite’ model:'3405-L’
endpointId:‘01’ profileId:‘0104’ deviceId:‘0401’ in:‘0000,0001,0003,0020,0402,0500,0B05’ out:‘0019,0501’ manufacturer:‘CentraLite’ model:‘3400’

@alexwlada You can go to the device in the ide and change it to the keypad handler. It will be near or at the bottom of the list.
If you cant find it in there then you might have not added it in the right ide. I know I kept doing that myself for a while and idk if they fixed the problem yet. Was making me pull out my hair. A quick way to double check is when your in the ide click on the three bars on the top right for the drop down menu then click on location. You should then have the choose to choose your hub. Once you choose it then click on the three bars again and then select device handlers and see if the dth is still there. If it isn’t then that was it. You can re add the dth and it should add the keypad no problem.

Ok so now I’ve got it paired with my STH but the keypad itself is still blinking. Tried pressing that switch, left it alone for an hour - still nothing.

Alright after some more reading of this thread and tweaking - I got it to work! Thank you guys so much this is perfect for when my friends come over so they don’t set off my full alarm.

1 Like