[OBSOLETE] Lock User Management (LUM)

You need to look for Dark Blue INFO messages, those are confirmation back from the lock that the programming is complete (in Live Logging). If you don’t see then you lock isn’t able to communicate with the hub. Try repairing it and starting over until you can see those blue INFO messages show up (which indicated a response from the lock)

###Multi User Lock Code Management with Notifications and Actions - Version 5.2.5

  • Fix for bug individual user lock selection does not work if the locks have custom names defined in the system

Recommend use the [Universal Enhanced Z-Wave Lock] ([RELEASE] Universal Enhanced Z-Wave Lock Driver for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung) device handler version 3.0.1 or newer for full SmartApp functionality

Thanks to DnCCrew for this step:

Set the hub Location (i.e timezone) for scheduled/expiry codes to work correctly, from smartphone app:

  1. Clicked on the 3 lines (top right corner)
  1. Clicked on gear icon (top right)
  2. Click area that says “Tap to set where home is on the map” and zoom in to correct location on map.

I got it to work. Not sure what exactly helped of unplugging the hub and unplugging the lock.

BUT I found out that the lock only takes 2 codes, a master code and a 2nd “service code”.
In your app, the 1st user is the master code, so that user1 will overwrite the mastercode.
The 2nd user will be the “service code”.
And then there are now more users in the lock, which is at least why I couldn’t get my 3rd test user to work.

Works great :slight_smile:

The lock can autolock after 3 seconds, and I cannot change the number of seconds on the lock.
But in your smartapp I see same function, but where I can set the number of seconds.
I wanna try that out.

BUT 2-4 months when considering a smart lock, I believe I read somewhere in this forum that some people recommended using the locks own autolock, and not rely on smartthings to do it.
Do you have any thoughts on that?

That’s correct IDlock only allows for 2 keypad codes, master and service which correspond to User 1 and User 2 in the SmartApp.
However do note that the RFID codes are also reported by the lock, while they can’t be programmed by the SmartApp it can report on it. So if you enter say User 3 information and then use a RFID key which is programmed to RFID user 3 it will show up on the SmartApp notifications. Do note that RFID has user 1 and so does the master code (keypad user 1), Similarly RFID user 2 and service code (keypad user 2). But since the App can only accept 1 one name for user 1 and 2 you will get a notification like Lock unlocked by User Name (as written in smart app) via Keypad or RFID (depending up on the source). So if you’re using RFID keys I would start programming at User 3 to avoid this issue OR you can install this separate app to get notification/take actions for the RFID users.

The above SmartApp is identical to this SmartApp except it doesn’t program codes. So you can use this SmartApp to program you keypad master/services codes and the above SmartApp to manage your RFID users. That way you have no conflict and can use the full range of the locks’ capabilities.
Alternative if you want just one app use this app and start your RFID codes at User 3 (just note that it can’t be programmed from the SmartApp and I would set the type to inactive for the RFID uesrs (3 and beyond) otherwise the SmartApp will keep trying to program the lock and the lock won’t respond).

This is true to some extent because of ST’s less than perfect scheduler and z-wave network issues the lock based auto lock is more reliable. However the downside is that you can’t coordinate with door sensors which the SmartApp can do (e…g don’t autolock while door is open etc).

I missed the note stating that multiple devices cannot be configured. I thought if you installed and configured it one place, settings would show on all devices with the smartthings app. The thing has been adding and removing codes from my lock for about 4 hours. Can anyone help? I get a push notification to my phone about once every 30 seconds. Ugh.

I removed all but 3 lines of code and re-published it. Finally it stopped sending notifications to every member of my household. Literally hundreds (probably over 500) push notifications were sent to each device. I still cannot remove the smart app. I have removed its association with the device in the mobile app, and tried removing it from the mobile app under marketplace->my apps, but it is still there. I have tried in the IDE about 30 times, and it says it cannot be removed because one or more users has it installed. I removed the SmartThings app from my mobile device completely, still same stuff.

Any advice on cleanup? I changed the device handler back to what I believe is the default one, but that also did not help. Thanks in advance.

Okay, once I went to the mobile app, and then Automations->SmartApps tab, clicked the app, and remove, it removed it from the mobile app completely. Why this does not work from the other 3 or 4 places in the app, I don’t understand, but apparently, this is the procedure.

Sound like you’re having trouble with your account. These are all questions for ST support as to why you’re having trouble configuring or deleting the SmartApp from the phone on your ST hub account. It isn’t normal, it works fine here.

As for the constant retrying that indicates that your lock isn’t responding properly to your hub/commands. I would start by rebooting the hub and repairing the z-wave network (see the first post FAQ’s). And if you don’t want it to retry a failed command (ie. lock not acknowledge as successful command) then turn off the rety option on the first page.

As for the notifications just turn off the notifications (or “detailed notifications” on the first page as I suspect in your case you’ve enabled which is why you’re getting for programming success and failure) and you won’t get any notifications or extra programming notifications (see the description for each option in the SmartApp, there is a paragraph for each option). The detailed notifications is under “Advanced Code Programming Options” and has a paragraph explaining it’s use and is disabled by default so I’m assuming you had a reason to enable it. It is typically enabled by folks using rental homes to be notified when the reprogramming of the lock codes are complete.

Having a hard time with this. This code used to work great, and then a while ago it started giving me errors. I updated to the latest version today. No codes are being pushed to the device anymore which has been going on for a while now. This is what is happening:

java.lang.IllegalArgumentException: Command ‘updateCodes’ is not supported by device c948491c-75b9-47a2-87c5-800c3213f050 of type ‘Lock Capability’. Supported commands: [lock, unlock] @ line 1350

Line 1350 is: lock.updateCodes(userCodes)

Any idea what the issue is? All I’ve done is copy/pasted the code and gone through the simulator to set it up.

You’re using an unsupported lock/DH. This isn’t a Smartapp issue it’s a Lock/Device Handler issue. If it was working earlier and stopped now then this indicates that you/someone changed the device handler for your lock. The DH is the one reporting that that updateCodes isn’t supported, not the SmartApp. Did you change your DH or put a new lock (Zigbee?). Make sure you’re using the recommended Enhanced Universal Z-Wave Lock DH for full compatibility.

I have two Kwikset 910 Z-Wave SmartCode Electronic Deadbolt featuring SmartKey in Lifetime Polished Brass locks.

They were working fine without a device handler. I did add the DH Universal Z-Wave Lock with Yale/Schlage/Kwikset/IDLock Alarm, Notification and Advanced Features
today. But it didn’t change anything with with error.

Any help is appreciated!

I just got it working. I think. 250 miles from the location gives some unknown. Before it would work fine just through the smart things website using the simulator but using the phone app would error. Now the phone app doesn’t error but the website does. I’ll just try the other if this happens again.

I had removed the app last night. I was finally successful in removing it. There are a lot of “Remove” hyperlinks in the mobile app which do not seem to remove the app, such as in the smart apps associated with the lock, and in Marketplace->SmartApps->MyApps.

Since I am managing a small number of users, and only 1 lock currently, I am going to try the simpler app you have with my lock. This will save me from standing in front of my door programming it manually, but will do what I need. I’ll use your handler with alerting.

FYI; Marketplace is only for adding something new (device or SmartApp), so when you go to Marketplace->SmartApps->MyApps and select a SmartApp you are creating a new instance of the SmartApp. When you go into there and hit Remove, you are removing the new instance you just created, not the previously existing SmartApp.

The proper place to access exitsing SmartApps in the mobile app is under Routines->SmartApps.

Going into the SmartApp from an associated device should have worked for you to remove it, however.

1 Like

Then I think they should remove the “Remove” link if it does not remove anything. Just one opinion.

I removed it from the Automations->SmartApps tab, which did do the trick. Thanks for taking the time to reply.

That remove link does remove the new SmartApp instance, so it is functional, but quite confusing.

1 Like

Please send a note to ST support (support@smartthings.com), ST is not monitoring this thread for any feedback. This is only for the SmartApp.

That’s the correct place to configure/modify and remove apps :slight_smile:

My hub/lock are at a remote property so it’s time consuming for me to test/troubleshoot.

I went out there this weekend and removed the lock and re-added it. I also moved the hub closer to the lock. I think the combination of this fixed my issue, but will still need to test more.

I also thought about an issue I had a while back and have not tested it recently. When I tried setting a code where the user name had a / in the name…for example user name: “John 10/3/16” code: 1234 the code would appear to set, but the lock would not program it so it wouldn’t work. Is this a known issue? Is this fixed now?

1 Like

It’s as known an issue as what you just fixed. There’s a difference between telling the lock to set the code and the lock acknowledging it. The hub can keep telling the lock all day but if the lock can’t communicate effectively with the hub it’ll have problems acknowledging it. So what you just did will fix that problem. See the first post, move it closer or better yet add a few active repeaters around the house to make a STRONG mesh network. Then reboot the hub and repair the z-wave network and you won’t have any problems.

Hey Rboy, I posted last month about Expire On codes no longer working. You suggested a few things and I finally had time to implement them. I completely wiped my hub and put it on a new account. I installed the latest version of the smart app and the device handler. I moved the hub to within 10 feet of the lock and added some additional z-wave devices to strengthen the mesh. Signal strength is no longer a problem, nor is legacy code.

Unfortunately, Expire On codes still do not work. They simply are not being pushed to the lock at the time they are supposed to, five minutes later, or even fifteen minutes later. Live logging shows that the code activation is not being sent, although it does show the scheduler is working to inactivate the code at expiration time. Yes, housekeeping is working.

I see another user is having the same issue. It seems that you are insistent that the problem lies with ST scheduler dying. That’s fine, but your housekeeping script is not solving the problem. I believe you should either find the true issue and fix it or stop advertising scheduled codes as a feature until it’s fixed.

I’ve spent way too many hours troubleshooting this while you insist that it’s a problem with my equipment or ST while not acknowledging it could be a bug you’re overlooking. Please, please take another look. I really need this feature to work, it’s actually the only reason I bought the app. Thanks.