[OBSOLETE] Lock User Management (LUM)

Got it. I didn’t realize that just simply enabling user specific options disabled all lock specific options until I started skimming through the code trying to figure out why my lights weren’t being turned on from unlocking. So I just need to specify the door specific options for each user.

It’s possible I missed that in the documentation, but if it’s not in there it might not hurt to add it.

It’s there…

Right, I guess I assumed that general lock/unlock actions didn’t include lock-specific actions. Anyways, it doesn’t matter to me, just wanted to mention it in case other people had the same misunderstanding. Keep up the good work!

1 Like

Got it thanks for the specific feedback will update the description.


I placed a ticket but of course they blamed your app. I think it’s my address book still as i don’t see “Push”

Yes that’s correct. Apparently @jbrown “account” just fixed itself. Did you try adding the email address of the individuals to the contact address book? That’s the only thing I have heard would prevent push notifications from working in some cases.

Interestingly you can point out to support that’s @jbrown notifications stopped working and then just started working byitself. I’d love to hear their explanation :slight_smile:

Yes, my email is in there as well.

I think it’s going to be just like everything else. If it doesn’t work…just wait a bit, that will change. If it does work…just wait a bit, that will also change!

1 Like

I asked them to check logs again and this is what I got:


1 Like

Great, I would love to know from “Annie” why she blamed the app…

@Aaron maybe a little educating ST support staff wouldn’t hurt, debug before pointing fingers.

It seams that the lock code AP runs down the battery on my kwickset lock 914 very fast I replaced the battery’s 2 weeks ago and they are already down to 60 % prior it would last 5 month or more , no increase in use an d I do have the incremental feature enabled.

Suggestion on what to look for?

If you have the incremental feature enabled then it isn’t the app(as it won’t retry). Try few basics, reset the lock, reboot the hub and repair the z wave network. Do you have active repeaters in your network? What type of battery are you using?

Couple things:

  1. Please DM me the support ticket number so I can look at the conversation.
  2. I am not aware of any notification issues that were occurring platform side. I also cannot tell from the snippet of conversation if her concern was with our Contact Book capabilities or the SmartApp itself.
  3. If you were using our Contact Book feature, this was a beta that released to some customers and never pulled. It is prone to failures - especially because it is untested with most first party (let alone custom) SmartApps. If you would like, we can pull it from your account.
  4. We (SmartThings) needs to do a better job with tools, guardrails, etc for third party developers (so we don’t just assume bad code). We are aware of this and working to get there.
1 Like

Was a beta or it still is a beta? Has it been abandoned and most likely will never make it to production?

1 Like

Never say never… But I don’t have a timeline, etc to announce

1 Like

I’m having a similar issue as @jbrown from 5 days ago, with ‘Click here to define actions when the user locks/unlocks the door successfully’. The page loads the red ‘Unexpected Error’, with nothing else available. This has been going on for a little over a week (since update), and have also tried rebooting the hub, re-installing the app, etc. Everything else in the app seems to work as it should.

I’m running two instances of this app for different doors- the one which I did not uninstall is still firing off events though no way to edit them. Looking at the live logging when trying to open that page, there are no errors but I’m getting this trace: Passed from submitOnChange, atomicState lookup for user, which I haven’t seen on other events.

Any suggestions?

Check your routines. Do you have Ghost routines? Routines you don’t recognize which are empty? Three people have reported this in the last week which is causing apps to break and there is no response from ST on why there are ghost routines.

So there were two ghost smartapps instances called ‘Routine Director’ by @tslagle13, installed one week ago (not by me)… I got the same ‘unexpected error’ trying to access those. I manually added the code for the ‘Routine Director’ SmartApp then deleted everything, but still getting errors on the Lock Code Management app.

I fired up the simulator for the Lock multi user code management with notifications and automatic relock app, when I install it on either door lock (Schlage 469), and try to access the ‘Click here to define actions when the user locks/unlocks the door successfully’ page, I get this: error java.lang.IllegalArgumentException: Command ‘size’ is not supported by device [hidden] of type ‘Universal Z-Wave Lock With Alarms’. Supported commands: [poll, lock, unlock, refresh, lock, unlock, updateCodes, setCode, deleteCode, requestCode, reloadAllCodes, unlockwtimeout, alarmToggle, setAlarm, sensitiveToggle, setSensitivity, disableKeypad, enableKeypad, enableAutolock, disableAutolock, disableAudio, enableAudio] @ line 246

FYI I removed the device address and replaced with [hidden] in text. Would this error be specific to the simulator?

Yes that problem is for the simulator don’t use the simulator it behaves differently and is buggy and hence the error, use the real stuff. See my PM I’ve sent you to get to the bottom of the ghost routines (not Ghost SmartApps).

###Multi User Lock Code Management with Notifications and Actions - Version 5.2.4

  • Patch for ST’s “ghost” routines causing some users to get an error while trying to access the actions page

Recommend use the [Universal Enhanced Z-Wave Lock] ([RELEASE] Universal Enhanced Z-Wave Lock Driver for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung) device handler version 3.0.1 or newer for full SmartApp functionality

Thanks to DnCCrew for this step:

Set the hub Location (i.e timezone) for scheduled/expiry codes to work correctly, from smartphone app:

  1. Clicked on the 3 lines (top right corner)
  1. Clicked on gear icon (top right)
  2. Click area that says “Tap to set where home is on the map” and zoom in to correct location on map.


I just got my ID Lock today, and installed it.
Really loving it so far :slight_smile:
I’m using your DH for Smart Locks, and this SmartApp.

But right after installing it, I didn’t connect it to either SmartThings nor it’s own remote.
I set up the basics first, like changing the master code, I put in another code for my wife, added a couple RFIDs, enabled autolock after 3 seconds.

When that all worked, I took out batteries, added z-wave module, added batteries, included in ST, using your DH.
And installed this SmartApp.
I put in 3 users:

  • Me (same code as master code)
  • My wife (same code as I already programmed)
  • A test user/code

The Live log for the device says:

  1. code1 was null, set to 1234
  2. setting code 1 to 1234
    And the same for the 2 other codes.


  1. the test user code doesn’t work. I need to troubleshoot, but as the Live Log shows it should be set I guess I should have been set or what?
  2. The z-wave modue instructions mention different commands in secure and unsecure mode. See this like
    So I was wondering if I need to make sure that my device is securely connected, if that is even under my control.

About the feature for running a routine, when unlocked: I like that, BUT should there be an option to say “only if I’m the first to arrive”? Because if I’m at home already, and messing arround with music and lights, and wife gets home, I dont what the “I’m back” rutine to be triggered again.