[OBSOLETE] Lock User Management (LUM)

Since the latest update to the hub, iOS app and your app my lock no longer immediately locks upon detection of the sensor closing. This is an important feature for me as the family never remembers to lock the door upon exit. Any suggestions? I have installed pollster to poll the lock and door every 5 minutes but this just seems to drain the lock batteries and do nothing else.

All I can suggest is reboot your hub and do a z-wave repair and likely that will fix the issue. If that doesn’t work please report it to ST support, can’t really do anything from your end. Why poll the lock? That really won’t help, this is a event driven architecture, polling like you said will only serve to reduce the battery life. Polling should only be used where events aren’t coming through or don’t exist (e.g. weather devices)

This is a problem with you ST account scheduler dying. NOTE that it takes up to 5 minutes for the code to be updated due to the way ST scheduler works. There is also a backup built into the app to detect a dead scheduler but that runs every 10 minutes. So I would wait for upto 15 mintues for the codes to be updated on the lock. You can also verify the same by looking at the Live Logging and you should see housekeeping activities run every 5 minutes and 15 minutes if your scheduler has died.

I thought so as well.

After testing both locks (while I was there, I am back home now), this is the test I did:

  1. Programmed “Expire on” codes for both locks using your app. I set both Expire on codes to begin one hour from the start of the test, and to end three hours after that.
  2. Waited for an hour and thirty minutes.
  3. Tried code that should have been entered, didn’t work on either lock (units are beside each other).
  4. Went back into the code for the first unit, hit “Done” again as though I had changed something. As soon as I tried the code on the first unit, the door unlocked immediately. I tried the 2nd door, and the code wasn’t working.
  5. I went into the app for the 2nd door, and did the “done” thing, and it too worked immediately.

I’m not sure if this is related to the whole “must hit done to register the input” like with the codes where it doesn’t take unless you hit “done” on the keypad in addition to the “done” in the top right corner.

Anytime you change codes or any settings like expiry dates etc you need to go through the pages and click done on the last page. Don’t go back or exit the app otherwise it won’t program the codes. Beyond that if the expiration does kick in then the scheduler is dying or there is a communication issue with the lock and hub. But if you’re saying when you go in and hit done and it works then your scheduler is dying.

I’m having the same non-locking issue as Mstolli. I’ve restarted everything, repaired, etc. Running latest release of device handler and smartapp.

Here’s what I think is the pertinent log:

1:33:35 PM: debug "zw device: 26, command: 9881, payload: 00 22 01 00 00 " parsed to [‘displayed’:true, ‘descriptionText’:GR Side Lock is busy, try again later, ‘isStateChange’:false, ‘linkText’:‘GR Side Lock’]

Looks like your lock and hub are having communication issues. Unfortunately ST hub does not retry failed or blocked commands. Please report to ST support. Don’t know if it’s anything to do with the recent firmware update for the hub. Try rebooting your lock. That worked for one user (remove battery and reinsert)

I’ll try the battery pull. ST and the lock do seem to be talking just fine (watching the logs). Almost instant when locking, unlocking, etc…

On a side note, it does lock, eventually…

1 Like

That’s great news, it looks like ST may have implemented retry on blocked/busy communication in some recent firmware updates. :slight_smile:

We’ve put these on our feature queue, thanks for the suggestions.

“Rebooting” the lock didn’t change anything. However, setting the app to lock after one minute (instead of instantly) works every time. Perhaps we can set it less than a minute in a future release?

That means your zwave network is problematic. It’s a communication issue with your mesh. Shorter response times need a stronger mesh. You may need more active devices on your network. If you have a few active devices then I would suggest contact ST support to find out why your mesh has trouble.

I’m having the same issue, where the lock doesn’t work consistently(Lock immediately, Schlage). I’ve updated the smarttapps, device handlers and batteries for the devices. Reading comments I do think ST might have some issues that are affecting how the smartapp work. I’ll ask them tomorrow. If you @Rboy want any logs let me know. I know you’ve done everything on your end except writing the ST HUB code for them at this point. Just offering logs if you want.

Thanks for your support.

This question has been asked every few days and I’ve tried to put the FAQ in the first post. Immediate auto lock puts a strain on the mesh. If you have a weak mesh or communication issue between the lock and hub it won’t work properly. You need lots of active devices to create a strong mesh. Also reboot your hub and do a z wave repair. 99% of the time this solves all your issues.

We have also noticed that the v2 hub tends to have a better mesh than the v1 hub.

My door is 5 feet from my hub. I’ll report back after hub reboot, network repairs. Us old timers might not start at the top of the Thread anymore, you might want to force us to look at the FAQ on the your smartapps page or make it part of your signature. I go there first next time. Again thank you for the great additions and support for your app/device handlers. At least I’m not longer having any issues with the Blink Cameras. :slight_smile:

1 Like


I’m not sure what you mean by “your scheduler is dying”. These are brand new locks…

Or is it something I can actively fix?

That’s actually no guarantee that you don’t have RF interference or issues. One user about 6-8 months has a similar issue, he put this hub in the same room as the lock but the auto lock worked on part of the time, turned out reflections were causing the issue, when he moved the hub into another room and added an active switch (repeater) it started working. you’re dealing with a RF mesh here, you’ll have to go through trial and error to create a active/strong redundant mesh.

PS in our labs which spans 3 floors we have setup 9 repeaters (active switches) and it took a while to get that “strong” mesh. Even then depending upon hub firmware updates and hub status we get minor issues and have to do a hub reboot or z-wave repair. Again follow through the posts and you’ll see what users have done to fix their network issues.

A quick question in regards to lock / unlock notifications…following up quite late on this admittedly.

It seems that these notifications quit working right around the time ST introduced “My Contacts”

I’ve been away fom the forums and I’m sure there’s something I missed.

v5.2.3 and newest DTH

If your account “supports” the contact address book feature you will need to go back into the app and select the notifications options and select the users for whom you want notifications (mobile, push etc).
However do note, that are bugs in ST’s contact address book and if you still aren’t getting them after selecting the names then contact ST support.

EDIT: Also double check that you notifications for the ST app has been enabled/turned on in your phone. Had a few folks who forgot they had turned them off. :slight_smile:

I still get mode change notifications but quit getting door notifications once the address book feature was integrated to the app. I figured it was a support things and have already thrown a ticket into the abyss lol.

1 Like

Did you open the SmartApp and reconfigure your notifications, if you’ve moved to Contract Address book you need to go in and setup the notifications, it’s won’t push it to all automatically and now it’s per user/contact.